You are not logged in.

#1 2006-03-15 12:04:55

Registered: 2006-02-06
Posts: 208

sblive problems

Hi all,

I am trying to get an SBLive soundcard which I have recently installed to work.  I have a Gigabyte motherboard (NForce4) with onboard sound (AC97) which I have disabled.  The SBLive has been used by me in another machine and works fine.

All the correct modules seem to load:

$ lsmod | grep snd
snd_seq_oss            33408  0
snd_seq_midi_event      6400  1 snd_seq_oss
snd_seq                51984  4 snd_seq_oss,snd_seq_midi_event
snd_pcm_oss            50848  0
snd_mixer_oss          17920  1 snd_pcm_oss
snd_emu10k1           121892  0
snd_rawmidi            21152  1 snd_emu10k1
snd_ac97_codec         95136  1 snd_emu10k1
snd_ac97_bus            2176  1 snd_ac97_codec
snd_pcm                84100  3 snd_pcm_oss,snd_emu10k1,snd_ac97_codec
snd_seq_device          7436  4 snd_seq_oss,snd_seq,snd_emu10k1,snd_rawmidi
snd_timer              22148  3 snd_seq,snd_emu10k1,snd_pcm
snd_page_alloc          8840  2 snd_emu10k1,snd_pcm
snd_util_mem            3840  1 snd_emu10k1
snd_hwdep               7712  1 snd_emu10k1
snd                    49124  11 snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,
soundcore               8160  1 snd

But there is nothing in /proc:

$ cat /proc/asound/cards
--- no soundcards ---

Alsamixer bombs out with a unsurprising (in light of above) error:

$ alsamixer

alsamixer: function snd_ctl_open failed for default: No such device

lspci shows the device:

$ /usr/sbin/lspci -v | grep -i audio
01:07.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 05)

The wierd thing is that when I first installed it, I got these same sort of errors and symptoms, but then I updated the system with pacman, getting the latest udev (087-1) and kernel (, after which I rebooted, and got sound!  There was a /proc/asound/card0 entry, tested xmms and Doom3, all was fine.  But a subsequent reboot resulted in the above symptoms again, and I have rebooted about 3 or 4 times since then (just in case!), but with no joy.

I have tried running /etc/start_udev with no result.  I have also tried both forcing snd_emu10k1 in /etc/rc.conf, and disabling it and manually loading it later.

I was wondering if there is something basic I am neglecting?

Any ideas anyone?

Thanks in advance,



#2 2006-03-15 20:20:21

Registered: 2006-02-06
Posts: 208

Re: sblive problems

Hi all,

I've managed to nail this one (I hope - I'll be checking /proc/asound/cards for several reboots now!)

A recurring entry in /var/log/kernel.log aroused my suspicion:

Mar 15 16:12:22 aquilonia ACPI: PCI interrupt for device 0000:01:07.0 disabled
Mar 15 16:12:22 aquilonia EMU10K1_Audigy: probe of 0000:01:07.0 failed with error -5

Which prompted me to move the soundcard to another PCI slot.  Now when I `cat /proc/asound/cards`, I get:

0 [Live           ]: EMU10K1 - SBLive! Platinum [CT4760P]
                     SBLive! Platinum [CT4760P] (rev.5, serial:0x80401102) at 0xc000, irq 17

Sound now works (xmms is streaming from WickedKarma as I type 8) ), and it's survived two reboots so far!

I hope this helps anyone else who has a similar issue.




Board footer

Powered by FluxBB