You are not logged in.

#1 2015-05-06 09:50:11

sakuya16
Member
Registered: 2015-05-06
Posts: 3

[SOLVED] Error with Wickr deb package

Hi people, I was trying to running wickr on Arch Linux. (I am under Gnome), I used debtap utility, attempted to convert wickr deb package to work with pacman but failed with this dependency:

warning: cannot resolve "libavutil52|libavutil54", a dependency of "wickr"
:: The following package cannot be upgraded due to unresolvable dependencies:

error: failed to prepare transaction (could not satisfy dependencies)
:: wickr: requires libavutil52|libavutil54


I am pretty sure I have already got the libavutil-52 installed and does not help. I even managed to convert libavutil54 from debian and installed but still no progress.

Any help? thx in advance.

Last edited by sakuya16 (2015-05-06 11:06:50)

Offline

#2 2015-05-06 10:18:31

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

Re: [SOLVED] Error with Wickr deb package

"libavutil52|libavutil54" is meaningless to pacman - obviously, that debtap thing is not perfect, so you'll need to get your hands dirty.

libavutil.so.54 is provided by the current ffmpeg package, so that might work for you.

Offline

#3 2015-05-06 10:22:27

mauritiusdadd
Member
From: Benevento, Italy
Registered: 2013-10-27
Posts: 776

Re: [SOLVED] Error with Wickr deb package

Hi sakuya16,

the | character does not work as logical or inside the PKGBUILD, depends is an array of strings separated by withe spaces. Also you must specify only one version of libavutil and its name is libavutil-52 and not  libavutil52. For more information read the wiki https://wiki.archlinux.org/index.php/PKGBUILD#depends

--edit:

Yeah, tomk is right, try to see if it works with the current libavutil.so.54 first.

Last edited by mauritiusdadd (2015-05-06 10:42:02)


registered linux user #588260github

-- When you have eliminated the impossible, whatever remains, however improbable, must be the truth -- Spock | Sherlock Holmes

Offline

#4 2015-05-06 10:25:09

sakuya16
Member
Registered: 2015-05-06
Posts: 3

Re: [SOLVED] Error with Wickr deb package

I got ffmpeg installed, but actually no help. I doubt wickr Inc. will pay any attention to a situation as such, they just build a Ubuntu version software. Currently I am running wickr windows version with wine, which is pretty ridiculous though. We have a deb Linux version package but still have to rely on wine.

I am still tweaking it, and listening to any advice.

Last edited by sakuya16 (2015-05-06 10:26:08)

Offline

#5 2015-05-06 10:34:09

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

Re: [SOLVED] Error with Wickr deb package

sakuya16 wrote:

I got ffmpeg installed, but actually no help.

And how do you expect anyone to respond to that?

What about some actual error messages? Did you try creating a PKGBUILD manually, as I suggested? What twaking are you doing exactly?

Offline

#6 2015-05-06 10:57:53

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 26,900
Website

Re: [SOLVED] Error with Wickr deb package

The error was never that wickr was failing due to a missing dependency - pacman just couldn't find anything to satisfy a dependency with a ridiculous name with a pipe in the middle.  Fix the ridiculous name with the pipe in the middle and you should be all set.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#7 2015-05-06 11:05:28

sakuya16
Member
Registered: 2015-05-06
Posts: 3

Re: [SOLVED] Error with Wickr deb package

Anyway, just got it boot.

It seems that edit PKGBUILD file while using debtap and remove "libavutil52|libavutil54" line works. Although it does not necssarily means all functions of the package works, but at least it boots.

Thx all above for help smile

Last edited by sakuya16 (2015-05-06 11:05:50)

Offline

#8 2015-05-06 11:12:58

helix
Member
Registered: 2013-02-17
Posts: 177

Re: [SOLVED] Error with Wickr deb package

Glad it helped

Offline

Board footer

Powered by FluxBB