You are not logged in.

#1 2015-05-11 22:22:12

ttoirrah
Member
Registered: 2015-01-29
Posts: 16

reverting from 8192cu-dkms

My TP-Link TL-WN822N could be investigated with:

sudo iw dev wlp0s2f1u5 scan

when it was giving me the internet with:

su <pw>
wpa_passphrase Livebox-acf8_EXT <my-wp(WPA2-PSK)passphrase> >> /etc/wpa_supplicant/Lacf8E.conf
wpa_supplicant -D nl80211 -i wlp0s2f1u5 -c /etc/wpa_supplicant/Lacf8E.conf

But it was losing it's connection regularly (to my Netgear WN3000RP), as it did in Linux Mint 17 Xfce, so I decided to try runnytu's 8192cu-dkms.  With it still plugged in, I did:

cower -d 8192cu-dkms && cd 8192cu-dkms
makepkg -s
sudo pacmatic -U 8192cu-dkms-v4.0.2_9000-8-any.pkg.tar.xz

- which gave an error:

modprobe: ERROR: could not insert '8192cu': Device or resource busy

So I Unplugged the TL-WN822N, Rebooted my system, and:

sudo pacmatic -Rc 8192cu-dkms
sudo pacmatic -U 8192cu-dkms-v4.0.2_9000-8-any.pkg.tar.xz

- which seemed to've worked, but the device's name had weirdly changed:

ip link
6: enp0s2f1u5: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
  link/ether e8:de:27:07:34:70 brd ff:ff:ff:ff:ff:ff

- and it wouldn't connect:

wpa_supplicant -D nl80211 -i enp0s2f1u5 -c /etc/wpa_supplicant/Lacf8E.conf
  Successfully initialized wpa_supplicant
  nl80211: Driver does not support authentication/association or connect commands
  enp0s2f1u5: Failed to initialize driver interface

So I gave up, Unplugged it, Rebooted, Uninstalled 8192cu-dkms (again), Rebooted, plugged it back in, and I can get it to scan again, but it just won't connect to anything at all.  I've tried:

sudo dkms install rtl8192cu --all

- no change.  Any idea how I can get it back to it's original working (though regularly dropping the connection) state?

Offline

Board footer

Powered by FluxBB