You are not logged in.

#1 2015-05-15 09:43:01

Registered: 2013-05-19
Posts: 46

[SOLVED] X / gdm not starting; using catalyst

I have been running catalyst and X quite nicely until two days ago. On booting the computer X and therefore gdm for gnome no longer starts. The gdm.service was enabled  but my computer screen just went blank and I couldn't access any other ttys. I chrooted into disable gdm and now it will boot to the tty and I can at least work from the command line. However it is my home computer and my wife is not pleased; despite my best efforts to convince her to use vim, ranger, cmus, imagemagick and lynx, she didn't buy it wink

I have downgraded Xorg to 1.16. I installed xorg-xinit and I was able to start X in the minimum environment as per the Xorg wiki page. I was then hopeful that I could get X working at least, I changed .xinitrc to execute gnome but it just flashed me back to the terminal. I have reinstalled gnome and updated all the packages on the system (barring the downgraded xorg packages) but still no luck, what should I do next?

[EDIT] I have installed xfce4 which starts through startx so I think it is something wrong with my gnome...

[EDIt #2 - solution] I reinstalled catalyst and made sure to enable catalyst-hook before rebooting. And I could then start X and gnome again.

Probably unrelated but I see a lot of messages in my booting messages that I have not seen before;

[  OK  ] Created slice user-120.slice
         Starting User Manager for UID 120...
[  OK  ] Started User Manager for UID 120.
         Stopping User Manager for UID 120...
[  OK  ] Stopped User Manager for UID 120.
[  OK  ] Removed slice user-120.slice

Which is repeated again and again.

Last edited by cdrjameson (2015-05-15 13:17:39)


Board footer

Powered by FluxBB