You are not logged in.

#1 2006-03-17 10:39:20

brazzmonkey
Member
From: between keyboard and chair
Registered: 2006-03-16
Posts: 818
Website

kde lags when applications are launched [SOLVED]

hi there,
i'm new to archlinux. i've been using gentoo for a while but got tired with all its compilation stuff.

so i tried arch and basically liked it. well, i find this distro reasonably fast (the fastest i ever tried was yoper - i'm eager to test the coming v3), and i like pacman too.

i installed kde and whenever i launch an application, the system lags. i mean,  everything freezes for 1 sec or so. this is quite annoying... i switched to archck kernel, but didn't notice any improvement.

DMA's on though i'm not entirely sure it works properly (my system is supposed to support UDMA66, but hdparm only detects my disk to support UDMA33). i don't think it has to do withh disk acces though. to me it sounds more like launching an app is too cpu-intensive - but i'm probably wrong.

thanks for any help !


what goes up must come down

Offline

#2 2006-03-17 22:30:31

brazzmonkey
Member
From: between keyboard and chair
Registered: 2006-03-16
Posts: 818
Website

Re: kde lags when applications are launched [SOLVED]

no ideas ?

i'm currently discussing this issues on the french forums, and it looks like it's related to kde 3.5.1...

not sure, though.


what goes up must come down

Offline

#3 2006-03-18 15:21:57

jaboua
Member
Registered: 2005-11-05
Posts: 634

Re: kde lags when applications are launched [SOLVED]

Try having "top" open in a terminal when launching something, maybe you can see any specific process using a lot of CPU time? Also, try turning off startup notifications (the mouse pointer and the sound effect) and see if it makes any difference.

Offline

#4 2006-03-18 23:17:12

brazzmonkey
Member
From: between keyboard and chair
Registered: 2006-03-16
Posts: 818
Website

Re: kde lags when applications are launched [SOLVED]

ok, i got it sorted out through the french forums : some stuff in xorg.conf was a bit optimistic...
i had composite and render stuff enabled, a bit too much for my old video card (geforce2).

thanks anyway for trying to help jaboua, much appreciated !


what goes up must come down

Offline

#5 2006-06-15 12:40:33

brazzmonkey
Member
From: between keyboard and chair
Registered: 2006-03-16
Posts: 818
Website

Re: kde lags when applications are launched [SOLVED]

actually, arts was the culprit


what goes up must come down

Offline

#6 2006-06-15 16:06:20

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: kde lags when applications are launched [SOLVED]

aRTs sucks as a rule, it's really better to turn it off and let ALSA do the software mixing in most cases.

Offline

#7 2006-06-16 11:02:31

brazzmonkey
Member
From: between keyboard and chair
Registered: 2006-03-16
Posts: 818
Website

Re: kde lags when applications are launched [SOLVED]

Gullible Jones wrote:

aRTs sucks as a rule, it's really better to turn it off and let ALSA do the software mixing in most cases.

yeah i know that, but i never had any problems with it before...


what goes up must come down

Offline

#8 2006-06-20 09:10:13

brazzmonkey
Member
From: between keyboard and chair
Registered: 2006-03-16
Posts: 818
Website

Re: kde lags when applications are launched [SOLVED]

funny, i upgraded to kernel26-beyond, and this happens again... whereas it works fine with arch stock kernel...

this sounds like a latency problem... i'll stick with standard kernel26 then...


what goes up must come down

Offline

Board footer

Powered by FluxBB