You are not logged in.

#1 2015-05-25 10:06:30

gen2arch
Member
Registered: 2013-05-16
Posts: 119

SOLVED: No more Emacs due to segfault/coredump during compilation

Hi

I used to compile emacs on Arch from the official git sources on savannah:
git clone -b master git://git.sv.gnu.org/emacs.git
Yet since recently this no longer works as a segfault/coredump happens during compilation:

Loading /home/user/git/emacs/lisp/tooltip.el (source)...
Finding pointers to doc strings...
Finding pointers to doc strings...done
Dumping under the name emacs
Makefile:700: recipe for target 'bootstrap-emacs' failed
make[2]: *** [bootstrap-emacs] Segmentation fault (core dumped)
make[2]: Leaving directory '/home/user/git/emacs/src'
Makefile:398: recipe for target 'src' failed
make[1]: *** [src] Error 2
make[1]: Leaving directory '/home/user/git/emacs'
Makefile:1091: recipe for target 'bootstrap' failed
make: *** [bootstrap] Error 2
make -j5 bootstrap  653.43s user 16.82s system 271% cpu 4:07.10 total

The same error occurs when using the AUR emacs-git package. This is actually the first time ever that emacs won't compile on linux!

Anyone knows what exactly happens during this "temacs" phase of compilation, when a temporary emacs is build, what can go wrong here?

Also I'm wondering if this is related to changes in the repository or otherwise to some fatal incompatible change on my Arch installation?
Anyone else seeing this, any hints?

Thanks

Last edited by gen2arch (2015-06-06 16:52:23)

Offline

#2 2015-05-30 00:58:48

newnumbertwo
Member
Registered: 2014-10-10
Posts: 4

Re: SOLVED: No more Emacs due to segfault/coredump during compilation

I'm having the same issue.

Offline

#3 2015-05-30 08:37:15

catseye
Member
Registered: 2009-03-09
Posts: 16

Re: SOLVED: No more Emacs due to segfault/coredump during compilation

Hello,

do you happen to have the hardening-wrapper package installed?  That package optimizes the build and linking process in a way the emacs build process doesn't like for some reason. The easiest way to get around this problem is by setting this environment variable either from the command line or by inserting it into your PKGBUILD which builds your emacs package -- this will disable these problematic optimizations.

export HARDENING_PIE=0

If that doesn't help then try to go the hard way by deinstalling the "hardening-wrapper" package before building emacs and reinstall it again after you are done.

Last edited by catseye (2015-05-30 08:39:24)

Offline

#4 2015-06-02 21:27:55

gen2arch
Member
Registered: 2013-05-16
Posts: 119

Re: SOLVED: No more Emacs due to segfault/coredump during compilation

catseye wrote:

do you happen to have the hardening-wrapper package installed?.

catseye, thanks for your reply: actually, not that I know, that is, I didn't install it explicitely; I have to check when I'm back home as I don't have my machine with me right now.

gen2arch

Offline

#5 2015-06-06 16:51:18

gen2arch
Member
Registered: 2013-05-16
Posts: 119

Re: SOLVED: No more Emacs due to segfault/coredump during compilation

catseye wrote:

Hello,do you happen to have the hardening-wrapper package installed?  That package optimizes the build and linking process in a way the emacs build process doesn't like for some reason .

Hi again catseye,

back home I checked my arch installation and indeed: hardening-wrapper is installed as a dependency of another program (I couldn't figure out which one as arch lacks gentoo's equery d), but here is a hint:
https://www.archlinux.org/packages/comm … ng-wrapper.

And your workaround works also: once HARDENING_PIE is set to zero, emacs compiles normally again!

Weird that very few web resources exist on this issue.

Thanks again

gen2arch

Offline

Board footer

Powered by FluxBB