You are not logged in.

#1 2006-03-19 19:31:54

MAC!EK
Member
Registered: 2005-09-27
Posts: 265

mplayer cut's the end of wave files

I use kydpdict ( pol-eng dictionary) and set up mplayer to play audio files.

When I play the pronunciation of "assailant" or "ass"(mayby other too) it won't play the WAV to the end, just finishes playing after letter "A"
Heres the WAV for "assailant":
http://o.dyn.pl/~macieks/arch/001249.WAV

play(program) plays those WAV OK. Amarok also.

Offline

#2 2006-03-20 12:56:03

sebcactus
Member
From: Germany
Registered: 2005-01-27
Posts: 277

Re: mplayer cut's the end of wave files

You should give us the output of mplayer while playing the file

In a terminal:

mplayer MyWavFile.wav

And check also that mplayer uses ALSA.

Offline

#3 2006-03-20 13:49:20

MAC!EK
Member
Registered: 2005-09-27
Posts: 265

Re: mplayer cut's the end of wave files

sorry I forgot about that:

MPlayer 1.0pre7try2-4.0.3 (C) 2000-2005 MPlayer Team
CPU: Advanced Micro Devices Athlon Thunderbird (Family: 6, Stepping: 2)
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled with runtime CPU detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.


/etc/mplayer/font/subfont.ttf doesn't look like a font description, ignoring.
Cannot load font: /etc/mplayer/font/subfont.ttf
Failed to open /dev/rtc: No such file or directory (it should be readable by the user.)
Playing http://o.dyn.pl/~macieks/arch/001249.WAV.
Resolving o.dyn.pl for AF_INET6...
Couldn't resolve name for AF_INET6: o.dyn.pl
Resolving o.dyn.pl for AF_INET...
Connecting to server o.dyn.pl[83.22.92.235]:80 ...
Cache size set to 320 KBytes
Connected to server: o.dyn.pl

Cache fill:  0.00% (0 bytes)    
Cache fill:  2.50% (8192 bytes)    
Cache fill:  2.50% (8192 bytes)    
Cache fill:  2.50% (8192 bytes)    
Cache fill:  5.00% (16384 bytes)    
Cache fill:  7.50% (24576 bytes)    
Cache fill:  7.50% (24576 bytes)    
Cache fill:  7.50% (24576 bytes)    
Cache fill: 10.00% (32768 bytes)    
Cache fill: 10.00% (32768 bytes)    
Cache fill: 11.80% (38650 bytes)    Audio file detected.
==========================================================================
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 22050 Hz, 1 ch, s16le, 352.8 kbit/100.00% (ratio: 44100->44100)
Selected audio codec: [pcm] afm:pcm (Uncompressed PCM)
==========================================================================
Checking audio filter chain for 22050Hz/1ch/s16le -> 22050Hz/2ch/s16le...
AF_pre: 22050Hz/1ch/s16le
alsa-init: 1 soundcard found, using: default
alsa: 22050 Hz/2 channels/4 bpf/30104 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 22050Hz 2ch s16le (2 bps)
Building audio filter chain for 22050Hz/1ch/s16le -> 22050Hz/2ch/s16le...
Video: no video
Starting playback...
A:   0.0 (00.0) ??,?% 0%                                                        
alsa-uninit: pcm closed

Exiting... (End of file)

Is that WAV playing OK on your system?

Offline

#4 2006-03-20 15:02:14

sh__
Member
Registered: 2005-07-19
Posts: 271

Re: mplayer cut's the end of wave files

Plays fine with mplayer-cvs here.

Offline

#5 2006-03-20 18:32:22

sebcactus
Member
From: Germany
Registered: 2005-01-27
Posts: 277

Re: mplayer cut's the end of wave files

Plays fine with mplayer compiled with disable-runtime-cpudetection (took from abs and only changed this)

My output:

MPlayer 1.0pre7try2-4.0.3 (C) 2000-2005 MPlayer Team
CPU: Intel Pentium 4/Xeon/Celeron Foster (Family: 8, Stepping: 9)
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2


Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Playing http://o.dyn.pl/~macieks/arch/001249.WAV.
Resolving proxy.xx.xx for AF_INET6...
Couldn't resolve name for AF_INET6: proxy.xx.xx
Resolving proxy.xx.xx for AF_INET...
Connecting to server proxy.xx.xx[XX.XXX.X.XX]:8080 ...
Cache size set to 320 KBytes
Connected to server: o.dyn.pl
Cache fill: 11.80% (38650 bytes)    Audio file detected.
==========================================================================
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 22050 Hz, 1 ch, s16le, 352.8 kbit/100.00% (ratio: 44100->44100)
Selected audio codec: [pcm] afm:pcm (Uncompressed PCM)
==========================================================================
Checking audio filter chain for 22050Hz/1ch/s16le -> 22050Hz/2ch/s16le...
AF_pre: 22050Hz/1ch/s16le
alsa-init: 1 soundcard found, using: default
alsa: 22050 Hz/2 channels/4 bpf/65536 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 22050Hz 2ch s16le (2 bps)
Building audio filter chain for 22050Hz/1ch/s16le -> 22050Hz/2ch/s16le...
Video: no video
Starting playback...
A:  -0.0 (00.0)  5.3% 0%
alsa-uninit: pcm closed

Exiting... (End of file)

Note the line:

alsa: 22050 Hz/2 channels/4 bpf/65536 bytes buffer/Signed 16 bit Little Endian

The pb must be nearby

Offline

#6 2006-03-20 20:23:29

MAC!EK
Member
Registered: 2005-09-27
Posts: 265

Re: mplayer cut's the end of wave files

after compiling the newest mplayer-cvs from AUR WAV plays OK.

MPlayer dev-CVS-060320-20:52-4.0.3 (C) 2000-2006 MPlayer Team
CPU: Advanced Micro Devices Athlon Thunderbird (Family: 6, Stepping: 2)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx



/etc/mplayer/font/subfont.ttf doesn't look like a font description, ignoring.
Cannot load font: /etc/mplayer/font/subfont.ttf
Failed to open /dev/rtc: No such file or directory (it should be readable by the user.)
Playing 001249.WAV.
Audio file file format detected.
==========================================================================
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 22050 Hz, 1 ch, s16le, 352.8 kbit/100.00% (ratio: 44100->44100)
Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
==========================================================================
alsa-init: using device default
alsa: 48000 Hz/1 channels/2 bpf/32768 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 48000Hz 1ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:  -0.0 (unknown) of 0.9 (00.8) ??,?% [J
A:  -0.0 (unknown) of 0.9 (00.8) ??,?% [J
A:   0.0 (00.0) of 0.9 (00.8) ??,?% [J
A:   0.1 (00.0) of 0.9 (00.8) ??,?% [J
A:   0.1 (00.0) of 0.9 (00.8) ??,?% [J
A:   0.1 (00.0) of 0.9 (00.8) ??,?% [J
A:   0.1 (00.1) of 0.9 (00.8) ??,?% [J
A:   0.1 (00.1) of 0.9 (00.8) ??,?% [J
A:   0.2 (00.1) of 0.9 (00.8) ??,?% [J
A:   0.2 (00.1) of 0.9 (00.8)  1.1% [J
A:   0.2 (00.2) of 0.9 (00.8)  1.1% [J
A:   0.2 (00.2) of 0.9 (00.8)  1.1% [J
A:   0.2 (00.2) of 0.9 (00.8)  1.1% [J
A:   0.3 (00.2) of 0.9 (00.8)  1.1% [J
A:   0.3 (00.2) of 0.9 (00.8)  1.1% [J
A:   0.3 (00.3) of 0.9 (00.8)  1.1% [J
A:   0.3 (00.3) of 0.9 (00.8)  1.1% [J
A:   0.3 (00.3) of 0.9 (00.8)  1.1% [J
A:   0.4 (00.3) of 0.9 (00.8)  1.1% [J
A:   0.4 (00.3) of 0.9 (00.8)  1.1% [J
A:   0.4 (00.4) of 0.9 (00.8)  1.1% [J
A:   0.4 (00.4) of 0.9 (00.8)  1.1% [J
A:   0.5 (00.4) of 0.9 (00.8)  1.1% [J
A:   0.5 (00.4) of 0.9 (00.8)  1.1% [J
A:   0.5 (00.4) of 0.9 (00.8)  1.1% [J
A:   0.5 (00.5) of 0.9 (00.8)  1.1% [J
A:   0.5 (00.5) of 0.9 (00.8)  1.1% [J
alsa-uninit: pcm closed

Exiting... (End of file)

No idea whats the difference but works now.

Offline

#7 2006-03-21 12:47:39

sebcactus
Member
From: Germany
Registered: 2005-01-27
Posts: 277

Re: mplayer cut's the end of wave files

MAC!EK wrote:

after compiling the newest mplayer-cvs from AUR WAV plays OK.
No idea whats the difference but works now.

Did you try the Wav files you tested before? According to your output the file is not the same (44kHz instead of 22kHz sample frequency)

Offline

#8 2006-03-21 19:02:05

MAC!EK
Member
Registered: 2005-09-27
Posts: 265

Re: mplayer cut's the end of wave files

mplayer-cvs:

alsa: 48000 Hz/1 channels/2 bpf/32768 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 48000Hz 1ch s16le (2 bytes per sample)

mplayer stock:

alsa: 22050 Hz/2 channels/4 bpf/30104 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 22050Hz 2ch s16le (2 bps)

For the same WAV file.

Offline

#9 2006-03-23 19:01:48

sebcactus
Member
From: Germany
Registered: 2005-01-27
Posts: 277

Re: mplayer cut's the end of wave files

And mine (stock slightly modified):

alsa: 22050 Hz/2 channels/4 bpf/65536 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 22050Hz 2ch s16le (2 bps) 

It's really weird

Offline

#10 2006-03-23 20:10:04

codemac
Member
From: Cliche Tech Place
Registered: 2005-05-13
Posts: 776
Website

Re: mplayer cut's the end of wave files

why do we enable cpu detection on the mplayer package?  Mplayer even yells at you for compiling it with that option.

Offline

#11 2006-03-24 05:15:41

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: mplayer cut's the end of wave files

codemac wrote:

why do we enable cpu detection on the mplayer package?  Mplayer even yells at you for compiling it with that option.

Because i686 covers a large range of CPUs which uses different CPU flags. Athlons use 3DNow/2 flags while Intel has MMX and/or SSE, etc.  The runtime CPU detection allows the package to work on all i686 processors.  The message that is displayed just means that mplayer takes a fraction of a second more to load because it needs to detect your CPU type.

Feel free to recompile mplayer with --disable-runtime-cpudetection (like I did once), you'll probably won't notice any difference.

Offline

Board footer

Powered by FluxBB