You are not logged in.

#1 2015-06-08 15:58:49

ratcheer
Member
Registered: 2011-10-09
Posts: 776

[SOLVED] How to switch SSD to 6 Gb/s mode?

I have been running a Samsung 850 Pro SSD for several months. I just now noticed that it is in 3 GB/sec transfer mode:

 SATA Version is:  SATA 3.1, 6.0 Gb/s (current: 3.0 Gb/s)

Both of my HDD's are in 6 GB/sec mode. How do I get the SSD to also run in that mode? I am 99% certain that I plugged the SSD into a SATA III port on the motherboard, but I can open the case, if necessary.

Tim

Last edited by ratcheer (2015-06-10 21:58:45)

Offline

#2 2015-06-08 16:05:57

paulkerry
Member
From: Sheffield, UK
Registered: 2014-10-02
Posts: 491

Re: [SOLVED] How to switch SSD to 6 Gb/s mode?

Have you checked to see if there is a bios option for changing the interface speed? There is such an option in my HP ProBook 450 G1 laptop bios.

As a matter of interest, which software did you use to get your output stating the speed?

I normally use

hdparm -I /dev/sda

which shows my Samsung SSD 840 EVO 250GB is running at 6Gb/s

*    Gen1 signaling speed (1.5Gb/s)
*    Gen2 signaling speed (3.0Gb/s)
*    Gen3 signaling speed (6.0Gb/s)

Offline

#3 2015-06-08 16:07:41

ratcheer
Member
Registered: 2011-10-09
Posts: 776

Re: [SOLVED] How to switch SSD to 6 Gb/s mode?

Thanks. I will look at the BIOS settings. I used "smartctl -x" to see much info about the drives.

Tim

Offline

#4 2015-06-08 16:13:22

ratcheer
Member
Registered: 2011-10-09
Posts: 776

Re: [SOLVED] How to switch SSD to 6 Gb/s mode?

I just installed hdparm and ran your command:

hdparm -I /dev/sdc
/dev/sdc:

ATA device, with non-removable media
        Model Number:       Samsung SSD 850 PRO 256GB               
        Serial Number:      S1SUNSAFB27444M     
        Firmware Revision:  EXM01B6Q
        Transport:          Serial, ATA8-AST, SATA 1.0a, SATA II Extensions, SATA Rev 2.5, SATA Rev 2.6, SATA Rev 3.0
Standards:
        Used: unknown (minor revision code 0x0039) 
        Supported: 9 8 7 6 5 
        Likely used: 9
Configuration:
           *    General Purpose Logging feature set
           *    WRITE_{DMA|MULTIPLE}_FUA_EXT
           *    64-bit World wide name
                Write-Read-Verify feature set
           *    WRITE_UNCORRECTABLE_EXT command
           *    {READ,WRITE}_DMA_EXT_GPL commands
           *    Segmented DOWNLOAD_MICROCODE
           *    Gen1 signaling speed (1.5Gb/s)
           *    Gen2 signaling speed (3.0Gb/s)
           *    Gen3 signaling speed (6.0Gb/s)
           *    Native Command Queueing (NCQ)
           *    Phy event counters
           *    unknown 76[15]
                DMA Setup Auto-Activate optimization
                Device-initiated interface power management
           *    Asynchronous notification (eg. media change)
           *    Software settings preservation
                unknown 78[8]
           *    SMART Command Transport (SCT) feature set
           *    SCT Write Same (AC2)
           *    SCT Error Recovery Control (AC3)
           *    SCT Features Control (AC4)
           *    SCT Data Tables (AC5)
           *    reserved 69[4]
           *    DOWNLOAD MICROCODE DMA command
           *    SET MAX SETPASSWORD/UNLOCK DMA commands
           *    WRITE BUFFER DMA command
           *    READ BUFFER DMA command
           *    Data Set Management TRIM supported (limit 8 blocks)
Security: 
        Master password revision code = 65534
                supported
        not     enabled
        not     locked
        not     frozen
        not     expired: security count
                supported: enhanced erase
        2min for SECURITY ERASE UNIT. 2min for ENHANCED SECURITY ERASE UNIT. 
Logical Unit WWN Device Identifier: 50025388a081f996
        NAA             : 5
        IEEE OUI        : 002538
        Unique ID       : 8a081f996
Checksum: correct

Tim

Offline

#5 2015-06-08 16:26:17

paulkerry
Member
From: Sheffield, UK
Registered: 2014-10-02
Posts: 491

Re: [SOLVED] How to switch SSD to 6 Gb/s mode?

ratcheer wrote:

I just installed hdparm and ran your command:

hdparm -I /dev/sdc
           *    Gen1 signaling speed (1.5Gb/s)
           *    Gen2 signaling speed (3.0Gb/s)
           *    Gen3 signaling speed (6.0Gb/s)
 

Tim


So it would appear that you are running at 6Gb/s.

I ran your smartctl command on my setup and got the following

smartctl -x /dev/sda | grep SATA
SATA Version is:  SATA 3.1, 6.0 Gb/s (current: 6.0 Gb/s)

so on my system, hdparm and smartctl outputs match. Are your packages fully up to date?

Offline

#6 2015-06-08 17:24:09

ratcheer
Member
Registered: 2011-10-09
Posts: 776

Re: [SOLVED] How to switch SSD to 6 Gb/s mode?

paulkerry wrote:

so on my system, hdparm and smartctl outputs match. Are your packages fully up to date?

Yes, my system is compeltely up-to-date. local/hdparm 9.45-1 last updated in the repository on 2014-11-05, local/gsmartcontrol 0.8.7-5 last updated in the repository on 2015-05-30.

It appears to me that the hdparm output is telling what capabilities are there, while the smartctl output is showing the actual current mode.

Tim

Last edited by ratcheer (2015-06-08 17:25:19)

Offline

#7 2015-06-08 17:47:21

frostschutz
Member
Registered: 2013-11-15
Posts: 988

Re: [SOLVED] How to switch SSD to 6 Gb/s mode?

check dmesg

readlink /sys/block/sda
../devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda
dmesg | grep ata1:
[    0.742117] ata1: SATA link up 6.0 Gbps (SStatus 133 SControl 300)

Online

#8 2015-06-08 17:59:36

ratcheer
Member
Registered: 2011-10-09
Posts: 776

Re: [SOLVED] How to switch SSD to 6 Gb/s mode?

Thank you, frostschutz, but I do not see anything like than in my dmesg for my device sdc.

dmesg|grep sdc
[    1.207672] sd 2:0:0:0: [sdc] 500118192 512-byte logical blocks: (256 GB/238 GiB)
[    1.207759] sd 2:0:0:0: [sdc] Write Protect is off
[    1.207763] sd 2:0:0:0: [sdc] Mode Sense: 00 3a 00 00
[    1.207792] sd 2:0:0:0: [sdc] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    1.211283]  sdc: sdc1 sdc2 sdc3 sdc4
[    1.212111] sd 2:0:0:0: [sdc] Attached SCSI disk
[    1.686356] BTRFS: device fsid afaa7e09-dcd5-4db3-82bf-88acdeafc7d2 devid 1 transid 86794 /dev/sdc3
[    1.686486] BTRFS: device fsid 72910198-e574-45ee-aab0-3ef7f7407920 devid 1 transid 21383 /dev/sdc2
[    1.698115] BTRFS: device fsid f45496d9-1ebb-4512-bb7a-1732e24a7d3e devid 1 transid 13640 /dev/sdc4
[    3.427836] BTRFS info (device sdc2): disk space caching is enabled
[    3.768205] BTRFS info (device sdc2): disk space caching is enabled
[    4.136165] BTRFS info (device sdc3): use ssd allocation scheme
[    4.136168] BTRFS info (device sdc3): disk space caching is enabled

Tim

Offline

#9 2015-06-08 18:03:39

frostschutz
Member
Registered: 2013-11-15
Posts: 988

Re: [SOLVED] How to switch SSD to 6 Gb/s mode?

Why grep sdc?

Online

#10 2015-06-08 20:36:06

paulkerry
Member
From: Sheffield, UK
Registered: 2014-10-02
Posts: 491

Re: [SOLVED] How to switch SSD to 6 Gb/s mode?

grep for "ata" rather than the disk identifier: I have two devices, so mine shows this...

dmesg | grep ata
...
[    3.430492] ata5: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[    3.430512] ata6: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
...

and then further down the output...

[    3.432512] ata5.00: ATA-9: Samsung SSD 840 EVO 250GB, EXT0CB6Q, max UDMA/133
...
[    3.434425] ata6.00: ATAPI: hp       DVD-RAM UJ8DB, H.02, max UDMA/100

Offline

#11 2015-06-08 21:48:51

ratcheer
Member
Registered: 2011-10-09
Posts: 776

Re: [SOLVED] How to switch SSD to 6 Gb/s mode?

Ok, I didn't understand what I was looking for.

dmesg|grep ata
[    0.000000] BIOS-e820: [mem 0x00000000df7a3000-0x00000000df7dffff] ACPI data
[    0.000000] Memory: 8157396K/8371320K available (5629K kernel code, 840K rwdata, 1784K rodata, 1160K init, 1152K bss, 213924K reserved, 0K cma-reserved)
[    0.307419] Write protecting the kernel read-only data: 8192k
[    0.336887] libata version 3.00 loaded.
[    0.359514] ata_piix 0000:00:1f.2: version 2.13
[    0.359586] ata_piix 0000:00:1f.2: MAP [ P0 P2 P1 P3 ]
[    0.360190] scsi host0: ata_piix
[    0.360402] scsi host1: ata_piix
[    0.360446] ata1: SATA max UDMA/133 cmd 0xff00 ctl 0xfe00 bmdma 0xfb00 irq 19
[    0.360450] ata2: SATA max UDMA/133 cmd 0xfd00 ctl 0xfc00 bmdma 0xfb08 irq 19
[    0.360518] ata_piix 0000:00:1f.5: MAP [ P0 -- P1 -- ]
[    0.360927] scsi host2: ata_piix
[    0.361011] scsi host3: ata_piix
[    0.361044] ata3: SATA max UDMA/133 cmd 0xf800 ctl 0xf700 bmdma 0xf400 irq 19
[    0.361046] ata4: SATA max UDMA/133 cmd 0xf600 ctl 0xf500 bmdma 0xf408 irq 19
[    0.689704] ata4: SATA link down (SStatus 0 SControl 300)
[    0.841965] ata3: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[    0.848886] ata3.00: supports DRM functions and may not be fully accessible
[    0.848891] ata3.00: ATA-9: Samsung SSD 850 PRO 256GB, EXM01B6Q, max UDMA/133
[    0.848894] ata3.00: 500118192 sectors, multi 1: LBA48 NCQ (depth 0/32)
[    0.855540] ata3.00: supports DRM functions and may not be fully accessible
[    0.855811] ata3.00: configured for UDMA/133
[    1.151552] ata1.00: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[    1.151566] ata1.01: SATA link down (SStatus 0 SControl 300)
[    1.151697] ata2.00: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[    1.151713] ata2.01: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[    1.158872] ata1.00: ATA-8: ST31000524AS, JC45, max UDMA/133
[    1.158877] ata1.00: 1953525168 sectors, multi 16: LBA48 NCQ (depth 0/32)
[    1.165376] ata2.00: ATA-8: ST2000DM001-9YN164, CC4B, max UDMA/133
[    1.165381] ata2.00: 3907029168 sectors, multi 16: LBA48 NCQ (depth 0/32)
[    1.165389] ata2.01: ATAPI: Optiarc DVD RW AD-7260S, 1.03, max UDMA/100
[    1.172099] ata1.00: configured for UDMA/133
[    1.178631] ata2.00: configured for UDMA/133
[    1.191740] ata2.01: configured for UDMA/100
[    3.573269] systemd[1]: Listening on LVM2 metadata daemon socket.
[    3.573278] systemd[1]: Starting LVM2 metadata daemon socket.
[    3.769644] systemd[1]: Started Rebuild Hardware Database.

So, my SSD is ata3 and it does seem that something is wrong.

[    0.841965] ata3: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[    0.848886] ata3.00: supports DRM functions and may not be fully accessible
[    0.848891] ata3.00: ATA-9: Samsung SSD 850 PRO 256GB, EXM01B6Q, max UDMA/133
[    0.848894] ata3.00: 500118192 sectors, multi 1: LBA48 NCQ (depth 0/32)
[    0.855540] ata3.00: supports DRM functions and may not be fully accessible
[    0.855811] ata3.00: configured for UDMA/133

I would appreciate any advice on troubleshooting and correcting this. In the meantime, I will be searching for similar issues and possible fixes.

Thank you, frostschutz and paulkerry

Tim

Offline

#12 2015-06-08 21:54:17

ratcheer
Member
Registered: 2011-10-09
Posts: 776

Re: [SOLVED] How to switch SSD to 6 Gb/s mode?

There was a kernel bug giving the same symptom, but that was over a year ago. I am running the current main Arch kernel, 4.0.5-1-ARCH. Also, the bug statuses boil down to Crucial and Micron firmware issues.

https://bugzilla.kernel.org/show_bug.cgi?id=71371

Tim

Last edited by ratcheer (2015-06-08 21:56:41)

Offline

#13 2015-06-08 22:03:04

ratcheer
Member
Registered: 2011-10-09
Posts: 776

Re: [SOLVED] How to switch SSD to 6 Gb/s mode?

This looks more relevant:

https://unix.stackexchange.com/question … ata3-drive

This is a known error in Samsung SSDs: The drives do not properly implement queued trim commands.
...
The reason the error did not appear in older kernels is that these do not try to use the buggy function of the drive, they thus never see the error. Even newer kernels (4.0 and forward) know that the drives have this error, so the error will not be shown for the drive in the future.

Well, my kernel is >= 4.0, and I'm still having the error.

Tim

Offline

#14 2015-06-09 05:28:47

paulkerry
Member
From: Sheffield, UK
Registered: 2014-10-02
Posts: 491

Re: [SOLVED] How to switch SSD to 6 Gb/s mode?

A few other ideas...
- going back to your first post, did you check the sata connectors on your motherboard as sometimes only a pair of sata ports are 6Gb/s capable (motherboard manual)?
- are your other hdd's running at 6Gb/s? If they are, perhaps swap the sata cables over to test your ssd (straightforward if you are using UUID's)?
- in bios if it's possible, change your hdd settings to use ahci rather than the current option: when you run dmesg again, you will notice "ata_piix" has been replaced by "ahci"

Offline

#15 2015-06-09 13:03:40

ratcheer
Member
Registered: 2011-10-09
Posts: 776

Re: [SOLVED] How to switch SSD to 6 Gb/s mode?

Yes, my top post states that both HDD's are running at 6 Gb/sec. I will check the BIOS setting, now. The SATA 3 ports on my motherboard are color coded bright blue, and I am certain I used one, but I will open the case and double check.

Another post I read somewhere says the SATA cable may have to be upgraded to support 6 GB/sec. I guess the only way to check that is to buy another one.

Tim

Offline

#16 2015-06-09 13:08:54

frostschutz
Member
Registered: 2013-11-15
Posts: 988

Re: [SOLVED] How to switch SSD to 6 Gb/s mode?

ratcheer wrote:

Another post I read somewhere says the SATA cable may have to be upgraded to support 6 GB/sec.

Unlikely unless the cable is very long. The only thing that changed about the cable were the clamps that prevent accidental disconnects...

But since you have two disks operating at 6gbps just switch cables/ports with those disks. It's more important that a SSD runs at this speed, with HDD the difference should be unnoticable.

Last edited by frostschutz (2015-06-09 13:36:29)

Online

#17 2015-06-09 13:54:57

ratcheer
Member
Registered: 2011-10-09
Posts: 776

Re: [SOLVED] How to switch SSD to 6 Gb/s mode?

Ok, minor problem is now major.

I went to the BIOS and changed the SATA control mode from IDE to AHCI. The PC would not boot. It hung before starting GRUB.

So, I changed it back to IDE, and it still won't boot. It still doesn't start GRUB.

So, I started the system from a live image, mounted the Arch partition and bind mounted Arch's /dev. chrooted, successfully. I am definitely in Arch, and I can see all my stuff, including /dev and /boot. But, grub-install fails, saying it cannot find the boot directory to install to, and asking whether /dev is mounted.

I am stuck.

Tim

Offline

#18 2015-06-09 15:27:57

ratcheer
Member
Registered: 2011-10-09
Posts: 776

Re: [SOLVED] How to switch SSD to 6 Gb/s mode?

Status: I finally got grub-install to run by bind mounting /proc and /sys before chroot'ing. Then, one time, the system booted to an old install of Arch on one of the HDD's. I tried to reboot and select the correct Arch system, but grub would not run, again.

Still trying...

Tim

Offline

#19 2015-06-09 17:48:01

ratcheer
Member
Registered: 2011-10-09
Posts: 776

Re: [SOLVED] How to switch SSD to 6 Gb/s mode?

Ok, I got my system back. Apparently, when I switched to AHCI, there was a fruit basket turnover of the boot order settings. Since I had not touched them, or even looked at them, it did not occur to me to check them. I moved the SSD to the top of the list and booted right up.

I am afraid to mess with this any more, so I'm marking the thread as RESOLVED. But, the original problem is not solved, as the SSD is still running at 3 Gb/sec.

Tim

Offline

#20 2015-06-09 17:50:49

Spider.007
Member
Registered: 2004-06-20
Posts: 1,172

Re: [SOLVED] How to switch SSD to 6 Gb/s mode?

ratcheer wrote:

Status: I finally got grub-install to run by bind mounting /proc and /sys before chroot'ing

Next time use `arch-chroot` instead, it'll do this for you; and prevents some other problems such as dns-issues from the chroot as well

Offline

#21 2015-06-09 17:53:12

paulkerry
Member
From: Sheffield, UK
Registered: 2014-10-02
Posts: 491

Re: [SOLVED] How to switch SSD to 6 Gb/s mode?

I understand your reluctance to investigate further. Just for info, did you try swapping the cable/port connection over from one of your HDD's to your SSD?

Offline

#22 2015-06-09 18:09:18

frostschutz
Member
Registered: 2013-11-15
Posts: 988

Re: [SOLVED] How to switch SSD to 6 Gb/s mode?

Switching cables would mess with the boot order, probably. If that's what you tried as I suggested it in my earlier reply.

Online

#23 2015-06-09 19:51:30

Tutti
Member
Registered: 2015-02-26
Posts: 117

Re: [SOLVED] How to switch SSD to 6 Gb/s mode?

If I understood correctly you switched to AHCI and then back to IDE, then later fixed the boot order.
Have you tried switching back to AHCI and ensure that the boot order is correct? From my own reading I've gotten the impression that AHCI is recommended with SSD.

Offline

#24 2015-06-09 20:12:13

ratcheer
Member
Registered: 2011-10-09
Posts: 776

Re: [SOLVED] How to switch SSD to 6 Gb/s mode?

Tutti, yes, I guess I could try that, now that I know what is happening to prevent booting. But, one thing is that while I was in the live environment with the BIOS setting on AHCI, it still reported 6 GB/sec for the hard drives and 3 Gb/sec for the SSD. So, there's really not much point to doing it.

paulkerry, I haven't gone into the case yet. After the research I have been doing, I see that this is a common problem with Samsung SSD's. I think it is really a hardware and firmware issue. As nearly as I can tell, Samsung still has not released a firmware fix.

Thanks,
Tim

Offline

#25 2015-06-09 21:18:42

ratcheer
Member
Registered: 2011-10-09
Posts: 776

Re: [SOLVED] How to switch SSD to 6 Gb/s mode?

Tutti, I did try AHCI again. Oddly, Arch on sdc2 would not boot, but openSUSE on sdc4 would. So, while in openSUSE, I verified that sdc was in AHCI mode and that it was still only operating at 3 GB/sec. Also, it was getting the noncq errors that others are having in AHCI mode. So, I have again gone back to IDE mode, and no noncq errors.

Thanks,
Tim

Last edited by ratcheer (2015-06-09 21:19:30)

Offline

Board footer

Powered by FluxBB