You are not logged in.

#1 2015-06-14 20:56:56

shoober420
Banned
Registered: 2014-07-22
Posts: 184

Enable DRI3 on Proprietary NVIDIA driver

I have come across numerous threads about enable DRI3, but none of them seem to work. I have put "--enable-dri3" in the PKGBUILD of mesa-git and lib32-mesa-git, and it still loads DRI2. What am I missing?

Last edited by shoober420 (2015-06-14 20:57:10)

Offline

#2 2015-06-14 21:54:35

Xabre
Member
From: Serbia
Registered: 2009-03-19
Posts: 739

Re: Enable DRI3 on Proprietary NVIDIA driver

Nvidia uses their own implementation of OpenGL, thus DRI3 from Mesa libs has no influence.

Offline

#3 2015-06-14 23:04:03

shoober420
Banned
Registered: 2014-07-22
Posts: 184

Re: Enable DRI3 on Proprietary NVIDIA driver

Oh, I see. How could I get DRI3 to load instead of DRI2 then on NVIDIA proprietary drivers? Is there a command I can put in the xorg.conf file?

Offline

#4 2015-06-15 01:26:40

Gusar
Member
Registered: 2009-08-25
Posts: 3,605

Re: Enable DRI3 on Proprietary NVIDIA driver

DRI is a Mesa thing, you're not using *any* DRI when using the Nvidia proprietary driver. The driver may report some info through the DRI protocol but otherwise it isn't used at all. As Xabre said, Nvidia has their own OpenGL implementation.

Offline

#5 2015-06-15 01:29:51

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,296

Re: Enable DRI3 on Proprietary NVIDIA driver

shoober420 wrote:

Oh, I see.

No, apparently you don't see. Go back and re-read Xabre's post.

Offline

#6 2015-06-15 21:14:51

shoober420
Banned
Registered: 2014-07-22
Posts: 184

Re: Enable DRI3 on Proprietary NVIDIA driver

Scimmia wrote:

No, apparently you don't see. Go back and re-read Xabre's post.

I thought he meant that the DRI came from elsewere if you use NVIDIA proprietary drivers. Like for example, it comes from X server instead of MESA. I now understand how it works because of Gusar's post. No need to be disrespectful.

Offline

Board footer

Powered by FluxBB