You are not logged in.

#1 2015-06-15 20:34:22

LessWire
Member
From: Bavaria
Registered: 2010-06-14
Posts: 46

[solved] perl 5.22.0-1: undefined symbol: perl_xs_apiversion_bootcheck

urxvt doesn't start with perl 5.22.0-1 from the testing repo:

urxvt: symbol lookup error: urxvt: undefined symbol: Perl_xs_apiversion_bootcheck

Last edited by LessWire (2015-06-24 07:06:51)

Offline

#2 2015-06-15 22:32:41

A.J.Rouvoet
Member
From: Naaldwijk, The Netherlands
Registered: 2012-06-30
Posts: 36
Website

Re: [solved] perl 5.22.0-1: undefined symbol: perl_xs_apiversion_bootcheck

Same here

Offline

#3 2015-06-15 23:58:43

Knute
Member
From: Minot, ND
Registered: 2009-03-17
Posts: 604

Re: [solved] perl 5.22.0-1: undefined symbol: perl_xs_apiversion_bootcheck

Reinstall urxvt.


Knute

Offline

#4 2015-06-16 00:05:09

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 26,981
Website

Re: [solved] perl 5.22.0-1: undefined symbol: perl_xs_apiversion_bootcheck

And rebuild all your necessary packages: https://lists.archlinux.org/pipermail/a … 27236.html

The two scripts will identify problematic packages.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#5 2015-06-24 07:06:18

LessWire
Member
From: Bavaria
Registered: 2010-06-14
Posts: 46

Re: [solved] perl 5.22.0-1: undefined symbol: perl_xs_apiversion_bootcheck

Uncarefully i forgot to activate [community-testing] in pacman.conf. Now it updates all Perl scripts and urxvt works fine.

Thanks for the hints.

Rgds, LW

Offline

#6 2015-06-24 07:07:16

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 26,981
Website

Re: [solved] perl 5.22.0-1: undefined symbol: perl_xs_apiversion_bootcheck

Please remember to mark your thread as [Solved] by editing your first post and prepending it to the title.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#7 2015-07-04 20:06:03

txtsd
Member
Registered: 2014-10-02
Posts: 65
Website

Re: [solved] perl 5.22.0-1: undefined symbol: perl_xs_apiversion_bootcheck

Hi. Perl broke things for me too. I can't run urxvt or weechat. I'm not sure if conky uses perl too, but my conky has recently started to show full commands instead just the processes.

Anyway, I ran the script, but it doesn't work. How can fix my system now?

┌[txtsd@dungeon-of-data]─[~/temp] 
└─▶ ./find-broken-perl-packages.sh 
/usr/bin/perl: symbol lookup error: /usr/lib/perl5/site_perl/auto/Socket/Socket.so: undefined symbol: Perl_xs_apiversion_bootcheck
/usr/bin/perl: symbol lookup error: /usr/lib/perl5/site_perl/auto/Socket/Socket.so: undefined symbol: Perl_xs_apiversion_bootcheck
results are in "/tmp/find-broken-perl-package.4wGmrwjB"
 - {local-,}raw.txt is a list of files that caused errors
 - pacman.txt is a list of packages that need to be rebuilt. Those are likely AUR packages
 - local-perl-dists.txt is a list of cpan distributions installed to site_perl. Use cpan to rebuild them

additional files:
 - {local-,}perl-modules.txt is a list of cpan modules that caused errors
 - perl-dists.txt is a list of cpan distributions that caused errors

┌[txtsd@dungeon-of-data]─[~/temp] 
└─▶ 

[CPU] Quad core AMD Ryzen 5 2400G with Radeon Vega Graphics (-MT-MCP-)
[GPU] Advanced Micro Devices [AMD/ATI] Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series]
[Kernel] linux-mainline
[Openbox + tint2] [zsh] Arch user since [2014-09-01 02:09]

Offline

#8 2015-07-04 20:23:28

anatolik
Developer
Registered: 2012-09-27
Posts: 435

Re: [solved] perl 5.22.0-1: undefined symbol: perl_xs_apiversion_bootcheck

Files in /usr/lib/perl5/site_perl/ are installed by system CPAN installer. These packages should be recompiled. Use scripts in https://lists.archlinux.org/pipermail/a … 27236.html to find all such packages.

Or even better stop using system CPAN completely - it brings more harm than good.

Offline

#9 2015-07-04 20:42:44

txtsd
Member
Registered: 2014-10-02
Posts: 65
Website

Re: [solved] perl 5.22.0-1: undefined symbol: perl_xs_apiversion_bootcheck

anatolik wrote:

Files in /usr/lib/perl5/site_perl/ are installed by system CPAN installer. These packages should be recompiled. Use scripts in https://lists.archlinux.org/pipermail/a … 27236.html to find all such packages.

Or even better stop using system CPAN completely - it brings more harm than good.

The scripts don't run, that's what my output is showing!


[CPU] Quad core AMD Ryzen 5 2400G with Radeon Vega Graphics (-MT-MCP-)
[GPU] Advanced Micro Devices [AMD/ATI] Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series]
[Kernel] linux-mainline
[Openbox + tint2] [zsh] Arch user since [2014-09-01 02:09]

Offline

#10 2015-07-13 06:30:11

martenjacobs
Member
Registered: 2015-07-13
Posts: 2

Re: [solved] perl 5.22.0-1: undefined symbol: perl_xs_apiversion_bootcheck

I have an issue similar to this one. I cannot use CPAN because it gives this error:

/usr/bin/perl: symbol lookup error: /usr/lib/perl5/site_perl/auto/List/Util/Util.so: undefined symbol: Perl_xs_apiversion_bootcheck

I've had a version issue in the past and was able to fix it after some botching, but I'm reluctant to try that again at this point. I don't use perl much on this server, and I don't think I have any custom modules installed (I do have a few from CPAN). I have tried running the "find-broken-perl-packages.sh" script but this throws a similar issue:

/usr/bin/perl: symbol lookup error: /usr/lib/perl5/site_perl/auto/Socket/Socket.so: undefined symbol: Perl_xs_apiversion_bootcheck

I'm not using testing or urxvt on this machine (for as far as I know). I'm responding here, as a new thread on the sysadmin subboard was deleted by jasonwryan in all his generosity, suggesting that I hadn't done any searching before posting the question. Of course, I'd found this thread before posting, but as it wasn't quite the same as my issue (as I'm not in testing and I'm not using urxvt), I had decided to make a new thread.

Before posting, I've of course tried to recompile the Scalar-List-Utils package, as suggested on some forums, but compiling that also gave an error:

$ perl Makefile.PL 
perl: symbol lookup error: /usr/lib/perl5/site_perl/auto/version/vxs/vxs.so: undefined symbol: Perl_xs_apiversion_bootcheck

Offline

#11 2015-07-13 06:46:18

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 26,981
Website

Re: [solved] perl 5.22.0-1: undefined symbol: perl_xs_apiversion_bootcheck

martenjacobs wrote:

I'm not using testing or urxvt on this machine (for as far as I know). I'm responding here, as a new thread on the sysadmin subboard was deleted by jasonwryan in all his generosity, suggesting that I hadn't done any searching before posting the question. Of course, I'd found this thread before posting, but as it wasn't quite the same as my issue (as I'm not in testing and I'm not using urxvt), I had decided to make a new thread.

God knows why I would help an ingrate like you, but I did make a mistake in telling yout the thread was in [testing] when it was in Pacman & Package Upgrades: https://bbs.archlinux.org/viewtopic.php?id=199172

Before posting, I've of course tried to recompile the Scalar-List-Utils package, as suggested on some forums, but compiling that also gave an error:

$ perl Makefile.PL 
perl: symbol lookup error: /usr/lib/perl5/site_perl/auto/version/vxs/vxs.so: undefined symbol: Perl_xs_apiversion_bootcheck

"as suggested on some forums" is a stupid as not knowing if you have [testing] enabled or not.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#12 2015-07-15 13:32:12

kozaki
Member
From: London >. < Paris
Registered: 2005-06-13
Posts: 670
Website

Re: [solved] perl 5.22.0-1: undefined symbol: perl_xs_apiversion_bootcheck

Same error as LessWire here. No testing repos.
Rebuilding AUR packages as quoted above solved the issue in this location: irssi, rxvt-unicode-256xresources 9.21-1
Thank you Jasonwryan smile


Seeded last month: Arch 50 gig, derivatives 1 gig
Desktop @3.3GHz 8 gig RAM, linux-ck
laptop #1 Atom 2 gig RAM, Arch linux stock i686 (6H w/ 6yrs old battery smile) #2: ARM Tegra K1, 4 gig RAM, ChrOS
Atom Z520 2 gig RAM, OMV (Debian 7) kernel 3.16 bpo on SDHC | PGP Key: 0xFF0157D9

Offline

#13 2015-09-08 18:03:31

_will
Member
Registered: 2004-07-08
Posts: 123

Re: [solved] perl 5.22.0-1: undefined symbol: perl_xs_apiversion_bootcheck

I had a problem with old packages that are now provided by core (esp. perl-encode and perl-scalar-list-utils )

Here's a quick and dirty pipeline for finding the packages now provided by core, stripping the version info, and removing them from the system

pacman -Qi perl |
 sed -n /Provides/,/Depends/p|
 sed '$d' |cut -f 2 -d: | 
 perl -lne 's/=[\d\.]+/\n/g;s/[ \t]//g;print' | 
 sed '/^$/d' | 
 xargs -n1 \
  sudo pacman -R --noconfirm

Offline

Board footer

Powered by FluxBB