You are not logged in.

#1 2015-06-18 11:15:00

Buddlespit
Member
From: Chesapeake, Va.
Registered: 2014-02-07
Posts: 444

systemd-boot (220-5) and splash-arch.bmp

OK, you win.... I can't figure it out. How does the splash-arch.bmp installed with systemd 220-5 bootctl get loaded or used? There is no documentation other than someone a few years ago stating that gummiboot splash will 'just work'. There isn't a bootctl  command/option to enable splash. Enabling splash on the kernel cmd line doesn't make it show up, even though I put a copy of splash-arch.bmp in every directory in /boot.


AMD Ryzen 7 1700X | Asus PRIME X370-A | GeForce GTX 980 Ti | 16G Ram | KDE Plasma | Zen Kernel
Until linuxcounter.com closed, I was registered linux user #560427

Offline

#2 2015-06-18 20:15:02

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 4,859
Website

Re: systemd-boot (220-5) and splash-arch.bmp

bootctl is just gummiboot under a different name wink

Try placing the .bmp in the ESP and add this line in /boot/loader/loader.conf

splash splash-arch.bmp

http://freedesktop.org/wiki/Software/gummiboot/

Offline

#3 2016-09-11 15:20:35

colinkeenan
Member
From: Kansas City, MO USA
Registered: 2013-06-13
Posts: 209
Website

Re: systemd-boot (220-5) and splash-arch.bmp

Head_on_a_Stick wrote:

bootctl is just gummiboot under a different name wink

Try placing the .bmp in the ESP and add this line in /boot/loader/loader.conf

splash splash-arch.bmp

http://freedesktop.org/wiki/Software/gummiboot/

Did this work? I tried it, but didn't work for me. The only reason I'm interested is that I currently get a black rectangle displayed over my machine's default image and would like to replace that with something more sensible.

Offline

#4 2016-09-11 15:53:27

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 4,859
Website

Re: systemd-boot (220-5) and splash-arch.bmp

colinkeenan wrote:

Did this work?

I have never got that to work but the systemd-boot screen only shows for a fraction of a second anyway so...
hmm

Offline

#5 2016-09-11 16:04:19

Buddlespit
Member
From: Chesapeake, Va.
Registered: 2014-02-07
Posts: 444

Re: systemd-boot (220-5) and splash-arch.bmp

Same here, never got it to work. Last tried yesterday. Once every blue moon, I'll go thru my EFI for some reason and see all of the bmp's and I'll try again. A google search, btw, will bring you here...


AMD Ryzen 7 1700X | Asus PRIME X370-A | GeForce GTX 980 Ti | 16G Ram | KDE Plasma | Zen Kernel
Until linuxcounter.com closed, I was registered linux user #560427

Offline

#6 2016-09-11 16:07:25

colinkeenan
Member
From: Kansas City, MO USA
Registered: 2013-06-13
Posts: 209
Website

Re: systemd-boot (220-5) and splash-arch.bmp

Buddlespit wrote:

Same here, never got it to work. Last tried yesterday. Once every blue moon, I'll go thru my EFI for some reason and see all of the bmp's and I'll try again. A google search, btw, will bring you here...

I also found this: https://www.reddit.com/r/archlinux/comm … reen_boot/

Somebody got it to work, but others in that thread didn't, and it didn't work for me either. I really don't care except that flash of a black rectangle is a little annoying.

Offline

Board footer

Powered by FluxBB