You are not logged in.

#1 2015-06-29 15:17:15

slackcub
Member
Registered: 2009-03-14
Posts: 136

Unable to update packages in perl 5.22

Hello everyone, I'm running into an issue with perl 5.22.  When I upgraded to that, I started getting undefined symbol errors.  I followed the instructions on this post.

I got my lists, however, all my packages are CPAN modules, not from AUR. I tried updating them, but I keep getting errors preventing me from updating them:

$ perl -MCPAN -e "upgrade /(.\*)/"
perl: symbol lookup error: /home/me/perl5/lib/perl5/x86_64-linux-thread-multi/auto/Cwd/Cwd.so: undefined symbol: Perl_xs_apiversion_bootcheck

$ cpan-outdated -p
/usr/bin/perl: symbol lookup error: /home/me/perl5/lib/perl5/x86_64-linux-thread-multi/auto/Cwd/Cwd.so: undefined symbol: Perl_xs_apiversion_bootcheck

$ cpan
/usr/bin/perl: symbol lookup error: /home/me/perl5/lib/perl5/x86_64-linux-thread-multi/auto/Cwd/Cwd.so: undefined symbol: Perl_xs_apiversion_bootcheck

I ended up rolling back to perl 5.20 in order to get things working.  Does anyone have any suggestions on what could be causing this?

Last edited by slackcub (2015-06-29 16:36:38)

Offline

#2 2015-06-29 15:44:36

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: Unable to update packages in perl 5.22

Offline

#3 2015-06-29 15:45:27

paris3200
Member
Registered: 2012-12-08
Posts: 22

Re: Unable to update packages in perl 5.22

I'm having the same issue.  If you do happen to find a solution be sure to post it.

Offline

#4 2015-06-29 16:37:06

slackcub
Member
Registered: 2009-03-14
Posts: 136

Re: Unable to update packages in perl 5.22

Karol, that's the post I linked to in my original post.

Offline

#5 2015-06-29 20:23:15

tolmun
Member
Registered: 2011-12-04
Posts: 8

Re: Unable to update packages in perl 5.22

Same issue here, after perl upgrade.

perl: symbol lookup error: /usr/lib/perl5/vendor_perl/auto/List/Util/Util.so: undefined symbol: Perl_xs_apiversion_bootcheck

Solved with:

1. Update mirrors

2. Find out all packages not in the main repos (packages installed from AUR)
   

$ pacman -Qm

3. Remove packages from the list
   

$ pacman -Rn <package>

4. Rebuild and install all

Offline

#6 2015-07-01 02:25:37

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,104

Re: Unable to update packages in perl 5.22

I found that just removing the one package from AUR which started with perl- seemed to resolve the issue I was having. I don't think it is really necessary to remove all foreign packages - let alone to remove all their configuration files as well!


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Corporation Wireless 8265 / 8275 | US keyboard with Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#7 2015-07-06 17:17:20

slackcub
Member
Registered: 2009-03-14
Posts: 136

Re: Unable to update packages in perl 5.22

tolmun and cfr,

    Sorry for the delay, I had a family emergency and was away for a bit.  As I had stated previously, I don't have any AUR, they've all been installed locally via CPAN.

Offline

#8 2015-07-06 18:18:15

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 27,957
Website

Re: Unable to update packages in perl 5.22

slackcub wrote:

As I had stated previously, I don't have any AUR, they've all been installed locally via CPAN.

This is your issue: pacman doesn't know about these modules.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#9 2015-07-07 01:24:58

slackcub
Member
Registered: 2009-03-14
Posts: 136

Re: Unable to update packages in perl 5.22

yes, I understand that.  But how can I update all the modules that I have currently installed without uninstalling all of them and reinstalling?  There has to be a way.

Offline

#10 2015-07-18 02:53:30

Gyscos
Member
Registered: 2009-09-19
Posts: 27

Re: Unable to update packages in perl 5.22

I had this exact issue.
Looking at the owner of the faulty file, I found the package perl-scalar-list-utils, that doesn't exist anymore (probably replaced by something else).
Removing this single package solved the problem.

EDIT: actually, I had it installed in pacman, so not exactly the same issue.

Last edited by Gyscos (2015-07-21 18:44:33)

Offline

#11 2015-07-18 11:49:31

slackcub
Member
Registered: 2009-03-14
Posts: 136

Re: Unable to update packages in perl 5.22

Gyscos, how did you remove it without being able to execute cpan?

Offline

#12 2015-07-21 18:37:09

Gyscos
Member
Registered: 2009-09-19
Posts: 27

Re: Unable to update packages in perl 5.22

I actually had installed it with the aur, so I just had to run:

pacman -Rsc perl-scalar-list-utils

This didn't give me any error.

If you installed this package separately, I believe you only need to remove this one manually (and not all other perl packages).

Last edited by Gyscos (2015-07-21 18:44:03)

Offline

#13 2015-07-21 19:41:24

slackcub
Member
Registered: 2009-03-14
Posts: 136

Re: Unable to update packages in perl 5.22

Do you have any suggestions on removing it manually since I can't run cpan or perl?

Offline

#14 2015-07-22 22:49:11

Gyscos
Member
Registered: 2009-09-19
Posts: 27

Re: Unable to update packages in perl 5.22

I just checked a few aur perl packages, and they don't have an uninstall script, so I guess the uninstallation procedure is just removing the package files?
Try removing (or moving to a backup location) the problematic file (or maybe the entire Cwd directory)? Then you can uninstall it properly once CPAN works again.

Last edited by Gyscos (2015-07-23 18:27:55)

Offline

Board footer

Powered by FluxBB