You are not logged in.

#1 2015-07-07 06:37:22

Deutschwings
Member
Registered: 2015-07-07
Posts: 3

No wireless connection

Hello,
I have been using Arch Linux for a while on a temporary wired connection, but I would like to get a wireless connection working because my computer is in a really inconvenient place. According to the lspci -k command my wireless card is a Broadcom Corporation BCM4318 and I have installed the b43-firmware for it. When I try to select my network using the wifi-menu command I get this:

Job for netctl@TRENDnet.service failed because the control process exited with error code. See "systemctl status netctl@TRENDnet.service" and "journalctl -xe" for details.

The output of systemctl status netctl@TRENDnet.service is this:

● netctl@TRENDnet.service - Automatically generated profile by wifi-menu
   Loaded: loaded (/etc/systemd/system/netctl@TRENDnet.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Mon 2015-07-06 23:12:37 PDT; 2min 46s ago
     Docs: man:netctl.profile(5)
  Process: 1492 ExecStart=/usr/lib/network/network start %I (code=exited, status=1/FAILURE)
 Main PID: 1492 (code=exited, status=1/FAILURE)

Jul 06 23:12:21 Bovine systemd[1]: Starting Automatically generated profile by wifi-menu...
Jul 06 23:12:21 Bovine network[1492]: Starting network profile 'TRENDnet'...
Jul 06 23:12:37 Bovine network[1492]: WPA association/authentication failed for interface 'wlan0'
Jul 06 23:12:37 Bovine network[1492]: Failed to bring the network up for profile 'TRENDnet'
Jul 06 23:12:37 Bovine systemd[1]: netctl@TRENDnet.service: Main process exited, code=exited, status=1/FAILURE
Jul 06 23:12:37 Bovine systemd[1]: Failed to start Automatically generated profile by wifi-menu.
Jul 06 23:12:37 Bovine systemd[1]: netctl@TRENDnet.service: Unit entered failed state.
Jul 06 23:12:37 Bovine systemd[1]: netctl@TRENDnet.service: Failed with result 'exit-code'.

It says that it's failed, but I have no idea on how to fix this.

Here's some more information if it's needed:
Ip link:

$ ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp4s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT group default qlen 1000
    link/ether 00:13:72:31:09:08 brd ff:ff:ff:ff:ff:ff
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT group default qlen 1000
    link/ether 00:14:bf:74:6a:2f brd ff:ff:ff:ff:ff:ff

systemctl list-unit-files:

$ systemctl list-unit-files
UNIT FILE                                  STATE   
proc-sys-fs-binfmt_misc.automount          static  
org.freedesktop.hostname1.busname          static  
org.freedesktop.import1.busname            static  
org.freedesktop.locale1.busname            static  
org.freedesktop.login1.busname             static  
org.freedesktop.machine1.busname           static  
org.freedesktop.network1.busname           static  
org.freedesktop.resolve1.busname           static  
org.freedesktop.systemd1.busname           static  
org.freedesktop.timedate1.busname          static  
dev-hugepages.mount                        static  
dev-mqueue.mount                           static  
proc-sys-fs-binfmt_misc.mount              static  
sys-fs-fuse-connections.mount              static  
sys-kernel-config.mount                    static  
sys-kernel-debug.mount                     static  
tmp.mount                                  static  
var-lib-machines.mount                     static  
systemd-ask-password-console.path          static  
systemd-ask-password-wall.path             static  
session-c1.scope                           static  
alsa-restore.service                       static  
alsa-state.service                         static  
alsa-store.service                         static  
autovt@.service                            disabled
avahi-daemon.service                       disabled
avahi-dnsconfd.service                     disabled
blk-availability.service                   disabled
canberra-system-bootup.service             disabled
canberra-system-shutdown-reboot.service    disabled
canberra-system-shutdown.service           disabled
clamd.service                              disabled
colord.service                             static  
console-getty.service                      disabled
console-shell.service                      disabled
container-getty@.service                   static  
dbus-org.freedesktop.Avahi.service         disabled
dbus-org.freedesktop.hostname1.service     static  
dbus-org.freedesktop.import1.service       static  
dbus-org.freedesktop.locale1.service       static  
dbus-org.freedesktop.login1.service        static  
dbus-org.freedesktop.machine1.service      static  
dbus-org.freedesktop.network1.service      disabled
dbus-org.freedesktop.resolve1.service      disabled
dbus-org.freedesktop.timedate1.service     static  
dbus-org.wicd.daemon.service               enabled 
dbus.service                               static  
debug-shell.service                        disabled
dhcpcd.service                             enabled 
dhcpcd@.service                            disabled
display-manager.service                    enabled 
dm-event.service                           disabled
emergency.service                          static  
fancontrol.service                         disabled
freshclamd.service                         disabled
fstrim.service                             static  
ftpd.service                               disabled
getty@.service                             enabled 
git-daemon@.service                        static  
gpm.service                                disabled
healthd.service                            disabled

systemctl --failed:

$ systemctl --failed
  UNIT                           LOAD   ACTIVE SUB    DESCRIPTION
● netctl@TRENDnet.service        loaded failed failed Automatically generated profile by wifi-menu
● systemd-tmpfiles-clean.service loaded failed failed Cleanup of Temporary Directories
● systemd-tmpfiles-setup.service loaded failed failed Create Volatile Files and Directories

LOAD   = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB    = The low-level unit activation state, values depend on unit type.

3 loaded units listed. Pass --all to see loaded but inactive units, too.
To show all installed unit files use 'systemctl list-unit-files'.

If I need to post anymore information just ask.  smile

Last edited by Deutschwings (2015-07-07 06:55:51)

Offline

#2 2015-07-07 07:19:46

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 6,355

Re: No wireless connection

Deutschwings wrote:
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT group default qlen 1000
    link/ether 00:14:bf:74:6a:2f brd ff:ff:ff:ff:ff:ff

It seems strange that the wireless interface is using the traditional nomenclature but the ethernet connection is using the "predictable" naming system...

What is the output of:

cat /proc/cmdline

It looks like you may have dhcpcd@.service enabled which may conflict with netctl -- to be sure, lets see the output of:

ls -l /etc/systemd/systemd/multi-user.target.wants

With all networking .services disabled, can you connect manually?
https://wiki.archlinux.org/index.php/Wi … nual_setup

Offline

#3 2015-07-07 08:29:19

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

Re: No wireless connection

I have the 4318 here and it's 100% reliable. I use wpa_supplicant and systemd-networkd to manage it.

I'd second Head's suggestion that you try a manual connection with no automated services running - it's the only way you will be able to see what's going wrong.

Offline

#4 2015-07-07 09:18:14

Deutschwings
Member
Registered: 2015-07-07
Posts: 3

Re: No wireless connection

Head_on_a_Stick wrote:
Deutschwings wrote:
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT group default qlen 1000
    link/ether 00:14:bf:74:6a:2f brd ff:ff:ff:ff:ff:ff

It seems strange that the wireless interface is using the traditional nomenclature but the ethernet connection is using the "predictable" naming system...

I also thought it was odd that my wireless interface was shown as wlan0 instead of something like wl2p04. When I had a fresh install using ip link would only shown me the ethernet interface and lo, but now I get the wireless interface as well, but I can't explain it, I must have added it when trying out commands to get a connection.

output of cat /proc/cmdline:

$ cat /proc/cmdline
BOOT_IMAGE=/vmlinuz-linux root=UUID=fcace874-b085-4be0-812a-45c526458ea5 rw quiet

output of ls -l /etc/systemd/systemd/multi-user.target.wants:

$ ls -l /etc/systemd/systemd/multi-user.target.wants
ls: cannot access /etc/systemd/systemd/multi-user.target.wants: No such file or directory

I have the 4318 here and it's 100% reliable. I use wpa_supplicant and systemd-networkd to manage it.

I'd second Head's suggestion that you try a manual connection with no automated services running - it's the only way you will be able to see what's going wrong.

I'm going to try a manual connection, but I'm curious about how much hassle you went through to get the card working. It was my first Arch install I really have nothing important saved, and there's a good chance that I screwed up, so if it was easy for you to get the card working I might as well just reinstall.

Offline

#5 2015-07-07 09:31:34

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

Re: No wireless connection

No hassle at all - only difference would be that when I set it up first there was no b43-firmware package, so I did that manually using the b43-fwcutter tool, as described on the Broadcom wireless wiki page.

Not sure why you would consider reinstalling just for that, but it's your party.... smile

Offline

#6 2015-07-07 20:09:28

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 6,355

Re: No wireless connection

Deutschwings wrote:

output of ls -l /etc/systemd/systemd/multi-user.target.wants:

$ ls -l /etc/systemd/systemd/multi-user.target.wants
ls: cannot access /etc/systemd/systemd/multi-user.target.wants: No such file or directory

Ooops, sorry...

ls -l /etc/systemd/system/multi-user.target.wants

I'm using OpenBSD ATM...

Offline

#7 2015-07-07 21:16:39

Deutschwings
Member
Registered: 2015-07-07
Posts: 3

Re: No wireless connection

Head_on_a_Stick wrote:
Deutschwings wrote:

output of ls -l /etc/systemd/systemd/multi-user.target.wants:

$ ls -l /etc/systemd/systemd/multi-user.target.wants
ls: cannot access /etc/systemd/systemd/multi-user.target.wants: No such file or directory

Ooops, sorry...

ls -l /etc/systemd/system/multi-user.target.wants

I'm using OpenBSD ATM...

Oh, I see.

$ ls -l /etc/systemd/system/multi-user.target.wants
total 0
lrwxrwxrwx 1 root root 38 Jul  7 00:51 dhcpcd.service -> /usr/lib/systemd/system/dhcpcd.service
lrwxrwxrwx 1 root root 43 Jul  4 00:00 netctl@TRENDnet.service -> /etc/systemd/system/netctl@TRENDnet.service
lrwxrwxrwx 1 root root 40 Jun 22 12:34 remote-fs.target -> /usr/lib/systemd/system/remote-fs.target
lrwxrwxrwx 1 root root 48 Jul  7 02:07 systemd-networkd.service -> /usr/lib/systemd/system/systemd-networkd.service
lrwxrwxrwx 1 root root 36 Jul  3 00:13 wicd.service -> /usr/lib/systemd/system/wicd.service

Offline

#8 2015-07-07 21:37:16

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 6,355

Re: No wireless connection

# systemctl disable dhcpcd.service systemd-networkd.service wicd.service

Then reboot.

You should only have *one* networking .service `enable`d at a time.

If it still fails, `disable` the netctl .service as well and start again from scratch.
https://wiki.archlinux.org/index.php/Netctl

Last edited by Head_on_a_Stick (2015-07-07 21:37:50)

Offline

#9 2016-11-09 01:14:47

miguelcm.cm
Member
Registered: 2016-11-09
Posts: 1

Re: No wireless connection

Works for me... I have some time trying fix the error THANKS !!!

Offline

Board footer

Powered by FluxBB