You are not logged in.

#1 2015-07-16 06:46:21

chosentorture
Member
Registered: 2014-10-31
Posts: 58

xf86EnableIOPorts: failed to set IOPL for I/O

I started using bspwm (using startx) and when I exit the WM, Xorg gives the following error -

xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
Failed request: SetInputFocus, BadMatch: 16777227
Failed request: SetInputFocus, BadMatch: 18874372
Failed request: SetInputFocus, BadMatch: 20971523
The server closed the connection: scoket, pipe or stream error.
Ther server closed the connection.
xinit: connection to X server lost
waiting for X server to shut down urxvt: X connection to ':0' broken, unable to recover, exiting.
(II) Server terminated successfully (0). Closing log file.

This is my .xinitrc file

#!/bin/sh

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/.Xresources
sysmodmap=/etc/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then
    xrdb -merge $sysresources
fi

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f "$userresources" ]; then
    xrdb -merge "$userresources"
fi

if [ -f "$usermodmap" ]; then
    xmodmap "$usermodmap"
fi

# start some nice programs

if [ -d /etc/X11/xinit/xinitrc.d ] ; then
 for f in /etc/X11/xinit/xinitrc.d/* ; do
  [ -x "$f" ] && . "$f"
 done
 unset f
fi

#/usr/lib/polkit-gnome/polkit-authentication-agent-1 &
#exec openbox-session

/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 &
sxhkd &
exec bspwm

and this is the Xorg.0.log file -

[   746.213] 
X.Org X Server 1.17.2
Release Date: 2015-06-16
[   746.213] X Protocol Version 11, Revision 0
[   746.213] Build Operating System: Linux 4.0.4-2-ARCH x86_64 
[   746.213] Current Operating System: Linux syracuse 4.0.7-2-ARCH #1 SMP PREEMPT Tue Jun 30 07:50:21 UTC 2015 x86_64
[   746.213] Kernel command line: \vmlinuz-linux ro root=UUID=c47e7364-c9a7-429f-b6af-c7f6461bd1d6 quiet loglevel=3 vga=current udev.log-priority=3 initrd=/intel-ucode.img initrd=\initramfs-linux.img
[   746.213] Build Date: 30 June 2015  09:00:12PM
[   746.213]  
[   746.213] Current version of pixman: 0.32.6
[   746.213] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[   746.213] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   746.214] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Jul 16 11:08:45 2015
[   746.214] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   746.214] (==) No Layout section.  Using the first Screen section.
[   746.214] (==) No screen section available. Using defaults.
[   746.214] (**) |-->Screen "Default Screen Section" (0)
[   746.214] (**) |   |-->Monitor "<default monitor>"
[   746.214] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[   746.214] (==) Automatically adding devices
[   746.214] (==) Automatically enabling devices
[   746.214] (==) Automatically adding GPU devices
[   746.214] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[   746.214] 	Entry deleted from font path.
[   746.214] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[   746.214] 	Entry deleted from font path.
[   746.214] 	(Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[   746.214] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[   746.214] 	Entry deleted from font path.
[   746.214] 	(Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[   746.214] (==) FontPath set to:
	/usr/share/fonts/misc/,
	/usr/share/fonts/TTF/,
	/usr/share/fonts/OTF/
[   746.214] (==) ModulePath set to "/usr/lib/xorg/modules"
[   746.214] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[   746.214] (II) Loader magic: 0x816d60
[   746.214] (II) Module ABI versions:
[   746.214] 	X.Org ANSI C Emulation: 0.4
[   746.214] 	X.Org Video Driver: 19.0
[   746.214] 	X.Org XInput driver : 21.1
[   746.214] 	X.Org Server Extension : 9.0
[   746.215] (II) systemd-logind: took control of session /org/freedesktop/login1/session/c1
[   746.216] (II) xfree86: Adding drm device (/dev/dri/card0)
[   746.216] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 8 paused 0
[   746.217] (--) PCI:*(0:0:2:0) 8086:041e:1458:d000 rev 6, Mem @ 0xf7800000/4194304, 0xe0000000/268435456, I/O @ 0x0000f000/64
[   746.217] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[   746.217] (II) LoadModule: "glx"
[   746.217] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   746.218] (II) Module glx: vendor="X.Org Foundation"
[   746.218] 	compiled for 1.17.2, module version = 1.0.0
[   746.218] 	ABI class: X.Org Server Extension, version 9.0
[   746.218] (==) AIGLX enabled
[   746.218] (==) Matched intel as autoconfigured driver 0
[   746.218] (==) Matched intel as autoconfigured driver 1
[   746.218] (==) Matched modesetting as autoconfigured driver 2
[   746.218] (==) Matched fbdev as autoconfigured driver 3
[   746.218] (==) Matched vesa as autoconfigured driver 4
[   746.218] (==) Assigned the driver to the xf86ConfigLayout
[   746.218] (II) LoadModule: "intel"
[   746.218] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[   746.218] (II) Module intel: vendor="X.Org Foundation"
[   746.218] 	compiled for 1.17.2, module version = 2.99.917
[   746.218] 	Module class: X.Org Video Driver
[   746.218] 	ABI class: X.Org Video Driver, version 19.0
[   746.218] (II) LoadModule: "modesetting"
[   746.218] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[   746.218] (II) Module modesetting: vendor="X.Org Foundation"
[   746.218] 	compiled for 1.17.2, module version = 1.17.2
[   746.218] 	Module class: X.Org Video Driver
[   746.218] 	ABI class: X.Org Video Driver, version 19.0
[   746.218] (II) LoadModule: "fbdev"
[   746.218] (WW) Warning, couldn't open module fbdev
[   746.218] (II) UnloadModule: "fbdev"
[   746.218] (II) Unloading fbdev
[   746.218] (EE) Failed to load module "fbdev" (module does not exist, 0)
[   746.218] (II) LoadModule: "vesa"
[   746.218] (WW) Warning, couldn't open module vesa
[   746.218] (II) UnloadModule: "vesa"
[   746.218] (II) Unloading vesa
[   746.218] (EE) Failed to load module "vesa" (module does not exist, 0)
[   746.218] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
	i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
	915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
	Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
	GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[   746.218] (II) intel: Driver for Intel(R) HD Graphics: 2000-6000
[   746.218] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100, 6100
[   746.218] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200, 6200, P6300
[   746.218] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[   746.218] (++) using VT number 1

[   746.218] (--) controlling tty is VT number 1, auto-enabling KeepTty
[   746.218] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20150130
[   746.218] (II) intel(0): SNA compiled from 2.99.917-364-gb24e758
[   746.219] (WW) Falling back to old probe method for modesetting
[   746.219] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics
[   746.219] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx, avx2; using a maximum of 2 threads
[   746.219] (II) intel(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
[   746.219] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[   746.219] (==) intel(0): RGB weight 888
[   746.219] (==) intel(0): Default visual is TrueColor
[   746.219] (II) intel(0): Output VGA1 has no monitor section
[   746.219] (II) intel(0): Enabled output VGA1
[   746.219] (II) intel(0): Output HDMI1 has no monitor section
[   746.219] (II) intel(0): Enabled output HDMI1
[   746.219] (II) intel(0): Output HDMI2 has no monitor section
[   746.219] (II) intel(0): Enabled output HDMI2
[   746.219] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[   746.219] (II) intel(0): Output VIRTUAL1 has no monitor section
[   746.219] (II) intel(0): Enabled output VIRTUAL1
[   746.219] (--) intel(0): Output VGA1 using initial mode 1600x900 on pipe 0
[   746.219] (==) intel(0): TearFree disabled
[   746.219] (==) intel(0): DPI set to (96, 96)
[   746.219] (II) Loading sub module "dri2"
[   746.219] (II) LoadModule: "dri2"
[   746.219] (II) Module "dri2" already built-in
[   746.219] (II) Loading sub module "present"
[   746.219] (II) LoadModule: "present"
[   746.219] (II) Module "present" already built-in
[   746.219] (II) UnloadModule: "modesetting"
[   746.219] (II) Unloading modesetting
[   746.219] (==) Depth 24 pixmap format is 32 bpp
[   746.219] (II) intel(0): SNA initialized with Haswell (gen7.5, gt2) backend
[   746.219] (==) intel(0): Backing store enabled
[   746.219] (==) intel(0): Silken mouse enabled
[   746.219] (II) intel(0): HW Cursor enabled
[   746.219] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[   746.220] (==) intel(0): DPMS enabled
[   746.220] (==) intel(0): Display hotplug detection enabled
[   746.220] (II) intel(0): [DRI2] Setup complete
[   746.220] (II) intel(0): [DRI2]   DRI driver: i965
[   746.220] (II) intel(0): [DRI2]   VDPAU driver: va_gl
[   746.220] (II) intel(0): direct rendering: DRI2 enabled
[   746.220] (II) intel(0): hardware support for Present enabled
[   746.220] (--) RandR disabled
[   746.247] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[   746.247] (II) AIGLX: enabled GLX_ARB_create_context
[   746.247] (II) AIGLX: enabled GLX_ARB_create_context_profile
[   746.247] (II) AIGLX: enabled GLX_EXT_create_context_es2_profile
[   746.247] (II) AIGLX: enabled GLX_INTEL_swap_event
[   746.247] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[   746.247] (II) AIGLX: enabled GLX_EXT_framebuffer_sRGB
[   746.247] (II) AIGLX: enabled GLX_ARB_fbconfig_float
[   746.247] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[   746.247] (II) AIGLX: enabled GLX_ARB_create_context_robustness
[   746.248] (II) AIGLX: Loaded and initialized i965
[   746.248] (II) GLX: Initialized DRI2 GL provider for screen 0
[   746.250] (II) intel(0): switch to mode 1600x900@60.0 on VGA1 using pipe 0, position (0, 0), rotation normal, reflection none
[   746.250] (II) intel(0): Setting screen physical size to 423 x 238
[   746.280] (II) config/udev: Adding input device Power Button (/dev/input/event4)
[   746.280] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[   746.280] (II) LoadModule: "evdev"
[   746.280] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[   746.280] (II) Module evdev: vendor="X.Org Foundation"
[   746.280] 	compiled for 1.17.1, module version = 2.9.2
[   746.280] 	Module class: X.Org XInput Driver
[   746.280] 	ABI class: X.Org XInput driver, version 21.0
[   746.280] (II) systemd-logind: got fd for /dev/input/event4 13:68 fd 15 paused 0
[   746.280] (II) Using input driver 'evdev' for 'Power Button'
[   746.280] (**) Power Button: always reports core events
[   746.280] (**) evdev: Power Button: Device: "/dev/input/event4"
[   746.280] (--) evdev: Power Button: Vendor 0 Product 0x1
[   746.280] (--) evdev: Power Button: Found keys
[   746.280] (II) evdev: Power Button: Configuring as keyboard
[   746.280] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input6/event4"
[   746.281] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[   746.281] (**) Option "xkb_rules" "evdev"
[   746.281] (**) Option "xkb_model" "pc104"
[   746.281] (**) Option "xkb_layout" "us"
[   746.294] (II) config/udev: Adding input device Video Bus (/dev/input/event11)
[   746.294] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[   746.294] (II) systemd-logind: got fd for /dev/input/event11 13:75 fd 16 paused 0
[   746.294] (II) Using input driver 'evdev' for 'Video Bus'
[   746.294] (**) Video Bus: always reports core events
[   746.294] (**) evdev: Video Bus: Device: "/dev/input/event11"
[   746.294] (--) evdev: Video Bus: Vendor 0 Product 0x6
[   746.294] (--) evdev: Video Bus: Found keys
[   746.294] (II) evdev: Video Bus: Configuring as keyboard
[   746.294] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input14/event11"
[   746.294] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[   746.294] (**) Option "xkb_rules" "evdev"
[   746.294] (**) Option "xkb_model" "pc104"
[   746.294] (**) Option "xkb_layout" "us"
[   746.295] (II) config/udev: Adding input device Power Button (/dev/input/event3)
[   746.295] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[   746.295] (II) systemd-logind: got fd for /dev/input/event3 13:67 fd 17 paused 0
[   746.295] (II) Using input driver 'evdev' for 'Power Button'
[   746.295] (**) Power Button: always reports core events
[   746.295] (**) evdev: Power Button: Device: "/dev/input/event3"
[   746.295] (--) evdev: Power Button: Vendor 0 Product 0x1
[   746.295] (--) evdev: Power Button: Found keys
[   746.295] (II) evdev: Power Button: Configuring as keyboard
[   746.295] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input5/event3"
[   746.295] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 8)
[   746.295] (**) Option "xkb_rules" "evdev"
[   746.295] (**) Option "xkb_model" "pc104"
[   746.295] (**) Option "xkb_layout" "us"
[   746.296] (II) config/udev: Adding input device HDA Intel HDMI HDMI/DP,pcm=3 (/dev/input/event12)
[   746.296] (II) No input driver specified, ignoring this device.
[   746.296] (II) This device may have been added with another device file.
[   746.296] (II) config/udev: Adding input device HDA Intel HDMI HDMI/DP,pcm=7 (/dev/input/event13)
[   746.296] (II) No input driver specified, ignoring this device.
[   746.296] (II) This device may have been added with another device file.
[   746.296] (II) config/udev: Adding input device HDA Intel HDMI HDMI/DP,pcm=8 (/dev/input/event14)
[   746.296] (II) No input driver specified, ignoring this device.
[   746.296] (II) This device may have been added with another device file.
[   746.296] (II) config/udev: Adding input device SINO WEALTH USB KEYBOARD (/dev/input/event0)
[   746.296] (**) SINO WEALTH USB KEYBOARD: Applying InputClass "evdev keyboard catchall"
[   746.297] (II) systemd-logind: got fd for /dev/input/event0 13:64 fd 18 paused 0
[   746.297] (II) Using input driver 'evdev' for 'SINO WEALTH USB KEYBOARD'
[   746.297] (**) SINO WEALTH USB KEYBOARD: always reports core events
[   746.297] (**) evdev: SINO WEALTH USB KEYBOARD: Device: "/dev/input/event0"
[   746.297] (--) evdev: SINO WEALTH USB KEYBOARD: Vendor 0x258a Product 0x1
[   746.297] (--) evdev: SINO WEALTH USB KEYBOARD: Found keys
[   746.297] (II) evdev: SINO WEALTH USB KEYBOARD: Configuring as keyboard
[   746.297] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb3/3-11/3-11:1.0/0003:258A:0001.0001/input/input2/event0"
[   746.297] (II) XINPUT: Adding extended input device "SINO WEALTH USB KEYBOARD" (type: KEYBOARD, id 9)
[   746.297] (**) Option "xkb_rules" "evdev"
[   746.297] (**) Option "xkb_model" "pc104"
[   746.297] (**) Option "xkb_layout" "us"
[   746.297] (II) config/udev: Adding input device SINO WEALTH USB KEYBOARD (/dev/input/event1)
[   746.297] (**) SINO WEALTH USB KEYBOARD: Applying InputClass "evdev keyboard catchall"
[   746.298] (II) systemd-logind: got fd for /dev/input/event1 13:65 fd 19 paused 0
[   746.298] (II) Using input driver 'evdev' for 'SINO WEALTH USB KEYBOARD'
[   746.298] (**) SINO WEALTH USB KEYBOARD: always reports core events
[   746.298] (**) evdev: SINO WEALTH USB KEYBOARD: Device: "/dev/input/event1"
[   746.298] (--) evdev: SINO WEALTH USB KEYBOARD: Vendor 0x258a Product 0x1
[   746.298] (--) evdev: SINO WEALTH USB KEYBOARD: Found keys
[   746.298] (II) evdev: SINO WEALTH USB KEYBOARD: Configuring as keyboard
[   746.298] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb3/3-11/3-11:1.1/0003:258A:0001.0002/input/input3/event1"
[   746.298] (II) XINPUT: Adding extended input device "SINO WEALTH USB KEYBOARD" (type: KEYBOARD, id 10)
[   746.298] (**) Option "xkb_rules" "evdev"
[   746.298] (**) Option "xkb_model" "pc104"
[   746.298] (**) Option "xkb_layout" "us"
[   746.298] (II) config/udev: Adding input device USB OPTICAL MOUSE (/dev/input/event2)
[   746.298] (**) USB OPTICAL MOUSE: Applying InputClass "evdev pointer catchall"
[   746.350] (II) systemd-logind: got fd for /dev/input/event2 13:66 fd 20 paused 0
[   746.350] (II) Using input driver 'evdev' for 'USB OPTICAL MOUSE'
[   746.350] (**) USB OPTICAL MOUSE: always reports core events
[   746.350] (**) evdev: USB OPTICAL MOUSE: Device: "/dev/input/event2"
[   746.350] (--) evdev: USB OPTICAL MOUSE: Vendor 0x93a Product 0x2521
[   746.350] (--) evdev: USB OPTICAL MOUSE: Found 9 mouse buttons
[   746.350] (--) evdev: USB OPTICAL MOUSE: Found scroll wheel(s)
[   746.350] (--) evdev: USB OPTICAL MOUSE: Found relative axes
[   746.350] (--) evdev: USB OPTICAL MOUSE: Found x and y relative axes
[   746.350] (II) evdev: USB OPTICAL MOUSE: Configuring as mouse
[   746.350] (II) evdev: USB OPTICAL MOUSE: Adding scrollwheel support
[   746.350] (**) evdev: USB OPTICAL MOUSE: YAxisMapping: buttons 4 and 5
[   746.350] (**) evdev: USB OPTICAL MOUSE: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[   746.350] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb3/3-12/3-12:1.0/0003:093A:2521.0003/input/input4/event2"
[   746.350] (II) XINPUT: Adding extended input device "USB OPTICAL MOUSE" (type: MOUSE, id 11)
[   746.350] (II) evdev: USB OPTICAL MOUSE: initialized for relative axes.
[   746.350] (**) USB OPTICAL MOUSE: (accel) keeping acceleration scheme 1
[   746.350] (**) USB OPTICAL MOUSE: (accel) acceleration profile 0
[   746.350] (**) USB OPTICAL MOUSE: (accel) acceleration factor: 2.000
[   746.350] (**) USB OPTICAL MOUSE: (accel) acceleration threshold: 4
[   746.350] (II) config/udev: Adding input device USB OPTICAL MOUSE (/dev/input/mouse0)
[   746.350] (II) No input driver specified, ignoring this device.
[   746.350] (II) This device may have been added with another device file.
[   746.350] (II) config/udev: Adding input device HDA Digital PCBeep (/dev/input/event6)
[   746.350] (II) No input driver specified, ignoring this device.
[   746.350] (II) This device may have been added with another device file.
[   746.351] (II) config/udev: Adding input device HDA Intel PCH Rear Mic (/dev/input/event7)
[   746.351] (II) No input driver specified, ignoring this device.
[   746.351] (II) This device may have been added with another device file.
[   746.351] (II) config/udev: Adding input device HDA Intel PCH Front Mic (/dev/input/event8)
[   746.351] (II) No input driver specified, ignoring this device.
[   746.351] (II) This device may have been added with another device file.
[   746.351] (II) config/udev: Adding input device HDA Intel PCH Line (/dev/input/event9)
[   746.351] (II) No input driver specified, ignoring this device.
[   746.351] (II) This device may have been added with another device file.
[   746.351] (II) config/udev: Adding input device HDA Intel PCH Line Out (/dev/input/event10)
[   746.351] (II) No input driver specified, ignoring this device.
[   746.351] (II) This device may have been added with another device file.
[   746.351] (II) config/udev: Adding input device PC Speaker (/dev/input/event5)
[   746.351] (II) No input driver specified, ignoring this device.
[   746.351] (II) This device may have been added with another device file.
[   746.373] (II) evdev: USB OPTICAL MOUSE: Close
[   746.373] (II) UnloadModule: "evdev"
[   746.373] (II) systemd-logind: releasing fd for 13:66
[   746.436] (II) evdev: SINO WEALTH USB KEYBOARD: Close
[   746.436] (II) UnloadModule: "evdev"
[   746.436] (II) systemd-logind: releasing fd for 13:65
[   746.489] (II) evdev: SINO WEALTH USB KEYBOARD: Close
[   746.490] (II) UnloadModule: "evdev"
[   746.490] (II) systemd-logind: releasing fd for 13:64
[   746.543] (II) evdev: Power Button: Close
[   746.543] (II) UnloadModule: "evdev"
[   746.543] (II) systemd-logind: releasing fd for 13:67
[   746.569] (II) evdev: Video Bus: Close
[   746.570] (II) UnloadModule: "evdev"
[   746.570] (II) systemd-logind: releasing fd for 13:75
[   746.596] (II) evdev: Power Button: Close
[   746.596] (II) UnloadModule: "evdev"
[   746.596] (II) systemd-logind: releasing fd for 13:68
[   746.661] (II) Server terminated successfully (0). Closing log file.

What have I done wrong?

Offline

#2 2015-08-14 19:29:14

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,778

Re: xf86EnableIOPorts: failed to set IOPL for I/O

Your problem is not with X, and the error in the title has nothing to do with the root cause.  That is really a warning -- one that I also see on my machine.

The end of your Xorg log shows that Xorg ended normally and exited.  That means that your desktop environment  terminated.  When it did, urxvt was still running and was left holding the bag with nothing to talk to.  The errors are not really important.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#3 2015-08-18 15:05:23

d125q
Member
From: Europe/Berlin
Registered: 2015-01-01
Posts: 13

Re: xf86EnableIOPorts: failed to set IOPL for I/O

ewaller wrote:

Your problem is not with X, and the error in the title has nothing to do with the root cause.  That is really a warning -- one that I also see on my machine.

Could you please explain more regarding the `xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)' message? I also get that on my machine upon quitting X, and am wondering what the cause could be.

Offline

#4 2015-08-18 15:48:42

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,778

Re: xf86EnableIOPorts: failed to set IOPL for I/O

Sorry, not a clue.  I was just asserting that it is not a root cause of the problem the OP was chasing.  In their case, Xorg is exiting normally.

There are some murmurs that the  'failed to set IOPL for I/O ' message might be prevented by setting the suid bit on /usr/bin/xinit.  I've not tried this, and am not recommending it unless you know what you are doing and are willing to be a test pilot.   Other than that, let's take this to a different thread so we don't inadvertently hijack this one.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

Board footer

Powered by FluxBB