You are not logged in.

#1 2015-08-03 18:38:24

f3bruary
Member
From: /root
Registered: 2015-06-06
Posts: 58

[SOLVED] Virtualbox not starting any Windows VMs after last update

Since the last update my Windows VMs won't startup anymore. I got 1 Linux VM which starts fine.

ERROR:

The VM session was aborted.


Result Code: 
NS_ERROR_FAILURE (0x80004005)
Component: 
SessionMachine
Interface: 
ISession {7844aa05-b02e-4cdd-a04f-ade4a762e6b7}

I googled it and some people were able to fix it by either replacing ~/.config/VirtualBox/VirtualBox.xml with ~/.config/VirtualBox/VirtualBox.xml-prev, or by deleting the xml file. I've tried this and that didn't work.

I also tried re-installing virtualbox, virtualbox-host-modules, and virtualbox-ext-oracle. Didn't work either.

[f3bruary:~/.config/VirtualBox]$ pacman -Q virtualbox                          
virtualbox 5.0.0-1

[f3bruary:~/.config/VirtualBox]$ pacman -Q virtualbox-host-modules             
virtualbox-host-modules 5.0.0-1

[f3bruary:~/.config/VirtualBox]$ yaourt -Ss virtualbox-ext-oracle                                                                                                        
aur/virtualbox-ext-oracle 5.0.0-1 [installed] (915)

[f3bruary:~/.config/VirtualBox]$ lsmod | grep vbox                            
vboxpci                24576  0
vboxnetadp             28672  0
vboxnetflt             28672  0
vboxdrv               385024  3 vboxnetadp,vboxnetflt,vboxpci

Last edited by f3bruary (2015-08-11 15:22:25)


-f3b

Offline

#2 2015-08-11 08:57:01

f3bruary
Member
From: /root
Registered: 2015-06-06
Posts: 58

Re: [SOLVED] Virtualbox not starting any Windows VMs after last update

If anyone could help me out I'd appreciate it


-f3b

Offline

#3 2015-08-11 11:09:23

Smoerrebroed
Member
From: Germany
Registered: 2011-07-24
Posts: 62

Re: [SOLVED] Virtualbox not starting any Windows VMs after last update

I had the exact same issue with one of the previous versions of VirtualBox. Fixed it by installing the matching version extension pack (download from VB site). Give it a try!

Cheers,

Smoerrebroed

Offline

#4 2015-08-11 12:32:19

f3bruary
Member
From: /root
Registered: 2015-06-06
Posts: 58

Re: [SOLVED] Virtualbox not starting any Windows VMs after last update

Smoerrebroed wrote:

I had the exact same issue with one of the previous versions of VirtualBox. Fixed it by installing the matching version extension pack (download from VB site). Give it a try!

Cheers,

Smoerrebroed

Doesn't solve it for me. I uninstalled the AUR version, then downloaded the one from the virtualbox site and installed it. Still the same.


-f3b

Offline

#5 2015-08-11 13:05:51

Potomac
Member
Registered: 2011-12-25
Posts: 381

Re: [SOLVED] Virtualbox not starting any Windows VMs after last update

you can start a windows VM but can you create and start a new windows virtual machine without problem ?

another workaround is to create a new windows virtual machine by re-using an existing windows virtual drive file and set the same settings

Last edited by Potomac (2015-08-11 13:07:23)

Offline

#6 2015-08-11 13:23:12

coruun
Member
Registered: 2014-10-23
Posts: 25

Re: [SOLVED] Virtualbox not starting any Windows VMs after last update

I had problems with Linux VMs, where the version of the guest modules was still 4.* while the host was at 5.0.

If that's your problem, too, I would try to downgrade to Virtualbox 4.* and uninstall the guest additions. Then you can upgrade to Virtualbox 5.0 and install the new guest additions from the recent iso image.

Offline

#7 2015-08-11 14:34:40

f3bruary
Member
From: /root
Registered: 2015-06-06
Posts: 58

Re: [SOLVED] Virtualbox not starting any Windows VMs after last update

Potomac wrote:

you can start a windows VM but can you create and start a new windows virtual machine without problem ?

another workaround is to create a new windows virtual machine by re-using an existing windows virtual drive file and set the same settings

I've tried that but that didn't work either. I think it has something to do with https://bugs.archlinux.org/task/45785?p … virtualbox


-f3b

Offline

#8 2015-08-11 14:40:33

f3bruary
Member
From: /root
Registered: 2015-06-06
Posts: 58

Re: [SOLVED] Virtualbox not starting any Windows VMs after last update

coruun wrote:

I had problems with Linux VMs, where the version of the guest modules was still 4.* while the host was at 5.0.

If that's your problem, too, I would try to downgrade to Virtualbox 4.* and uninstall the guest additions. Then you can upgrade to Virtualbox 5.0 and install the new guest additions from the recent iso image.

Everything is running as the same version, except host modules but I had the same issue before the last update of this package, so I don't think that's the issue.

community/virtualbox 5.0.0-1 [installed]
community/virtualbox-guest-iso 5.0.0-1 [installed]
community/virtualbox-host-dkms 5.0.0-1 [installed]
community/virtualbox-host-modules 5.0.0-2 [installed]
community/virtualbox-sdk 5.0.0-1 [installed]
local/virtualbox-ext-oracle 5.0.0-1 [installed]

-f3b

Offline

#9 2015-08-11 15:22:09

f3bruary
Member
From: /root
Registered: 2015-06-06
Posts: 58

Re: [SOLVED] Virtualbox not starting any Windows VMs after last update

Solved. In the logs I noticed it couldn't connect to the host sound driver. Disabled sound and they boot once again.


-f3b

Offline

Board footer

Powered by FluxBB