You are not logged in.

#1 2015-08-09 05:46:18

carmelo12341
Member
Registered: 2015-08-09
Posts: 4

[Solved]Steam locale problems

Well, im having a really weird issue with steam since today

I tried to open steam from the applications menu, but it didnt open. Then i tried to open steam from the console and i got this from the stderr

[carmelo12341@mylittlearch etc]$ steam
Running Steam on arch rolling 64-bit
STEAM_RUNTIME is enabled automatically
steam: loadlocale.c:130: _nl_intern_locale_data: Assertion `cnt < (sizeof (_nl_value_type_LC_COLLATE) / sizeof (_nl_value_type_LC_COLLATE[0]))' failed.
/home/carmelo12341/.local/share/Steam/steam.sh: line 756: 15444 Aborted                 (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$STEAMEXEPATH" "$@"

I think the problem is with my locales(the error says it), I edited the locale.gen file and commented all the locales and then run locale-gen again.
This time steam opened normally but then i received an error talking about the en_US locale.
I uncommented the en_US utf-8 line and then ran locale-gen again. The same error appeared.

Is this a bug? because i was able to use steam yesterday

this is my first topic by the way

Last edited by carmelo12341 (2015-08-09 20:34:33)

Offline

#2 2015-08-09 06:04:23

Tambalamba
Member
Registered: 2015-03-13
Posts: 45

Re: [Solved]Steam locale problems

Have you seen this thread: http://www.reddit.com/r/archlinux/comments/3g9dzf/

And welcome!

Last edited by Tambalamba (2015-08-09 06:44:03)

Offline

#3 2015-08-09 12:17:20

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: [Solved]Steam locale problems

Tambalamba wrote:

Have you seen this thread: http://www.reddit.com/r/archlinux/comments/3g9dzf/

And welcome!

EDIT 2: I enabled [multilib-testing] and it updated glibc which fixed Steam. Would it be a good idea to just leave it enabled if I'm using [testing]?

...

Yes, it would.
Partial upgrades are unsupported: https://wiki.archlinux.org/index.php/Pa … nsupported

Offline

#4 2015-08-09 14:55:55

carmelo12341
Member
Registered: 2015-08-09
Posts: 4

Re: [Solved]Steam locale problems

karol wrote:

Yes, it would.

i dont understand that, so if I install the glibc from testing, I must upgrade my whole system from testing?

Offline

#5 2015-08-09 15:44:15

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,326

Re: [Solved]Steam locale problems

Yes

Offline

#6 2015-08-09 18:44:40

th0rgall
Member
From: Belgium
Registered: 2015-08-09
Posts: 1
Website

Re: [Solved]Steam locale problems

Thank you Arch community! Enabling [multilib-testing] & doing a pacman -Syu also worked for me.

Offline

#7 2015-08-09 20:32:24

carmelo12341
Member
Registered: 2015-08-09
Posts: 4

Re: [Solved]Steam locale problems

Well... after some research i found out i had a considerable amount of packages from testing(partial upgrade), first I commented out the testing lines from /etc/pacman.conf, then downgraded those packages using

sudo pacman -Syyuu

after that, my installation was completely broken, I was unable to start any apps from the terminal, maybe because of the glibc downgrade. I restarted(bad idea i think, i should have locale-gen), i was unable to boot the arch installation, everything failed while starting. I got this last message after trying to boot

loadlocale.c:130: _nl_intern_locale_data: Assertion `cnt < (sizeof (_nl_value_type_LC_COLLATE) / sizeof (_nl_value_type_LC_COLLATE[0]))' failed

tried to start in recovery mode, the same message. Tried to chroot inside my installation using a live usb, the message appeared and nothing happened. The way I fixed this is while in the live usb arch.

1.run locale-gen in the live usb
2.added this line to the locale.conf file located at /etc
LC_COLLATE=en_US.UTF-8
2.remove the locale-archive file located at /usr/lib/locale from your mounted file system
3.copy the file generated from the locale-gen in the live usb to the same directory in your mounted file system

after all was working, i was able to chroot in my installation without problems.
I restarted and everything was working, including steam smile, but unfortunately steam didnt recognize my games, i had to install them again.

I ran locale-gen again just to be sure and then restart, everything was working, just as expected. >:)
Maybe the glibc in testing has bugs, im not sure smile

Offline

#8 2015-08-12 23:20:13

lessonz
Member
Registered: 2015-08-12
Posts: 1

Re: [Solved]Steam locale problems

I'm getting the same error but from a python app:

python: loadlocale.c:130: _nl_intern_locale_data: Assertion `cnt < (sizeof (_nl_value_type_LC_COLLATE) / sizeof (_nl_value_type_LC_COLLATE[0]))' failed.

I'd rather not enable multilib-testing if at all possible. I tried downgrading gcc-libs, gcc, glibc, and binutils, but that totally borked my system. I had to use the live disk and pacstrap to get it back. I also tried using locale-gen again, but I'm still seeing the same error. Any other ideas?

Offline

#9 2015-08-15 11:59:13

Streetwalker
Member
From: Israel
Registered: 2013-11-11
Posts: 8

Re: [Solved]Steam locale problems

After downgrading these packages you need to unset $LANG (export LANG="") and run locale-gen, I had the same problem trying to build Android today.

Offline

#10 2015-08-15 20:41:46

alexo81
Member
Registered: 2015-08-15
Posts: 3

Re: [Solved]Steam locale problems

I'm getting the same error but from pandoc:

pandoc: loadlocale.c:131: _nl_intern_locale_data: Assertion `cnt < (sizeof (_nl_value_type_LC_COLLATE) / sizeof (_nl_value_type_LC_COLLATE[0]))' failed.
Error in strsplit(version_info, "\n")[[1]] : subscript out of bounds

Because I'm on a fresh arch box, I've downgraded to:

binutils-2.25.1-1
gcc-5.2.0-1
gcc-libs-5.2.0-1,
glibc-2.21-4

from Arch Rollback Machine, then I ran

# locale-gen

and the error went away.  big_smile

[EDIT] before running locale-gen I had to unset $LANG (export LANG="") as suggested by @Streetwalker.

Last edited by alexo81 (2015-08-21 22:10:00)

Offline

#11 2015-08-17 19:03:49

mrbrich
Member
Registered: 2010-04-24
Posts: 42

Re: [Solved]Steam locale problems

I was having the same problem (with pandoc). I tried to downgrade the packages as suggested, but now my system is totally useless. I cannot even open a terminal window. I have not shut down, but I'm not sure what to do to fix this. Help please.

[UPDATE]: I fixed the problem by booting from LiveUSB and using pacstrap to undo the downgrade, so now I can boot my system again. But the original problem still remains:

# pandoc --version
pandoc: loadlocale.c:131: _nl_intern_locale_data: Assertion `cnt < (sizeof (_nl_value_type_LC_COLLATE) / sizeof (_nl_value_type_LC_COLLATE[0]))' failed.
Aborted (core dumped)

I don't know how to fix this.

Last edited by mrbrich (2015-08-18 14:59:33)

Offline

#12 2015-08-19 13:21:50

michimichi
Member
Registered: 2015-08-19
Posts: 3

Re: [Solved]Steam locale problems

I can confirm the problem with pandoc, and I have no solution for this problem. I too would rather not downgrade the mentioned packages.

# locale-gen 

did not help.

I hope someone comes up with a solution, since I rely heavily on pandoc for my work, and right now, I urgently need it...

Offline

#13 2015-08-25 16:03:52

alexo81
Member
Registered: 2015-08-15
Posts: 3

Re: [Solved]Steam locale problems

@michimichi, here is a workaround https://github.com/rstudio/rmarkdown/issues/498. I've tested it using the AUR's pandoc-static and I'm able to knit again.

Offline

Board footer

Powered by FluxBB