You are not logged in.

#1 2015-08-13 22:13:46

dbt0210
Member
Registered: 2015-08-13
Posts: 3

QEMU + libvirt + OVMF: KVM Gaming Setup (Windows + Radeon R9 390)

Hello everyone!

Let me try to keep this short. I am trying to get a KVM Gaming Setup up and running using:
qemu 2.3.0
libvirtd (libvirt) 1.2.18
the latest stable release of OVMF from here: https://www.kraxel.org/repos/jenkins/edk2/
Windows 8.1 as a guest
Sapphire R9 390 being passed through to the Windows VM

I basically followed this tutorial
https://wiki.archlinux.org/index.php/PC … h_via_OVMF

up to this point:
https://wiki.archlinux.org/index.php/PC … ermissions

Then, I installed OVMF in libvirt like this:
https://fedoraproject.org/wiki/Using_UEFI_with_QEMU

and used libvirt-manager to create a VM. The OS installed fine, I get output from the 390, but as soon as I install the latest Catalyst Driver (15.7.1), I get this:

http://i.imgur.com/rBP91Hl.png

A Bluescreen Error upon driver installation has presumably been fixed in a previous release of the driver and passthrough itself seems to be working fine, so I don't really know what else to check. Perhaps some of you have more experience with this than I do and could help me out a little.

Relevant System Specs:
Intel Xeon E3-1246 v3
MSI H97 PC Mate
SAPPHIRE NITRO Radeon R9 390 8GB

If you need any further information, feel free to ask, I will try to collect everything in this post.

Thank you for taking your time reading this (and possibly helping me out).

Offline

#2 2015-08-13 22:39:26

dbt0210
Member
Registered: 2015-08-13
Posts: 3

Re: QEMU + libvirt + OVMF: KVM Gaming Setup (Windows + Radeon R9 390)

For what it's worth - here is the detailed analysis of the crash dump (scroll down)

http://pastebin.com/S7bnYfQF

Offline

#3 2015-09-06 10:17:30

Journer
Member
Registered: 2015-09-06
Posts: 1

Re: QEMU + libvirt + OVMF: KVM Gaming Setup (Windows + Radeon R9 390)

By chance, did you get this working?  I'm considering a similar setup with Radeon R9 390X

Offline

#4 2015-09-12 21:01:06

dbt0210
Member
Registered: 2015-08-13
Posts: 3

Re: QEMU + libvirt + OVMF: KVM Gaming Setup (Windows + Radeon R9 390)

No, not yet. I just can't think of anything to solve this.
The problem seems to be Windows assigning the BasicDisplay.sys Driver to the video card. There seems to be a driver conflict somehow, but I have no idea how to prevent that from happening.

Offline

#5 2015-09-20 15:48:54

timoral
Member
Registered: 2015-09-20
Posts: 4

Re: QEMU + libvirt + OVMF: KVM Gaming Setup (Windows + Radeon R9 390)

I've also got the same problem.. Whatever I try, I still get a SYSTEM_THREAD_NOT_HANDLED(atikmdag.sys) BSOD..

Offline

#6 2016-09-25 11:33:32

nesk
Member
Registered: 2011-03-31
Posts: 169

Re: QEMU + libvirt + OVMF: KVM Gaming Setup (Windows + Radeon R9 390)

Did you try hv_vendor_id=whatever? https://wiki.archlinux.org/index.php/PC … indows_VMs


My minimalist setup (WIP): TTY on second GPU, startx, i3, dunst, neomutt, ranger, newsboat

Offline

Board footer

Powered by FluxBB