You are not logged in.

#1 2015-08-15 11:47:08

firekage
Member
From: Eastern Europe, Poland
Registered: 2013-06-30
Posts: 577

[SOLVED}Setting nvidia fan control speed does not work

Hi.

I would like to ask for help. My nvidia graphic card has bios that enables fan when temperature reaches 60 C degrees. I would like to manually do it. On Windows it is simple - i set it for 40% (around 900-920rpm), added this setting to nvidia control panel and enabled it to launch on windows start. With Arch i have problem. I did exacly as the nvidia archwiki says and it does not work.

I tried 3 method

1) I set 40% in nvidia control panel. Fan is spinning 40% but after log in, log out or reboot fan is not spinning (default bios setup of my graphic card, as i said earlier, it launches it when tere is more than 60 C degree).

2) I use KDE. I created ~/.xinitrc file with this:

nvidia-settings -a "[gpu:0]/GPUFanControlState=1" -a "[fan:0]/GPUCurrentFanSpeed=40"

It does not work after reboot. Fan stays at 0 rpm.

3) I created desktop entry like the nvidia archwiki says with this:

[firekage@arch_desktop autostart]$ cat ~/.config/autostart/nvidia-fan-speed.desktop 
[Desktop Entry]
Type=Application
Exec=nvidia-settings -a "[gpu:0]/GPUFanControlState=1" -a "[fan:0]/GPUCurrentFanSpeed=40"
X-GNOME-Autostart-enabled=true
X-KDE-Autostart-enabled=true
Name=nvidia-fan-speed

I added by myself 

X-KDE-Autostart-enabled=true

but it does not work.



In fact, i tried 3 described methods and none works. Could somebody help me? I would like to have this 40%, i know that the manufacturer did it but i want to cool it, cool vrm on it.


I forget to mention one thing - i set also 40% in nvidia fan control panel and did a

nvidia-settings --load-config-only 

in terminal but it does not work.


Is there a fix for it?


I did something more. I just simply put in terminal

nvidia-settings -a "[gpu:0]/GPUFanControlState=1" -a "[fan:0]/GPUCurrentFanSpeed=90"

but terminal gives me this:

  Attribute 'GPUFanControlState' (arch_desktop:0[gpu:0]) assigned value 1.


ERROR: The attribute 'GPUCurrentFanSpeed' specified in assignment '[fan:0]/GPUCurrentFanSpeed=90' cannot be assigned (it is a read-only attribute)

Foget to mention - i have enabled "Options" "Coolbits" "4" in xorg.conf.



Ok - sorry for making this topic. I found a way to fix it. It looks that with recent nvidia video drivers there was a change in naming. ArchWiki has this:

Exec=nvidia-settings -a "[gpu:0]/GPUFanControlState=1" -a "[fan:0]/GPUCurrentFanSpeed=n"

and the correct name according to nvidia developer zone is this

Exec=nvidia-settings -a "[gpu:0]/GPUFanControlState=1" -a "[fan:0]/GPUTargetFanSpeed=n"

Maybe somebody find this useful. I will try to modify nvidia archwiki page.

Thanks.  I can't express how good documentation has linux, arch, and corelated pages.


BTW - if you want to check nvidia fan control settings type in terminal:

nvidia-settings -q all | grep Fan

and you should have something like this:

[firekage@arch_desktop ~]$ nvidia-settings -q all | grep Fan
  Attribute 'GPUFanControlState' (arch_desktop:0[gpu:0]): 1.
    'GPUFanControlState' is a boolean attribute; valid values are: 1 (on/true) and 0 (off/false).
    'GPUFanControlState' can use the following target types: GPU.
  Attribute 'GPUTargetFanSpeed' (arch_desktop:0[fan:0]): 40.
    The valid values for 'GPUTargetFanSpeed' are in the range 0 - 100 (inclusive).
    'GPUTargetFanSpeed' can use the following target types: Fan.
  Attribute 'GPUCurrentFanSpeed' (arch_desktop:0[fan:0]): 40.
    The valid values for 'GPUCurrentFanSpeed' are in the range 0 - 100 (inclusive).
    'GPUCurrentFanSpeed' is a read-only attribute.
    'GPUCurrentFanSpeed' can use the following target types: Fan.
  Attribute 'GPUCurrentFanSpeedRPM' (arch_desktop:0[fan:0]): 915.
    'GPUCurrentFanSpeedRPM' is an integer attribute.
    'GPUCurrentFanSpeedRPM' is a read-only attribute.
    'GPUCurrentFanSpeedRPM' can use the following target types: Fan.
  Attribute 'GPUFanControlType' (arch_desktop:0[fan:0]): 2.
    'GPUFanControlType' is an integer attribute.
    'GPUFanControlType' is a read-only attribute.
    'GPUFanControlType' can use the following target types: Fan.
  Attribute 'GPUFanTarget' (arch_desktop:0[fan:0]): 0x00000007.
    'GPUFanTarget' is a bitmask attribute.
    'GPUFanTarget' is a read-only attribute.
    'GPUFanTarget' can use the following target types: Fan.
[firekage@arch_desktop ~]$ 

Today i learned something new big_smile

Last edited by firekage (2015-08-15 12:05:27)

Offline

Board footer

Powered by FluxBB