You are not logged in.

#1 2015-08-20 12:48:26

Glove An
Member
Registered: 2015-08-20
Posts: 3

how to hide tty1 login prompt?

The tty1 login prompt becomes unnecessary after I installed Xfce4 desktop environment, so I want to hide it when the computer is booting. As the arch wiki says that tty1 is pre-activated, I disable it by removing "getty@tty1.service" in the "/etc/systemd/system/getty.target.wants/" folder. However, this solution results in serious side effect, when I use Ctrl+Alt+F1 to switch from Xfce to tty1, there is no login prompt now. Is there any way to just hide tty1 login prompt on booting but show it when pressing Ctrl+Alt+F1? Thanks in advance.

Last edited by Glove An (2015-08-20 12:48:48)

Offline

#2 2015-08-20 12:50:33

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: how to hide tty1 login prompt?

What exactly are you trying to do? Do you boot automatically to X? Wouldn't switching to tty2 be good enough?

Offline

#3 2015-08-20 13:02:39

Awebb
Member
Registered: 2010-05-06
Posts: 6,047

Re: how to hide tty1 login prompt?

If you see tty1 before the display manager starts, then something is wrong with your display manager. Seeing tty1 means you see a login prompt. If you mean the verbose kernel and systemd output, then you are not looking at tty1. Describe what you see, when you see it and why it bothers you.

EDIT: Also read this http://0pointer.de/blog/projects/serial-console.html and return with a full grasp.

Last edited by Awebb (2015-08-20 13:03:53)

Offline

#4 2015-08-20 13:11:09

Glove An
Member
Registered: 2015-08-20
Posts: 3

Re: how to hide tty1 login prompt?

karol wrote:

What exactly are you trying to do? Do you boot automatically to X? Wouldn't switching to tty2 be good enough?

I configured lightdm to autologin. The occurence of tty1 login prompt is somewhat ugly so I want to hide it.

Offline

#5 2015-08-20 13:48:22

Glove An
Member
Registered: 2015-08-20
Posts: 3

Re: how to hide tty1 login prompt?

Awebb wrote:

If you see tty1 before the display manager starts, then something is wrong with your display manager. Seeing tty1 means you see a login prompt. If you mean the verbose kernel and systemd output, then you are not looking at tty1. Describe what you see, when you see it and why it bothers you.

EDIT: Also read this http://0pointer.de/blog/projects/serial-console.html and return with a full grasp.


I see tty1 login prompt before display manager starts. The diaplay manager I use is lightdm with lightdm-gtk-greeter.  The login prompt problem exists before I made any changes to lightdm configuration. Below is what I have changed to make lightdm autologin:
1. autologin-user=glove
2. autologin-user-timeout=0
3. session-wrapper=/etc/lightdm/Xsession
"glove" is my username and I added it to autologin group. After autologin is configured, I uninstalled lightdm-gtk-greeter.

The kernel is booted with "quiet" parameter. Below is what I see when booting:
1. Strings echoed by grub
    Loading Linux linux ...
    Loading initial ramdisk ...
2. Systemd Info
    starting version 224
3. Disk check
   /dev/sda3 ......
4. tty1 login prompt
5. tty7 xfce4 desktop

Offline

#6 2015-08-20 13:58:48

progandy
Member
Registered: 2012-05-17
Posts: 5,047

Re: how to hide tty1 login prompt?

I suggest you create a systemd service that executes "chvt 7" early in the boot process. Maybe also add a console=tty1 to your kernel line.


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#7 2015-08-20 13:59:20

Awebb
Member
Registered: 2010-05-06
Posts: 6,047

Re: how to hide tty1 login prompt?

How long do you see it? Why does it bother you?

Offline

#8 2015-08-20 14:05:19

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: how to hide tty1 login prompt?

Does disabling tty1 fixes all these issues? If so, why not use e.g. tty2?
You can also try https://wiki.archlinux.org/index.php/Silent_boot

Offline

#9 2015-11-26 13:53:31

qandak
Member
Registered: 2015-11-26
Posts: 2

Re: how to hide tty1 login prompt?

I have the same problem. Just want to get rid of Getty Login appearing, and staying for some two seconds, right between Plymouth and LightDM.
I'm sure something is going wrong. As the wiki says - "If a display manager is installed, it will be executed on the configured tty, replacing the getty login prompt. If there is no display manager, getty will prompt the user for credentials by itself in a text-based manner, and proceed to call login itself."

My setup: Xfce + LightDM + Plymouth.

First time I noticed unnessesary Getty prompt was after LightDM installation over clear install.
Changing display manager, autologin or removing Plymouth doesn't effect.

Maybe the problem is getty@tty1.service starting before display manager?
Unfortunately, I have no idea what to do in this case:

● getty@tty1.service - Getty on tty1
   Loaded: loaded (/usr/lib/systemd/system/getty@.service; enabled; vendor preset: enabled)
   Active: active (running) since Thu 2015-11-26 13:56:42 MSK; 2min 31s ago
     Docs: man:agetty(8)
           man:systemd-getty-generator(8)
           http://0pointer.de/blog/projects/serial-console.html
 Main PID: 370 (agetty)
   CGroup: /system.slice/system-getty.slice/getty@tty1.service
           └─370 /sbin/agetty --noclear tty1 linux

Nov 26 13:56:42 arch systemd[1]: Started Getty on tty1.
● lightdm.service - Light Display Manager
   Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; vendor preset: disabled)
   Active: active (running) since Thu 2015-11-26 13:56:43 MSK; 2min 46s ago
     Docs: man:lightdm(1)
 Main PID: 369 (lightdm)
   CGroup: /system.slice/lightdm.service
           ├─369 /usr/bin/lightdm
           └─390 /usr/lib/xorg-server/Xorg :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch

Nov 26 13:56:42 arch systemd[1]: Starting Light Display Manager...
Nov 26 13:56:43 arch systemd[1]: Started Light Display Manager.
Nov 26 13:56:47 arch lightdm[457]: pam_unix(lightdm-greeter:session): session opened for user lightdm by (uid=0)
Nov 26 13:56:54 arch lightdm[500]: pam_unix(lightdm:session): session opened for user qandak by (uid=0)

Offline

Board footer

Powered by FluxBB