You are not logged in.

#1 2006-04-01 09:51:11

lang2
Member
Registered: 2006-02-10
Posts: 386

mplayer: missing libXau.so.6

I didn't update mplayer or anyting. Just installed ddd in the past few days and
had a conflict with it. See
http://bbs.archlinux.org/viewtopic.php? … highlight=

But I didn't remove a file called that.

Can somebody tell me what package this file belongs to?

Thanks,

Offline

#2 2006-04-01 09:56:07

MAC!EK
Member
Registered: 2005-09-27
Posts: 265

Re: mplayer: missing libXau.so.6

$ locate libXau.so.6
/usr/lib/libXau.so.6.0.0
/usr/lib/libXau.so.6
$ pacman -Qo /usr/lib/libXau.so.6
/usr/lib/libXau.so.6 is owned by libxau 1.0.0-1

Offline

#3 2006-04-01 10:20:47

lang2
Member
Registered: 2006-02-10
Posts: 386

Re: mplayer: missing libXau.so.6

hmmm. Now come to think of it. I did try to install mythtv but failed because of another conflict. That might be the cause of it??

Will try re-install libXaud later.

Thanks,

Offline

#4 2006-04-01 11:35:05

Richie
Member
From: Leverkusen, Germany
Registered: 2003-12-10
Posts: 22

Re: mplayer: missing libXau.so.6

When something like this happens I always pacman -Ss for the name of the file. Most of the time I find what was missing.

Offline

#5 2006-04-01 23:51:34

lang2
Member
Registered: 2006-02-10
Posts: 386

Re: mplayer: missing libXau.so.6

OK. I tried to reinstall libxau by

pacman -S libxau

pacman gave me two package to be installed. I said yes and got a conflict again: What should I do?

The actual log:

Targets: xproto-7.0.4-2 libxau-1.0.0-1

Total Package Size:   0.1 MB

Proceed with upgrade? [Y/n] y

checking package integrity... done.
loading package data... done.
checking for file conflicts...
error: the following file conflicts were found:
  xproto: /etc/profile.d/xorg.sh: exists in filesystem
  xproto: /usr/include/X11/DECkeysym.h: exists in filesystem
  xproto: /usr/include/X11/HPkeysym.h: exists in filesystem
  xproto: /usr/include/X11/Sunkeysym.h: exists in filesystem
  xproto: /usr/include/X11/X.h: exists in filesystem
  xproto: /usr/include/X11/XF86keysym.h: exists in filesystem
  xproto: /usr/include/X11/XWDFile.h: exists in filesystem
  xproto: /usr/include/X11/Xalloca.h: exists in filesystem
  xproto: /usr/include/X11/Xarch.h: exists in filesystem
  xproto: /usr/include/X11/Xatom.h: exists in filesystem
  xproto: /usr/include/X11/Xdefs.h: exists in filesystem
  xproto: /usr/include/X11/Xfuncproto.h: exists in filesystem
  xproto: /usr/include/X11/Xfuncs.h: exists in filesystem
  xproto: /usr/include/X11/Xmd.h: exists in filesystem
  xproto: /usr/include/X11/Xos.h: exists in filesystem
  xproto: /usr/include/X11/Xos_r.h: exists in filesystem
  xproto: /usr/include/X11/Xosdefs.h: exists in filesystem
  xproto: /usr/include/X11/Xpoll.h: exists in filesystem
  xproto: /usr/include/X11/Xproto.h: exists in filesystem
  xproto: /usr/include/X11/Xprotostr.h: exists in filesystem
  xproto: /usr/include/X11/Xthreads.h: exists in filesystem
  xproto: /usr/include/X11/ap_keysym.h: exists in filesystem
  xproto: /usr/include/X11/keysym.h: exists in filesystem
  xproto: /usr/include/X11/keysymdef.h: exists in filesystem
  libxau: /usr/include/X11/Xauth.h: exists in filesystem


errors occurred, no packages were upgraded.
[/code]

Offline

#6 2006-04-02 00:47:46

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

Re: mplayer: missing libXau.so.6

just force it.

pacman -Sf libxau xproto

Offline

#7 2006-04-02 09:24:43

lang2
Member
Registered: 2006-02-10
Posts: 386

Re: mplayer: missing libXau.so.6

Forcing it seems to work for mplayer. Thanks,

Offline

#8 2006-04-02 15:50:10

JGC
Developer
Registered: 2003-12-03
Posts: 1,660

Re: mplayer: missing libXau.so.6

Make sure your system is up2date, looks like you're still on xorg 6.8.2.

Offline

#9 2006-04-02 16:02:23

lang2
Member
Registered: 2006-02-10
Posts: 386

Re: mplayer: missing libXau.so.6

JGC wrote:

Make sure your system is up2date, looks like you're still on xorg 6.8.2.

which is true. I had bad experience with the later version of xorg + nvidia accelerated driver so was reluctant to upgrade. Is it a bad bad thing?

Offline

#10 2006-04-02 23:54:18

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: mplayer: missing libXau.so.6

lang2 wrote:
JGC wrote:

Make sure your system is up2date, looks like you're still on xorg 6.8.2.

which is true. I had bad experience with the later version of xorg + nvidia accelerated driver so was reluctant to upgrade. Is it a bad bad thing?

It's a bad thing especially if you upgrade/install packages as they assume that you have xorg7 installed. If you stay with xorg 6.8.2, you risk having problems with dependencies like this one. IMHO, I would suggest to upgrade to xorg 7 and to fix the nvidia problem.  Maybe there was a bug that has been fixed since then.

Offline

Board footer

Powered by FluxBB