You are not logged in.

#1 2015-08-31 03:49:12

UniqUsrNam
Member
Registered: 2015-05-13
Posts: 2

[Solved] Installing on BTRFS raid0, loading with EFIStub

My computer uses UEFI/GPT to boot.

I have 2 SSD's and 2 HDD's.

- Using GParted

I created a 512M FAT32 partition on one of the SSD's.
I also used the remaining space on this drive to make a BTRFS partition.
I made a partition of the same size and alignment on the other SSD.
I also made a BTRFS partition on both HDD's using their full space.

/dev/sda1 and /dev/sdb1 are the HDD's
/dev/sdc1 is the esp flagged with esp,boot
/dev/sdc2 and /dev/sdd1 are the SDD BTRFS partitions

- Using Arch Installer

#made my raids
mkfs.btrfs -f -L "Arch" -m raid0 -d raid0 /dev/sdc2 /dev/sdd1
mkfs.btrfs -f -L "Data" -m raid0 -d raid0 /dev/sda1 /dev/sdb1

# mount ROOT
mount /dev/sdc2 /mnt
btrfs subvolume create ROOT
umount /dev/sdc2
mount -o noatime,discard,ssd,compress=lzo,space_cache,subvol=ROOT /dev/sdc2 /mnt

#mount data,var,tmp from HDD raid to ROOT
mkdir var
mkdir tmp
mkdir data

mount /dev/sda1 /mnt/tmp
cd /mnt/tmp

btrfs subvolume create var
btrfs subvolume create tmp
btrfs subvolume create data

cd /mnt
umount /dev/sda1

mount -o noatime,autodefrag,compress=lzo,space_cache,subvol=var /dev/sda1 /mnt/var
mount -o noatime,autodefrag,compress=lzo,space_cache,subvol=tmp /dev/sda1 /mnt/tmp
mount -o noatime,autodefrag,compress=lzo,space_cache,subvol=data /dev/sda1 /mnt/data

#mount boot
mount /dev/sdc1 /mnt/boot

#create subvolumes on SDD raid under ROOT
btrfs subvolume create home
btrfs subvolume create usr
btrfs subvolume create etc
btrfs subvolume create mnt
btrfs subvolume create opt
btrfs subvolume create root

#install
pacstrap -i /mnt base base-devel btrfs-progs
genfstab -U -p /mnt >> /mnt/etc/fstab
arch-chroot /mnt

#did various unrelated tasks (timezone, locale, etc)

efibootmgr -d /dev/sdc -p 1 -c -L "Arch Linux" -l /vmlinuz-linux -u "root=/dev/sdc2 rw initrd=/initramfs-linux.img"

#modified mkinitcpio.conf
- removed fschk hook
- added btrfs hook
- tried with and without user hook

mkinitcpio -p linux

ctl-d
reboot

When the system rebooted it says that it loaded the boot partiton
However it didn't find /sbin/init

Last edited by UniqUsrNam (2015-09-01 04:24:57)

Offline

#2 2015-08-31 12:28:01

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 5,892
Website

Re: [Solved] Installing on BTRFS raid0, loading with EFIStub

You need to set the subvolume options and UUID on your kernel command line.

efibootmgr -d /dev/sdc -p 1 -c -L "Arch Linux" -l /vmlinuz-linux -u "root=UUID=$UUID rootflags=subvol=ROOT rw initrd=/initramfs-linux.img"

I've only done this once and it was a while ago so I may have the details wrong here.


There are two ways of constructing a software design: one way is to make it so simple that there are obviously no deficiencies and the other way is to make it so complicated that there are no obvious deficiencies.

— C.A.R. Hoare, The 1980 ACM Turing Award Lecture

Offline

Board footer

Powered by FluxBB