You are not logged in.

#1 2015-09-14 16:33:51

jaybruh
Member
Registered: 2015-09-14
Posts: 5

No sound -- Tried every possible solution.

Hello all,

I can not get my headphones/speakers to emit any sound. This seems to be the same on Arch and even Ubuntu. I have tried configuring the asoundrc file, changing the default sound device, unmuting ALSA, uninstalling pulseaudio, testing with aplay -D plughw, I    I have even tried reinstalling, nothing will work, I have read the ALSA docs as well.

My speakers have worked once when I plugged a different monitor in, never again.

Debugging information

aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: CA0132 Analog [CA0132 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: CA0132 Digital [CA0132 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1

aplay -L

null
    Discard all samples (playback) or generate zero samples (capture)
default:CARD=PCH
    HDA Intel PCH, CA0132 Analog
    Default Audio Device
sysdefault:CARD=PCH
    HDA Intel PCH, CA0132 Analog
    Default Audio Device
front:CARD=PCH,DEV=0
    HDA Intel PCH, CA0132 Analog
    Front speakers
surround21:CARD=PCH,DEV=0
    HDA Intel PCH, CA0132 Analog
    2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=PCH,DEV=0
    HDA Intel PCH, CA0132 Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=PCH,DEV=0
    HDA Intel PCH, CA0132 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=PCH,DEV=0
    HDA Intel PCH, CA0132 Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=PCH,DEV=0
    HDA Intel PCH, CA0132 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=PCH,DEV=0
    HDA Intel PCH, CA0132 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=PCH,DEV=0
    HDA Intel PCH, CA0132 Digital
    IEC958 (S/PDIF) Digital Audio Output
hdmi:CARD=NVidia,DEV=0
    HDA NVidia, HDMI 0
    HDMI Audio Output
hdmi:CARD=NVidia,DEV=1
    HDA NVidia, HDMI 1
    HDMI Audio Output
hdmi:CARD=NVidia,DEV=2
    HDA NVidia, HDMI 2
    HDMI Audio Output
hdmi:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 3
    HDMI Audio Output

amixer

Simple mixer control 'Master',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 99
  Mono:
  Front Left: Playback 94 [95%] [4.00dB] [on]
  Front Right: Playback 94 [95%] [4.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Surround',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Mic SVM',0
  Capabilities: cswitch cswitch-joined
  Capture channels: Mono
  Mono: Capture [on]
Simple mixer control 'Mic1-Boost (30dB)',0
  Capabilities: cswitch cswitch-joined
  Capture channels: Mono
  Mono: Capture [off]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined cswitch cswitch-joined
  Playback channels: Mono
  Capture channels: Mono
  Mono: Playback [off] Capture [off]
Simple mixer control 'IEC958 Default PCM',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 99
  Front Left: Capture 99 [100%] [9.00dB] [on]
  Front Right: Capture 99 [100%] [9.00dB] [on]
Simple mixer control 'AMic1/DMic',0
  Capabilities: cswitch cswitch-joined
  Capture channels: Mono
  Mono: Capture [off]
Simple mixer control 'AMic1/DMic Auto Detect',0
  Capabilities: cswitch cswitch-joined
  Capture channels: Mono
  Mono: Capture [off]
Simple mixer control 'Analog-Mic2',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 99
  Front Left: Capture 90 [91%] [0.00dB] [on]
  Front Right: Capture 90 [91%] [0.00dB] [on]
Simple mixer control 'CrystalVoice',0
  Capabilities: cswitch cswitch-joined
  Capture channels: Mono
  Mono: Capture [off]
Simple mixer control 'Crystalizer',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Dialog Plus',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Echo Cancellation',0
  Capabilities: cswitch cswitch-joined
  Capture channels: Mono
  Mono: Capture [off]
Simple mixer control 'Equalizer',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'HP/Speaker',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'HP/Speaker Auto Detect',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Noise Reduction',0
  Capabilities: cswitch cswitch-joined
  Capture channels: Mono
  Mono: Capture [on]
Simple mixer control 'PlayEnhancement',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Smart Volume',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Voice Focus',0
  Capabilities: cswitch cswitch-joined
  Capture channels: Mono
  Mono: Capture [on]
Simple mixer control 'VoiceFX',0
  Capabilities: cenum
  Items: 'Neutral' 'Female2Male' 'Male2Female' 'ScrappyKid' 'Elderly' 'Orc' 'Elf' 'Dwarf' 'AlienBrute' 'Robot' 'Marine' 'Emo' 'DeepVoice' 'Munchkin'
  Item0: 'Neutral'
Simple mixer control 'What U Hear',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 99
  Front Left: Capture 90 [91%] [0.00dB] [on]
  Front Right: Capture 90 [91%] [0.00dB] [on]
Simple mixer control 'X-Bass',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]

lsmod | grep snd

snd_hda_codec_hdmi     53248  1
snd_hda_codec_ca0132    45056  1
snd_hda_intel          28672  5
snd_hda_controller     28672  1 snd_hda_intel
snd_soc_rt5640         86016  0
snd_hda_codec          98304  4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_controller,snd_hda_codec_ca0132
snd_soc_rl6231         16384  1 snd_soc_rt5640
snd_hda_core           28672  4 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_controller,snd_hda_codec_ca0132
snd_soc_core          159744  1 snd_soc_rt5640
snd_compress           20480  1 snd_soc_core
snd_hwdep              16384  1 snd_hda_codec
snd_pcm_dmaengine      16384  1 snd_soc_core
snd_pcm                90112  7 snd_soc_rt5640,snd_soc_core,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_controller,snd_pcm_dmaengine
snd_timer              28672  1 snd_pcm
snd                    69632  19 snd_soc_core,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_hda_codec,snd_hda_intel,snd_compress,snd_hda_codec_ca0132
soundcore              16384  1 snd
regmap_i2c             16384  1 snd_soc_rt5640
snd_soc_sst_acpi       16384  0
i2c_core               49152  9 drm,i2c_i801,snd_soc_rt5640,i2c_hid,i2c_designware_platform,regmap_i2c,drm_kms_helper,i2c_algo_bit,nouveau

Offline

#2 2015-09-14 16:51:59

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,097

Re: No sound -- Tried every possible solution.

Judging from the codec you have a creative card, they are notorious for having issues like that because creative provides zero support for their cards on linux. From what I gather from various google results one way to temporarily initialize them is to start up windows and then reboot into linux. But you'd have to do that each time you turn off your computer. Some other thing that might help is loading intel_hda with the position fix somewhere in modprobe.d

snd_hda_intel position_fix=1

but as it stands, they are hard to get working. As it happens my next build will include a creative onboard (the mobo had other features which did outweigh the shitty card) so I might investigate somewhat more in depth, if it doesn't work I'm probably gonna buy a supported ASUS card, which is another option short of hoping creative provides enough information/the ALSA devs figure something out

Last edited by V1del (2015-09-14 16:56:01)

Offline

#3 2015-09-14 18:43:32

jaybruh
Member
Registered: 2015-09-14
Posts: 5

Re: No sound -- Tried every possible solution.

V1del wrote:

Judging from the codec you have a creative card, they are notorious for having issues like that because creative provides zero support for their cards on linux. From what I gather from various google results one way to temporarily initialize them is to start up windows and then reboot into linux. But you'd have to do that each time you turn off your computer. Some other thing that might help is loading intel_hda with the position fix somewhere in modprobe.d

snd_hda_intel position_fix=1

but as it stands, they are hard to get working. As it happens my next build will include a creative onboard (the mobo had other features which did outweigh the shitty card) so I might investigate somewhat more in depth, if it doesn't work I'm probably gonna buy a supported ASUS card, which is another option short of hoping creative provides enough information/the ALSA devs figure something out


Thank you for the help, I had no idea it was a driver issue.

It's strange since the kernel introduced this

http://www.phoronix.com/scan.php?page=n … px=MTEwNTg

Perhaps there are drivers out there for this card

Offline

#4 2015-09-14 18:50:16

ThreeMonkeys
Member
Registered: 2015-07-10
Posts: 14

Re: No sound -- Tried every possible solution.

Do you know which card model you are using? Mine is a Creative Soundblaster Z, and I never achieved to use it with Linux.

Offline

#5 2015-09-14 19:01:07

jaybruh
Member
Registered: 2015-09-14
Posts: 5

Re: No sound -- Tried every possible solution.

ThreeMonkeys wrote:

Do you know which card model you are using? Mine is a Creative Soundblaster Z, and I never achieved to use it with Linux.


Creative Sound Core3D

Offline

#6 2015-09-14 19:30:05

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,097

Re: No sound -- Tried every possible solution.

Yes to the extent the driver can provide support that's what you get. I also read the phoronix article but it looks like it laid itself out a bit too optimistically if you read the actual commit message which introduced the support it already says only the most basic stuff works and if you google past the phoronix link you will find quite a few bug reports that are unresolved to this day. Apparently the digital out works, the analog ports are up to complete chance if they decide to work or not

Offline

#7 2015-09-14 19:38:41

jaybruh
Member
Registered: 2015-09-14
Posts: 5

Re: No sound -- Tried every possible solution.

V1del wrote:

Yes to the extent the driver can provide support that's what you get. I also read the phoronix article but it looks like it laid itself out a bit too optimistically if you read the actual commit message which introduced the support it already says only the most basic stuff works and if you google past the phoronix link you will find quite a few bug reports that are unresolved to this day. Apparently the digital out works, the analog ports are up to complete chance if they decide to work or not

Interesting, by digital that is an S/PDIF port? whereas analog is the 3.5mm jack?

Are you aware if the kernel supports t the ASUS Xonar DG? From the ALSA support page, it shows support is available from kernel 3.1.

Offline

#8 2015-09-14 19:47:05

Roken
Member
From: UK
Registered: 2012-01-16
Posts: 1,077

Re: No sound -- Tried every possible solution.

Honestly, after more years (yes years) than I care to remember trying to get a Creative card to function as I wanted, I removed it and went to onboard. Not had a problem since.


[img=Speedtest]http://www.speedtest.net/my-result/5145583518[/img]

Ryzen 1800x 8 core/16 thread - GTX 1070 8Gb, Asus ROG STRIX B350-F, 16Gb Corsair DDR4, Cooler Master N300 chassis, 6 HD (1 NvME PCI, 2SSD, 3Spinners) + 1 x optical.
Linux user #545703

Offline

#9 2015-09-14 19:49:57

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,097

Re: No sound -- Tried every possible solution.

The sad thing is, this card is an onboard one. My first pc on which I put linux on had a Xi-Fi which worked pretty well though... an apparently the emuk series of creative cards had a completely open and very capable driver from what I gather

@Jaybruh
Yes s/PDIF should work, dunno about the ASUS card but if alsa wiki says they work that's probably true, there were a few people here that had working ASUS cards no idea as to which the exact model is. I'm going to look into this more in-depth when I get to build my new PC which is about a month from now, maybe the creative situation has bettered then

Last edited by V1del (2015-09-14 19:56:02)

Offline

#10 2015-09-15 14:39:06

pigiron
Member
From: USA
Registered: 2009-07-14
Posts: 150

Re: No sound -- Tried every possible solution.

A small glimmer of hope comes in version 4.2 of the kernel. They changed the CA1032 quirk code and added a quirk specific to the Alienware 15. You might give that a shot when it arrives. Even so, Takashi (ALSA dev) says the following:

Even with this fix, not all stuff works perfectly yet, mainly because of the badly written ca0132 driver code -- it has too many implicit assumptions of pin configs and maps.  Nevertheless, this is a small good step forward.

Offline

Board footer

Powered by FluxBB