You are not logged in.

#1 2015-09-17 23:31:31

whoop
Member
Registered: 2009-05-28
Posts: 101

[SOLVED] ncurses, readline update error

I get an error with updating today:

(  5/184) upgrading ncurses                                        [#####################################] 100%
(  6/184) upgrading readline                                       [#####################################] 100%
/usr/bin/bash: error while loading shared libraries: libncursesw.so.5: cannot open shared object file: No such file or directory
error: command failed to execute correctly

Any ideas?

Last edited by whoop (2015-09-18 00:07:51)

Offline

#2 2015-09-17 23:53:49

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 3,950

Re: [SOLVED] ncurses, readline update error

Posting the command you ran and the full output would be a start.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#3 2015-09-17 23:55:30

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,046
Website

Re: [SOLVED] ncurses, readline update error


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#4 2015-09-18 00:03:52

whoop
Member
Registered: 2009-05-28
Posts: 101

Re: [SOLVED] ncurses, readline update error

slithery wrote:

Posting the command you ran and the full output would be a start.

pacman -Syu

[2015-09-18 01:14] [PACMAN] Running 'pacman -Syu'
[2015-09-18 01:14] [PACMAN] synchronizing package lists
[2015-09-18 01:14] [PACMAN] starting full system upgrade
[2015-09-18 01:15] [ALPM] transaction started
[2015-09-18 01:15] [ALPM] upgraded linux-api-headers (4.0-1 -> 4.1.4-1)
[2015-09-18 01:15] [ALPM] upgraded tzdata (2015e-1 -> 2015f-1)
[2015-09-18 01:15] [ALPM] warning: /etc/locale.gen installed as /etc/locale.gen.pacnew
[2015-09-18 01:15] [ALPM] upgraded glibc (2.21-4 -> 2.22-3)
[2015-09-18 01:16] [ALPM-SCRIPTLET] Generating locales...
[2015-09-18 01:16] [ALPM-SCRIPTLET]   en_US.ISO-8859-1... done
[2015-09-18 01:16] [ALPM-SCRIPTLET]   en_US.UTF-8... done
[2015-09-18 01:16] [ALPM-SCRIPTLET] Generation complete.
[2015-09-18 01:16] [ALPM] upgraded gcc-libs (5.2.0-1 -> 5.2.0-2)
[2015-09-18 01:16] [ALPM] upgraded ncurses (5.9-7 -> 6.0-3)
[2015-09-18 01:16] [ALPM] upgraded readline (6.3.008-1 -> 6.3.008-2)
[2015-09-18 01:16] [ALPM-SCRIPTLET] /usr/bin/bash: error while loading shared libraries: libncursesw.so.5: cannot open shared object file: No such file or directory
[2015-09-18 01:16] [ALPM] upgraded bash (4.3.039-1 -> 4.3.042-2)
[2015-09-18 01:16] [ALPM] upgraded gpm (1.20.7-4 -> 1.20.7-5)
[2015-09-18 01:16] [ALPM] upgraded libxcb (1.11-1 -> 1.11.1-1)
[2015-09-18 01:16] [ALPM] upgraded aalib (1.4rc5-10 -> 1.4rc5-11)
[2015-09-18 01:16] [ALPM] upgraded aspell (0.60.6.1-2 -> 0.60.6.1-3)
[2015-09-18 01:16] [ALPM] upgraded pcre (8.37-2 -> 8.37-4)
[2015-09-18 01:16] [ALPM] upgraded less (479-1 -> 481-2)
[2015-09-18 01:16] [ALPM] upgraded texinfo (5.2-3 -> 5.2-4)
[2015-09-18 01:16] [ALPM] upgraded gc (7.4.2-2 -> 7.4.2-3)
[2015-09-18 01:16] [ALPM] upgraded guile (2.0.11-2 -> 2.0.11-3)
[2015-09-18 01:16] [ALPM] upgraded autogen (5.18.4-1 -> 5.18.5-1)
[2015-09-18 01:16] [ALPM] upgraded babl (0.1.10-2 -> 0.1.12-1)
[2015-09-18 01:16] [ALPM] upgraded libutil-linux (2.26.2-1 -> 2.27-2)
[2015-09-18 01:16] [ALPM] upgraded geoip-database (20150602-1 -> 20150804-1)
[2015-09-18 01:16] [ALPM] upgraded libldap (2.4.41-1 -> 2.4.42-2)
[2015-09-18 01:16] [ALPM] upgraded bind-tools (9.10.2.P2-1 -> 9.10.3-1)
[2015-09-18 01:16] [ALPM] upgraded libgpg-error (1.19-1 -> 1.20-1)
[2015-09-18 01:16] [ALPM] upgraded libgcrypt (1.6.3-2 -> 1.6.4-1)
[2015-09-18 01:16] [ALPM] upgraded libsystemd (222-1 -> 225-1)
[2015-09-18 01:16] [ALPM] upgraded libdbus (1.8.18-1 -> 1.10.0-2)
[2015-09-18 01:16] [ALPM] upgraded dbus (1.8.18-1 -> 1.10.0-2)
[2015-09-18 01:16] [ALPM] upgraded bluez (5.32-1 -> 5.34-1)
[2015-09-18 01:16] [ALPM] upgraded bluez-libs (5.32-1 -> 5.34-1)
[2015-09-18 01:16] [ALPM] upgraded libtasn1 (4.5-1 -> 4.7-1)
[2015-09-18 01:16] [ALPM] upgraded gnutls (3.4.2-1 -> 3.4.5-1)
[2015-09-18 01:16] [ALPM] upgraded libassuan (2.2.0-1 -> 2.2.1-1)
[2015-09-18 01:16] [ALPM] upgraded pinentry (0.9.1-1 -> 0.9.5-2)
[2015-09-18 01:16] [ALPM] upgraded gnupg (2.1.6-1 -> 2.1.8-2)
[2015-09-18 01:16] [ALPM] upgraded gpgme (1.5.4-1 -> 1.6.0-1)
[2015-09-18 01:16] [ALPM] upgraded libidn (1.30-1 -> 1.32-1)
[2015-09-18 01:16] [ALPM] upgraded ca-certificates-mozilla (3.19.2-2 -> 3.20-1)
[2015-09-18 01:16] [ALPM] upgraded curl (7.43.0-1 -> 7.44.0-1)
[2015-09-18 01:16] [ALPM] upgraded sqlite (3.8.10.2-1 -> 3.8.11.1-3)
[2015-09-18 01:16] [ALPM] upgraded totem-plparser (3.10.4-1 -> 3.10.5-1)
[2015-09-18 01:16] [ALPM] upgraded hicolor-icon-theme (0.13-1 -> 0.15-1)
[2015-09-18 01:16] [ALPM] upgraded pam (1.2.0-1 -> 1.2.1-1)
[2015-09-18 01:16] [ALPM] upgraded util-linux (2.26.2-1 -> 2.27-2)
[2015-09-18 01:16] [ALPM] upgraded libtracker-sparql (1.4.0-2 -> 1.4.1-1)
[2015-09-18 01:16] [ALPM] upgraded libsecret (0.18.2-1 -> 0.18.3-1)
[2015-09-18 01:16] [ALPM] upgraded libpng (1.6.16-1 -> 1.6.18-1)
[2015-09-18 01:16] [ALPM] upgraded graphite (1:1.2.4-1 -> 1:1.3.2-1)
[2015-09-18 01:16] [ALPM] upgraded harfbuzz (0.9.41-1 -> 1.0.3-1)
[2015-09-18 01:16] [ALPM] upgraded freetype2 (2.6-1 -> 2.6-2)
[2015-09-18 01:16] [ALPM] upgraded fontconfig (2.11.1-1 -> 2.11.1-2)
[2015-09-18 01:16] [ALPM-SCRIPTLET] updating font cache... done.
[2015-09-18 01:16] [ALPM] upgraded libcdio (0.93-1 -> 0.93-2)
[2015-09-18 01:16] [ALPM] upgraded kbd (2.0.2-1 -> 2.0.3-1)
[2015-09-18 01:16] [ALPM] upgraded kmod (21-1 -> 21-2)
[2015-09-18 01:16] [ALPM] upgraded hwids (20150129-1 -> 20150717-1)
[2015-09-18 01:16] [ALPM] upgraded libseccomp (2.2.0-1 -> 2.2.3-1)
[2015-09-18 01:17] [ALPM] upgraded systemd (222-1 -> 225-1)
[2015-09-18 01:17] [ALPM] upgraded nspr (4.10.8-1 -> 4.10.9-1)
[2015-09-18 01:17] [ALPM] upgraded polkit (0.112-4 -> 0.113-2)
[2015-09-18 01:17] [ALPM] upgraded gvfs (1.24.1-2 -> 1.24.2-1)
[2015-09-18 01:17] [ALPM] upgraded lame (3.99.5-2 -> 3.99.5-3)
[2015-09-18 01:17] [ALPM] upgraded jasper (1.900.1-13 -> 1.900.1-14)
[2015-09-18 01:17] [ALPM] upgraded gdk-pixbuf2 (2.31.5-1 -> 2.31.6-1)
[2015-09-18 01:17] [ALPM] upgraded libcaca (0.99.beta18-2 -> 0.99.beta18-3)
[2015-09-18 01:17] [ALPM] upgraded libdrm (2.4.62-1 -> 2.4.65-1)
[2015-09-18 01:17] [ALPM] upgraded libedit (20150325_3.1-1 -> 20150325_3.1-2)
[2015-09-18 01:17] [ALPM] upgraded llvm-libs (3.6.2-1 -> 3.6.2-4)
[2015-09-18 01:17] [ALPM] upgraded mesa (10.6.2-1 -> 10.6.7-1)
[2015-09-18 01:17] [ALPM] upgraded mesa-libgl (10.6.2-1 -> 10.6.7-1)
[2015-09-18 01:17] [ALPM] upgraded libxi (1.7.4-1 -> 1.7.5-1)
[2015-09-18 01:17] [ALPM] upgraded libgusb (0.2.4-1 -> 0.2.6-1)
[2015-09-18 01:17] [ALPM] upgraded colord (1.2.9-3 -> 1.2.12-1)
[2015-09-18 01:17] [ALPM] upgraded libcups (2.0.3-1 -> 2.1.0-1)
[2015-09-18 01:17] [ALPM] upgraded libdatrie (0.2.8-1 -> 0.2.9-1)
[2015-09-18 01:17] [ALPM] upgraded libthai (0.1.21-1 -> 0.1.22-1)
[2015-09-18 01:17] [ALPM] upgraded tdb (1.3.6-1 -> 1.3.7-1)
[2015-09-18 01:17] [ALPM] upgraded brasero (3.12.0-1 -> 3.12.1-1)
[2015-09-18 01:17] [ALPM] upgraded python (3.4.3-2 -> 3.4.3-3)
[2015-09-18 01:17] [ALPM] installed python-packaging (15.3-1)
[2015-09-18 01:17] [ALPM] upgraded python-setuptools (1:18.0.1-1 -> 1:18.3.1-1)
[2015-09-18 01:17] [ALPM] upgraded cython (0.22.1-1 -> 0.23.2-1)
[2015-09-18 01:17] [ALPM] upgraded brltty (5.2-3 -> 5.2-4)
[2015-09-18 01:17] [ALPM] upgraded btrfs-progs (4.1.2-1 -> 4.2-1)
[2015-09-18 01:17] [ALPM] upgraded cairomm (1.10.0-3 -> 1.11.2-1)
[2015-09-18 01:17] [ALPM] upgraded libevdev (1.4.3-1 -> 1.4.4-1)
[2015-09-18 01:17] [ALPM] upgraded libinput (0.20.0-1 -> 1.0.1-1)
[2015-09-18 01:17] [ALPM] upgraded iso-codes (3.57-1 -> 3.61-1)
[2015-09-18 01:17] [ALPM] upgraded caribou (0.4.18.1-1 -> 0.4.18.1-2)
[2015-09-18 01:17] [ALPM] upgraded fribidi (0.19.6-2 -> 0.19.7-1)
[2015-09-18 01:17] [ALPM] installed libsoxr (0.1.2-1)
[2015-09-18 01:17] [ALPM] upgraded libssh (0.7.1-1 -> 0.7.1-2)
[2015-09-18 01:17] [ALPM] upgraded libva (1.6.0-1 -> 1.6.1-1)
[2015-09-18 01:17] [ALPM] upgraded libvdpau (1.1-1 -> 1.1.1-1)
[2015-09-18 01:17] [ALPM] upgraded libx264 (2:148.20150717-1 -> 2:148.20150725-1)
[2015-09-18 01:17] [ALPM] upgraded ffmpeg (1:2.7.2-1 -> 1:2.8-1)
[2015-09-18 01:17] [ALPM] upgraded chromaprint (1.1-2 -> 1.2-1)
[2015-09-18 01:17] [ALPM] upgraded clutter-gst (3.0.8-1 -> 3.0.10-1)
[2015-09-18 01:18] [ALPM] upgraded dhcpcd (6.9.0-1 -> 6.9.3-1)
[2015-09-18 01:18] [ALPM] upgraded nss (3.19.2-2 -> 3.20-1)
[2015-09-18 01:18] [ALPM] upgraded ecryptfs-utils (106-1 -> 108-1)
[2015-09-18 01:18] [ALPM] upgraded efivar (0.20-1 -> 0.21-1)
[2015-09-18 01:18] [ALPM] upgraded harfbuzz-icu (0.9.41-1 -> 1.0.3-1)
[2015-09-18 01:18] [ALPM] upgraded hunspell (1.3.3-1 -> 1.3.3-2)
[2015-09-18 01:18] [ALPM] upgraded libnm-glib (1.0.4-1 -> 1.0.6-2)
[2015-09-18 01:18] [ALPM] upgraded webkit2gtk (2.8.4-1 -> 2.8.5-1)
[2015-09-18 01:18] [ALPM] upgraded gnome-online-accounts (3.16.3-1 -> 3.16.4.1-1)
[2015-09-18 01:18] [ALPM] upgraded libgdata (0.17.1-1 -> 0.17.2-1)
[2015-09-18 01:18] [ALPM] upgraded evolution-data-server (3.16.4-2 -> 3.16.5-1)
[2015-09-18 01:18] [ALPM] upgraded libgsf (1.14.33-1 -> 1.14.34-1)
[2015-09-18 01:18] [ALPM] upgraded evolution (3.16.4-1 -> 3.16.5-1)
[2015-09-18 01:18] [ALPM] upgraded exiv2 (0.24-1 -> 0.25-2)
[2015-09-18 01:18] [ALPM] upgraded libgdm (3.16.2-1 -> 3.16.3-1)
[2015-09-18 01:18] [ALPM] upgraded nm-connection-editor (1.0.4-1 -> 1.0.6-1)
[2015-09-18 01:18] [ALPM] upgraded python2 (2.7.10-1 -> 2.7.10-2)
[2015-09-18 01:18] [ALPM] upgraded libnl (3.2.25-1 -> 3.2.26-1)
[2015-09-18 01:18] [ALPM] installed libsodium (1.0.3-1)
[2015-09-18 01:18] [ALPM] installed libpgm (5.2.122-2)
[2015-09-18 01:18] [ALPM] installed zeromq (4.1.3-1)
[2015-09-18 01:18] [ALPM] upgraded libteam (1.14-2 -> 1.18-1)
[2015-09-18 01:18] [ALPM] upgraded networkmanager (1.0.4-1 -> 1.0.6-2)
[2015-09-18 01:18] [ALPM] upgraded gdm (3.16.2-1 -> 3.16.3-1)
[2015-09-18 01:18] [ALPM] upgraded gedit (3.16.2-1 -> 3.16.3-1)
[2015-09-18 01:18] [ALPM] upgraded gegl (0.2.0-15 -> 0.3.0-2)
[2015-09-18 01:18] [ALPM] upgraded gettext (0.19.4-1 -> 0.19.6-1)
[2015-09-18 01:18] [ALPM] upgraded git (2.4.6-1 -> 2.5.2-1)
[2015-09-18 01:18] [ALPM] upgraded libgit2 (1:0.22.2-1 -> 1:0.23.1-1)
[2015-09-18 01:18] [ALPM] upgraded libgit2-glib (0.22.6-1 -> 0.23.4-1)
[2015-09-18 01:18] [ALPM] upgraded gitg (3.16.1-1 -> 3.17.1-1)
[2015-09-18 01:18] [ALPM] upgraded gnome-clocks (3.16.1-1 -> 3.16.2-1)
[2015-09-18 01:18] [ALPM] upgraded gnome-color-manager (3.16.0-1 -> 3.16.0-2)
[2015-09-18 01:18] [ALPM] upgraded tracker (1.4.0-2 -> 1.4.1-1)
[2015-09-18 01:18] [ALPM] upgraded gsfonts (20150122-1 -> 20150811-1)
[2015-09-18 01:18] [ALPM] upgraded gnome-documents (3.16.2-2 -> 3.16.4-1)
[2015-09-18 01:18] [ALPM] upgraded libdmapsharing (2.9.30-1 -> 2.9.31-1)
[2015-09-18 01:18] [ALPM] upgraded gom (0.3.0-1 -> 0.3.1-1)
[2015-09-18 01:18] [ALPM] upgraded gnome-music (3.16.1-2 -> 3.16.2-1)
[2015-09-18 01:19] [ALPM] upgraded gnome-photos (3.14.2-2 -> 3.16.2-1)
[2015-09-18 01:19] [ALPM] upgraded libwbclient (4.2.3-1 -> 4.3.0-2)
[2015-09-18 01:19] [ALPM] upgraded talloc (2.1.2-1 -> 2.1.3-1)
[2015-09-18 01:19] [ALPM] upgraded ldb (1.1.20-1 -> 1.1.21-1)
[2015-09-18 01:19] [ALPM] upgraded smbclient (4.2.3-1 -> 4.3.0-2)
[2015-09-18 01:19] [ALPM] upgraded gvfs-smb (1.24.1-2 -> 1.24.2-1)
[2015-09-18 01:19] [ALPM] upgraded inetutils (1.9.4-1 -> 1.9.4-2)
[2015-09-18 01:19] [ALPM] installed python-decorator (4.0.2-1)
[2015-09-18 01:19] [ALPM] installed python-pexpect (3.3-1)
[2015-09-18 01:19] [ALPM] upgraded ipython (3.2.1-1 -> 4.0.0-2)
[2015-09-18 01:19] [ALPM] upgraded libcacard (2.3.0-3 -> 2.4.0-4)
[2015-09-18 01:19] [ALPM] upgraded libdvdread (5.0.1-1 -> 5.0.4-1)
[2015-09-18 01:19] [ALPM] upgraded libdvdnav (5.0.2-1 -> 5.0.3-1)
[2015-09-18 01:19] [ALPM] upgraded libmariadbclient (10.0.20-1 -> 10.0.21-3)
[2015-09-18 01:19] [ALPM] upgraded libnice (0.1.10-1 -> 0.1.13-1)
[2015-09-18 01:19] [ALPM] upgraded libpcap (1.6.2-1 -> 1.7.4-1)
[2015-09-18 01:19] [ALPM] upgraded libpipeline (1.4.0-1 -> 1.4.1-1)
[2015-09-18 01:19] [ALPM] upgraded linux-firmware (20150527.3161bfa-1 -> 20150722.e10097a-1)
[2015-09-18 01:19] [ALPM] upgraded linux (4.1.2-2 -> 4.1.6-1)
[2015-09-18 01:19] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
[2015-09-18 01:19] [ALPM-SCRIPTLET] >>> Generating initial ramdisk, using mkinitcpio.  Please wait...
[2015-09-18 01:19] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2015-09-18 01:19] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2015-09-18 01:19] [ALPM-SCRIPTLET] ==> Starting build: 4.1.6-1-ARCH
[2015-09-18 01:19] [ALPM-SCRIPTLET]   -> Running build hook: [systemd]
[2015-09-18 01:19] [ALPM-SCRIPTLET]   -> Running build hook: [btrfs]
[2015-09-18 01:19] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2015-09-18 01:19] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2015-09-18 01:19] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2015-09-18 01:19] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2015-09-18 01:19] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2015-09-18 01:19] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2015-09-18 01:19] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2015-09-18 01:19] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
[2015-09-18 01:19] [ALPM-SCRIPTLET] ==> Image generation successful
[2015-09-18 01:19] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2015-09-18 01:19] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2015-09-18 01:19] [ALPM-SCRIPTLET] ==> Starting build: 4.1.6-1-ARCH
[2015-09-18 01:19] [ALPM-SCRIPTLET]   -> Running build hook: [systemd]
[2015-09-18 01:19] [ALPM-SCRIPTLET]   -> Running build hook: [btrfs]
[2015-09-18 01:19] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2015-09-18 01:19] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2015-09-18 01:19] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2015-09-18 01:19] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2015-09-18 01:19] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2015-09-18 01:19] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2015-09-18 01:19] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2015-09-18 01:19] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2015-09-18 01:19] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
[2015-09-18 01:19] [ALPM-SCRIPTLET] ==> Image generation successful
[2015-09-18 01:19] [ALPM] upgraded man-db (2.7.1-1 -> 2.7.3-1)
[2015-09-18 01:19] [ALPM] upgraded man-pages (4.00-1 -> 4.02-1)
[2015-09-18 01:19] [ALPM] upgraded mdadm (3.3.2-2 -> 3.3.4-1)
[2015-09-18 01:19] [ALPM] upgraded mpg123 (1.22.1-1 -> 1.22.3-1)
[2015-09-18 01:19] [ALPM] upgraded nano (2.4.2-1 -> 2.4.2-2)
[2015-09-18 01:19] [ALPM] upgraded netctl (1.10-2 -> 1.11-1)
[2015-09-18 01:19] [ALPM] upgraded network-manager-applet (1.0.4-1 -> 1.0.6-1)
[2015-09-18 01:19] [ALPM] warning: /etc/pacman.d/mirrorlist installed as /etc/pacman.d/mirrorlist.pacnew
[2015-09-18 01:19] [ALPM] upgraded pacman-mirrorlist (20150719-1 -> 20150909-1)
[2015-09-18 01:19] [ALPM] upgraded pacman (4.2.1-1 -> 4.2.1-2)
[2015-09-18 01:19] [ALPM] upgraded parted (3.2-2 -> 3.2-3)
[2015-09-18 01:19] [ALPM] upgraded procps-ng (3.3.10-2 -> 3.3.11-2)
[2015-09-18 01:19] [ALPM] upgraded psmisc (22.21-2 -> 22.21-3)
[2015-09-18 01:19] [ALPM] upgraded python2-beaker (1.7.0-1 -> 1.7.0-2)
[2015-09-18 01:19] [ALPM] installed python2-packaging (15.3-1)
[2015-09-18 01:19] [ALPM] installed python2-setuptools (1:18.3.1-1)
[2015-09-18 01:19] [ALPM] upgraded python2-mako (1.0.1-1 -> 1.0.2-2)
[2015-09-18 01:19] [ALPM] upgraded qqwing (1.3.1-1 -> 1.3.4-1)
[2015-09-18 01:19] [ALPM] upgraded ruby (2.2.2-1 -> 2.2.3-1)
[2015-09-18 01:19] [ALPM] upgraded s-nail (14.8.3-1 -> 14.8.5-1)
[2015-09-18 01:19] [ALPM] upgraded subversion (1.8.13-2 -> 1.9.1-1)
[2015-09-18 01:19] [ALPM] upgraded swell-foop (3.16.1-1 -> 3.16.2-1)
[2015-09-18 01:19] [ALPM] upgraded systemd-sysvcompat (222-1 -> 225-1)
[2015-09-18 01:19] [ALPM] upgraded totem (3.16.2-1 -> 3.16.3-1)
[2015-09-18 01:19] [ALPM] upgraded vala (0.28.0-1 -> 0.28.1-1)
[2015-09-18 01:19] [ALPM] upgraded vi (1:070224-1 -> 1:070224-2)
[2015-09-18 01:19] [ALPM] upgraded vim-runtime (7.4.778-1 -> 7.4.854-2)
[2015-09-18 01:19] [ALPM] upgraded vim (7.4.778-1 -> 7.4.854-2)
[2015-09-18 01:19] [ALPM] upgraded virtualbox-guest-modules (5.0.0-1 -> 5.0.2-1)
[2015-09-18 01:19] [ALPM] upgraded virtualbox-guest-utils (5.0.0-1 -> 5.0.2-1)
[2015-09-18 01:19] [ALPM] upgraded xfsprogs (3.2.2-1 -> 3.2.4-1)
[2015-09-18 01:19] [ALPM] transaction completed

https://lists.archlinux.org/pipermail/a … 39844.html explained it...

Last edited by whoop (2015-09-18 00:08:18)

Offline

#5 2015-09-18 01:16:24

betseg
Member
From: Turkey
Registered: 2015-04-25
Posts: 178

Re: [SOLVED] ncurses, readline update error

Same here.

[2015-09-18 02:36] [PACMAN] Running 'pacman -Syu'
[2015-09-18 02:36] [PACMAN] synchronizing package lists
[2015-09-18 02:36] [PACMAN] starting full system upgrade
[2015-09-18 02:39] [ALPM] transaction started
[2015-09-18 02:39] [ALPM] upgraded ncurses (5.9-7 -> 6.0-3)
[2015-09-18 02:39] [ALPM] upgraded readline (6.3.008-1 -> 6.3.008-2)
[2015-09-18 02:39] [ALPM-SCRIPTLET] /usr/bin/bash: error while loading shared libraries: libncursesw.so.5: cannot open shared object file: No such file or directory
[2015-09-18 02:39] [ALPM] upgraded bash (4.3.042-1 -> 4.3.042-2)
[2015-09-18 02:39] [ALPM] upgraded gpm (1.20.7-4 -> 1.20.7-5)
[2015-09-18 02:39] [ALPM] upgraded aalib (1.4rc5-10 -> 1.4rc5-11)
[2015-09-18 02:39] [ALPM] upgraded psmisc (22.21-2 -> 22.21-3)
[2015-09-18 02:39] [ALPM] upgraded alsa-utils (1.0.29-1 -> 1.0.29-2)
[2015-09-18 02:39] [ALPM] upgraded aspell (0.60.6.1-2 -> 0.60.6.1-3)
[2015-09-18 02:39] [ALPM] upgraded bmon (3.8-1 -> 3.8-2)
[2015-09-18 02:39] [ALPM] upgraded python (3.4.3-2 -> 3.4.3-3)
[2015-09-18 02:39] [ALPM] upgraded libutil-linux (2.26.2-1 -> 2.27-2)
[2015-09-18 02:39] [ALPM] upgraded util-linux (2.26.2-1 -> 2.27-2)
[2015-09-18 02:39] [ALPM] upgraded brltty (5.2-3 -> 5.2-4)
[2015-09-18 02:39] [ALPM] upgraded libedit (20150325_3.1-1 -> 20150325_3.1-2)
[2015-09-18 02:39] [ALPM] upgraded python2 (2.7.10-1 -> 2.7.10-2)
[2015-09-18 02:39] [ALPM] upgraded less (481-1 -> 481-2)
[2015-09-18 02:39] [ALPM] upgraded texinfo (5.2-3 -> 5.2-4)
[2015-09-18 02:39] [ALPM] upgraded ceph (0.94.3-1 -> 0.94.3-2)
[2015-09-18 02:39] [ALPM] upgraded llvm-libs (3.6.2-3 -> 3.6.2-4)
[2015-09-18 02:39] [ALPM] upgraded clang (3.6.2-3 -> 3.6.2-4)
[2015-09-18 02:39] [ALPM] upgraded conky (1.10.0-4 -> 1.10.0-5)
[2015-09-18 02:39] [ALPM] upgraded dialog (1:1.2_20150528-1 -> 1:1.2_20150528-2)
[2015-09-18 02:39] [ALPM] upgraded guile (2.0.11-2 -> 2.0.11-3)
[2015-09-18 02:39] [ALPM] upgraded gdb (7.10-1 -> 7.10-3)
[2015-09-18 02:39] [ALPM] upgraded gettext (0.19.5.1-1 -> 0.19.6-1)
[2015-09-18 02:39] [ALPM] upgraded htop (1.0.3-2 -> 1.0.3-3)
[2015-09-18 02:39] [ALPM] upgraded hunspell (1.3.3-1 -> 1.3.3-2)
[2015-09-18 02:39] [ALPM] upgraded inetutils (1.9.4-1 -> 1.9.4-2)
[2015-09-18 02:39] [ALPM] upgraded lame (3.99.5-2 -> 3.99.5-3)
[2015-09-18 02:39] [ALPM] upgraded libcaca (0.99.beta18-2 -> 0.99.beta18-3)
[2015-09-18 02:39] [ALPM] upgraded libcacard (2.4.0-3 -> 2.4.0-4)
[2015-09-18 02:39] [ALPM] upgraded libcdio (0.93-1 -> 0.93-2)
[2015-09-18 02:39] [ALPM] upgraded libwbclient (4.3.0-1 -> 4.3.0-2)
[2015-09-18 02:39] [ALPM] upgraded nano (2.4.2-1 -> 2.4.2-2)
[2015-09-18 02:39] [ALPM] upgraded parted (3.2-2 -> 3.2-3)
[2015-09-18 02:39] [ALPM] upgraded pinentry (0.9.5-1 -> 0.9.5-2)
[2015-09-18 02:39] [ALPM] upgraded procps-ng (3.3.11-1 -> 3.3.11-2)
[2015-09-18 02:39] [ALPM] upgraded qemu (2.4.0-3 -> 2.4.0-4)
[2015-09-18 02:39] [ALPM] upgraded smbclient (4.3.0-1 -> 4.3.0-2)
[2015-09-18 02:39] [ALPM] upgraded tmux (2.0-1 -> 2.0-4)
[2015-09-18 02:39] [ALPM] upgraded unace (2.5-8 -> 2.5-9)
[2015-09-18 02:39] [ALPM] upgraded vi (1:070224-1 -> 1:070224-2)
[2015-09-18 02:39] [ALPM] upgraded vim-runtime (7.4.854-1 -> 7.4.854-2)
[2015-09-18 02:39] [ALPM] upgraded vim (7.4.854-1 -> 7.4.854-2)
[2015-09-18 02:39] [ALPM] upgraded w3m (0.5.3-8 -> 0.5.3-9)
[2015-09-18 02:39] [ALPM] transaction completed

Offline

#6 2015-09-18 08:02:18

smirky
Member
From: Bulgaria
Registered: 2013-02-23
Posts: 264
Website

Re: [SOLVED] ncurses, readline update error

So what, this was clearly a normal error if you ask me.
If you are worried that it might have not been installed properly, you can always "pacamn -S readline" afterwards...


Personal spot  ::  https://www.smirky.net/  ::  Try not to get lost!

Offline

#7 2015-09-18 10:03:10

cedricmc
Member
From: Madrid, Spain
Registered: 2011-11-20
Posts: 48

Re: [SOLVED] ncurses, readline update error

A possible workaround for other updates not to issue an error is to temporarily soft link libncursesw.so.6.

# ln -s /usr/lib/libncursesw.so.6  /usr/lib/libncursesw.so.5

Strangely, on the same update, while readline issued and error, lib32-readline did not.

EDIT: a proper solution (as indicated below by @anatolik) would be to install the package ncurses5-compat-libs from Aiur the AUR.

EDIT2: since the "proper solution" doesn't work for me (see below), I will continue to use the workaround.

EDIT3: A modified PKGBUILD solves it (see McMillan comment below).

Last edited by cedricmc (2015-09-21 15:10:26)

Offline

#8 2015-09-18 10:11:57

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,961
Website

Re: [SOLVED] ncurses, readline update error

Please don't suggest that people do that, even temporarily. If that was an appropriate workaround, then there would have been no need for a soname bump in the first place.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#9 2015-09-18 15:01:58

karlch
Member
Registered: 2015-06-14
Posts: 105

Re: [SOLVED] ncurses, readline update error

What is the danger in cedricmc's suggestion? I've been using this "workaround" for quite a while and right now it does make Matlab usable again. Shouldn't libraries be backwards compatible in general?

Offline

#10 2015-09-18 15:08:38

anatolik
Developer
Registered: 2012-09-27
Posts: 454

Re: [SOLVED] ncurses, readline update error

DO NOT "SOLVE" THIS PROBLEM BY LINKING *.so.5 to *.so.6

karlch wrote:

I've been using this "workaround" for quite a while and right now it does make Matlab usable again.

The right solution is to create ncurses5 AUR package with proper *.so.5 library.

Shouldn't libraries be backwards compatible in general?

Project sometime do backward incompatible changes. And when do they bump shared library version. That's exactly what happen recently with ncurses - versions 6 and 5 are *incompatible*.

Offline

#11 2015-09-18 15:11:08

karlch
Member
Registered: 2015-06-14
Posts: 105

Re: [SOLVED] ncurses, readline update error

Thanks for clarification and for the quick reply smile

Offline

#12 2015-09-18 17:39:10

charlie
Member
Registered: 2013-09-18
Posts: 55

Re: [SOLVED] ncurses, readline update error

I am a bit confused.

I had the same problem, then run 'pacman -S readline' afterwards and had no error.

Does this mean the problem is solved?

Is the topic marked solved because of anatolik's solution? Should I really create ncurses5 package from AUR?

Last edited by charlie (2015-09-18 17:39:18)

Offline

#13 2015-09-18 19:03:32

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,046
Website

Re: [SOLVED] ncurses, readline update error

No. The AUR package is only if you are trying to get Matlab to work. Otherwise, your system is fine, carry on...


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#14 2015-09-18 21:26:31

whoop
Member
Registered: 2009-05-28
Posts: 101

Re: [SOLVED] ncurses, readline update error

charlie wrote:

I am a bit confused.

Does this mean the problem is solved?

I marked the problem as solved  because at first I did not understand where the error was comming from as ncurses was installed before readline but: https://lists.archlinux.org/pipermail/a … 39844.html explained it for me so therefore there was no problem anymore.

Offline

#15 2015-09-21 09:36:50

cedricmc
Member
From: Madrid, Spain
Registered: 2011-11-20
Posts: 48

Re: [SOLVED] ncurses, readline update error

jasonwryan wrote:

No. The AUR package is only if you are trying to get Matlab to work. Otherwise, your system is fine, carry on...

Using ncurses5-compat-libs with Matlab R2013a gives me

$ matlab 
/opt/matlab/bin/glnxa64/MATLAB: error while loading shared libraries: /usr/lib/libncurses.so.5: file too short

I will continue to use the softlink workaround.

EDIT: A modified PKGBUILD solves it (see McMillan comment below).

Last edited by cedricmc (2015-09-21 15:10:46)

Offline

#16 2015-09-21 13:09:18

mcmillan
Member
Registered: 2006-04-06
Posts: 732

Re: [SOLVED] ncurses, readline update error

cedricmc wrote:
jasonwryan wrote:

No. The AUR package is only if you are trying to get Matlab to work. Otherwise, your system is fine, carry on...

Using ncurses5-compat-libs with Matlab R2013a gives me

$ matlab 
/opt/matlab/bin/glnxa64/MATLAB: error while loading shared libraries: /usr/lib/libncurses.so.5: file too short

I will continue to use the softlink workaround.

This is the problem with having multiple threads with the same issue. On another one the fix for this has been posted, but apparently hasn't made it into the AUR PKGBUILD yet
https://bbs.archlinux.org/viewtopic.php … 9#p1563139

Offline

#17 2015-09-21 15:09:03

cedricmc
Member
From: Madrid, Spain
Registered: 2011-11-20
Posts: 48

Re: [SOLVED] ncurses, readline update error

mcmillan wrote:

This is the problem with having multiple threads with the same issue. On another one the fix for this has been posted, but apparently hasn't made it into the AUR PKGBUILD yet
https://bbs.archlinux.org/viewtopic.php … 9#p1563139

Indeed! Solved here big_smile Thx, McMillan!

Offline

#18 2016-02-04 01:03:26

sleeping
Member
Registered: 2016-01-09
Posts: 35

Re: [SOLVED] ncurses, readline update error

Thanks people.

Oh and read the PKGBUILD if you plan on installing that package...

Offline

#19 2016-02-04 02:08:34

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 24,261
Website

Re: [SOLVED] ncurses, readline update error

I don't know how this thread wasn't closed before - but it can be now.  Don't hijack threads - this thread has (had) nothing to do with Matlab - and even if it did there is no need to revive it to add nothing new.

Closed.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

Board footer

Powered by FluxBB