You are not logged in.

#1 2015-09-22 05:52:07

H3g3m0n
Member
Registered: 2009-02-01
Posts: 17

VLC, gnome-session seg fault, no nvidia-egl-wayland (not microcode).

I'm getting:

    VLC media player 2.2.1 Terry Pratchett (Weatherwax) (revision 2.2.1-0-ga425c42)
    [1]    10543 segmentation fault (core dumped)  vlc
gnome-session --version       

[1]    23667 segmentation fault (core dumped)  gnome-session --version

I am on Skylake, I have the microcode installed and but I don't think there is any updates for Skylake yet.

dmesg | grep -i microcode

[    0.512333] microcode: CPU0 sig=0x506e3, pf=0x2, revision=0x19
[    0.512340] microcode: CPU1 sig=0x506e3, pf=0x2, revision=0x19
[    0.512349] microcode: CPU2 sig=0x506e3, pf=0x2, revision=0x19
[    0.512359] microcode: CPU3 sig=0x506e3, pf=0x2, revision=0x19
[    0.512369] microcode: CPU4 sig=0x506e3, pf=0x2, revision=0x19
[    0.512378] microcode: CPU5 sig=0x506e3, pf=0x2, revision=0x19
[    0.512387] microcode: CPU6 sig=0x506e3, pf=0x2, revision=0x19
[    0.512397] microcode: CPU7 sig=0x506e3, pf=0x2, revision=0x19
[    0.512432] microcode: Microcode Update Driver: v2.00 <tigran@aivazian.fsnet.co.uk>, Peter Oruba

I tried with LDPRELOADing libgobject without sucess. vlc-cache-gen also segfaults.

LD_PRELOAD=/usr/lib/libgobject-2.0.so.0 /usr/lib/vlc/vlc-cache-gen -f /usr/lib/vlc/plugin

[1]    21112 segmentation fault (core dumped)  LD_PRELOAD=/usr/lib/libgobject-2.0.so.0 /usr/lib/vlc/vlc-cache-gen -f

strace vlc:

open("/usr/lib/nvidia/libGL.so.352.41", O_RDONLY) = 5
fstat(5, {st_mode=S_IFREG|0755, st_size=1218248, ...}) = 0
close(5)                                = 0
open("/usr/lib/libnvidia-glcore.so.352.41", O_RDONLY) = 5
fstat(5, {st_mode=S_IFREG|0755, st_size=42460504, ...}) = 0
close(5)                                = 0
open("/proc/self/status", O_RDONLY)     = 5
lseek(5, 0, SEEK_SET)                   = 0
read(5, "Name:\tvlc\nState:\tR (running)\nTgi"..., 256) = 256
close(5)                                = 0
getpid()                                = 1168
futex(0x7f56ae29ace4, FUTEX_WAKE_PRIVATE, 2147483647) = 0
clock_gettime(CLOCK_MONOTONIC, {10575, 686748248}) = 0
readlink("/proc/1168/exe", "/usr/bin/vlc", 4095) = 12
open("/etc/ld.so.cache", O_RDONLY|O_CLOEXEC) = 5
fstat(5, {st_mode=S_IFREG|0644, st_size=347793, ...}) = 0
mmap(NULL, 347793, PROT_READ, MAP_PRIVATE, 5, 0) = 0x7f56b792a000
close(5)                                = 0
open("/usr/lib/libnvidia-egl-wayland.so.", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
munmap(0x7f56b792a000, 347793)          = 0
--- SIGSEGV {si_signo=SIGSEGV, si_code=SI_KERNEL, si_addr=0} ---
+++ killed by SIGSEGV (core dumped) +++
[1]    1166 segmentation fault (core dumped)  strace vlc

strace gnome-session --version

open("/etc/ld.so.cache", O_RDONLY|O_CLOEXEC) = 5
fstat(5, {st_mode=S_IFREG|0644, st_size=347793, ...}) = 0
mmap(NULL, 347793, PROT_READ, MAP_PRIVATE, 5, 0) = 0x7f0db9a4e000
close(5)                                = 0
open("/usr/lib/tls/x86_64/libnvidia-egl-wayland.so.", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/usr/lib/tls/x86_64", 0x7ffc50f595e0) = -1 ENOENT (No such file or directory)
open("/usr/lib/tls/libnvidia-egl-wayland.so.", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/usr/lib/tls", 0x7ffc50f595e0)    = -1 ENOENT (No such file or directory)
open("/usr/lib/x86_64/libnvidia-egl-wayland.so.", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/usr/lib/x86_64", 0x7ffc50f595e0) = -1 ENOENT (No such file or directory)
open("/usr/lib/libnvidia-egl-wayland.so.", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/usr/lib", {st_mode=S_IFDIR|0755, st_size=216432, ...}) = 0
munmap(0x7f0db9a4e000, 347793)          = 0
--- SIGSEGV {si_signo=SIGSEGV, si_code=SI_KERNEL, si_addr=0} ---
+++ killed by SIGSEGV (core dumped) +++
[1]    23648 segmentation fault (core dumped)  strace gnome-session --version

I tried removing libkate and rerunning vlc-cache-gen as described in a bug report, without success. https://bugs.archlinux.org/task/39676

It seems to claim the bug is fixed with a new glib2, but there isn't currently one in testing (I'm guessing it moved into stable since that bug was closed. There seems to be a newer one in gnome-unstable, I'm having a look at that now...).

Offline

#2 2015-09-22 06:55:31

FarStar07
Member
Registered: 2012-04-02
Posts: 46

Re: VLC, gnome-session seg fault, no nvidia-egl-wayland (not microcode).

Hello,
Same issue here with VLC (with Skylake, microcode installed and KDE).
Waiting for this new glib2 smile

Edit: I've installed glib2 (v2.45.8) fron gnome-unstable => https://www.archlinux.org/packages/gnom … _64/glib2/
Sadly, compiling VLC fails.
=> /bin/sh : ligne 4 :  2642 Erreur de segmentation  (core dumped)./vlc-cache-gen ../modules

Last edited by FarStar07 (2015-09-22 12:18:28)

Offline

#3 2015-09-22 22:08:57

H3g3m0n
Member
Registered: 2009-02-01
Posts: 17

Re: VLC, gnome-session seg fault, no nvidia-egl-wayland (not microcode).

FarStar07 wrote:

Hello,
Same issue here with VLC (with Skylake, microcode installed and KDE).
Waiting for this new glib2 smile

Does your vim crash on exit too?

Vim: Caught deadly signal SEGV

https://bbs.archlinux.org/viewtopic.php?id=196667

That's another thing that is reported as being fixed by microcode that I'm having issues with.

Offline

#4 2015-09-23 14:53:25

FarStar07
Member
Registered: 2012-04-02
Posts: 46

Re: VLC, gnome-session seg fault, no nvidia-egl-wayland (not microcode).

I don't use vim. I just installed it and it seems to works.

Offline

#5 2015-09-29 06:54:49

H3g3m0n
Member
Registered: 2009-02-01
Posts: 17

Re: VLC, gnome-session seg fault, no nvidia-egl-wayland (not microcode).

Looks like this might be the issue: https://www.phoronix.com/scan.php?page= … atest-Woes

Offline

#6 2015-09-30 12:35:39

FarStar07
Member
Registered: 2012-04-02
Posts: 46

Re: VLC, gnome-session seg fault, no nvidia-egl-wayland (not microcode).

Yes. Thanks for the link wink
A temporary solution:

I hope Intel will soon release a microcode data file for skylake.
Waiting for the release. The glibc and lib32-glibc rebuild without the --enable-lock-elision works fine.

Offline

#7 2015-10-04 07:41:18

firekage
Member
From: Eastern Europe, Poland
Registered: 2013-06-30
Posts: 572

Re: VLC, gnome-session seg fault, no nvidia-egl-wayland (not microcode).

FarStar07 wrote:

Yes. Thanks for the link wink
A temporary solution:

I hope Intel will soon release a microcode data file for skylake.
Waiting for the release. The glibc and lib32-glibc rebuild without the --enable-lock-elision works fine.

Sorry for stupid question, noobish question, but these segmentation faults also occurs to me on my 6700K. Could you point me to something that will explain to me how to install glibc and lib32-glibc without "--enable-lock-ellision" feature?

In fact, i thought that my cpu is damaged [:|]

Last edited by firekage (2015-10-04 07:41:35)

Offline

#8 2015-10-04 16:59:38

FarStar07
Member
Registered: 2012-04-02
Posts: 46

Re: VLC, gnome-session seg fault, no nvidia-egl-wayland (not microcode).

firekage wrote:
FarStar07 wrote:

Yes. Thanks for the link wink
A temporary solution:

I hope Intel will soon release a microcode data file for skylake.
Waiting for the release. The glibc and lib32-glibc rebuild without the --enable-lock-elision works fine.

Sorry for stupid question, noobish question, but these segmentation faults also occurs to me on my 6700K. Could you point me to something that will explain to me how to install glibc and lib32-glibc without "--enable-lock-ellision" feature?

In fact, i thought that my cpu is damaged [:|]

Your CPU goes well wink

You must compile yourself these two packages.

Source files for glibc: https://projects.archlinux.org/svntogit … ages/glibc
Source files for lib32-glibc: https://projects.archlinux.org/svntogit … ib32-glibc

In each PKGBUILD, you must remove this line: --enable-lock-elision \

For example, to compile glibc: put all these files in a directory: PKGBUILD (without the line above)  glibc-2.22-roundup.patch  glibc.install  locale-gen  locale.gen.txt
In a terminal:

makepkg -s

Compilation takes a long time...

To install the resulting package:

sudo pacman -U glibc-2.22-3-x86_64.pkg.tar.xz

Same thing for lib32-glibc

Last edited by FarStar07 (2015-11-01 05:15:20)

Offline

#9 2015-10-13 09:42:13

dllu
Member
Registered: 2015-10-11
Posts: 10

Re: VLC, gnome-session seg fault, no nvidia-egl-wayland (not microcode).

I did what you described but now I am getting the error:

loadlocale.c:130: _nl_intern_locale_data: Assertion `cnt < (sizeof (_nl_value_type_LC_COLLATE) / sizeof (_nl_value_type_LC_COLLATE[0]))' failed.

on everything I run. Even sudo, ls, sh, rm, vim, and cat have this error. sad

Now I will have boot from a USB stick and follow the instructions here to fix this problem...

See also the discussion on "Do NOT install glibc-2.22-4"

Last edited by dllu (2015-10-13 10:04:00)

Offline

#10 2015-11-01 05:17:57

FarStar07
Member
Registered: 2012-04-02
Posts: 46

Re: VLC, gnome-session seg fault, no nvidia-egl-wayland (not microcode).

Hello!
I just installed Linux Kernel 4.3 RC7, Nvidia Driver 358.09 (Beta) and reinstalled Glibc 2.2-3 with elision enabled => no more "segmentation fault (core dumped)" error with VLC and others. All seems ok smile

Offline

#11 2015-11-02 18:42:21

gerd
Member
Registered: 2007-03-19
Posts: 7

Re: VLC, gnome-session seg fault, no nvidia-egl-wayland (not microcode).

Hi,

I am suffering the same problem with a Skylake CPU.

I just updated my gigabyte bios with a microcode fix  from October 22 that set the microcode to revision 0x39.
The packaged glibc version 2.22-3 with linux-4.2.5-1 still produces segfaults.

If I rebuild the glibc package without "--enable-lock-elision" it works.

It was not easy to find the cause of the segfaults. I only noticed, because the kde screen locker kscreenlocker_greet crashed on unlocking after suspend but didn't show a crashlog.

Offline

#12 2015-11-05 21:46:48

orlfman
Member
Registered: 2007-11-20
Posts: 58

Re: VLC, gnome-session seg fault, no nvidia-egl-wayland (not microcode).

so wait is this a nvidia issue or a intel issue?
6700K paired with a 980 and a maximus viii hero with the latest bios, here having the same issues as well

i'm sorta confused though.

http://www.phoronix.com/scan.php?page=n … atest-Woes
https://bbs.archlinux.org/viewtopic.php?id=200583

those ones make it seem like its a nvidia issue since older nvidia drivers don't have this issue.

either way building glibc without intel tsx fixes the issue.

i tried upgrading to kernel 4.3 and the latest nvidia beta's (358.09) but i still received segmentation faults on anything GUI related when exiting. only console applications don't give the error. then i ran into another issue with pstates causing my 6700k to always down clock to 800mhz - 1ghz even though i set cpupower governor to performance and disabled c states, turbo boost off (running it at stock 4ghz), and speedstep off in bios.

with 4.2 pstates isn't enabled but its a desktop, i don't care about power saving features.

Last edited by orlfman (2015-11-05 22:52:09)

Offline

#13 2015-11-06 13:50:27

FarStar07
Member
Registered: 2012-04-02
Posts: 46

Re: VLC, gnome-session seg fault, no nvidia-egl-wayland (not microcode).

It's really a strange issue. I don't know what is guilty.
With Linux 4.3, Nvidia 358.09 and the latest bios for my MB, all seems now ok with elision enabled in Glibc 2.2-3.
For information, I have a motherboard ASUS Z170-Deluxe, an Intel Core i7 6700K and a Nvidia GeForce GTX 980 Ti (ASUS STRIX).

Edit from 2015-11-11 : With the update today (testing repos), Segmentation Fault for VLC is back sad

Last edited by FarStar07 (2015-11-11 06:29:11)

Offline

#14 2015-11-22 11:30:48

8472
Member
From: Slovakia
Registered: 2010-05-15
Posts: 68

Re: VLC, gnome-session seg fault, no nvidia-egl-wayland (not microcode).

dllu wrote:

I did what you described but now I am getting the error:

loadlocale.c:130: _nl_intern_locale_data: Assertion `cnt < (sizeof (_nl_value_type_LC_COLLATE) / sizeof (_nl_value_type_LC_COLLATE[0]))' failed.

on everything I run. Even sudo, ls, sh, rm, vim, and cat have this error. sad

Now I will have boot from a USB stick and follow the instructions here to fix this problem...

See also the discussion on "Do NOT install glibc-2.22-4"


As I just tested myself after getting the very same error, this problem could be fixed this way: https://bbs.archlinux.org/viewtopic.php … 9#p1551839


Logic clearly dictates that the needs of the many outweigh the needs of the few.

Offline

Board footer

Powered by FluxBB