You are not logged in.

#1 2015-09-23 06:09:55

fofoni
Member
From: Rio de Janeiro
Registered: 2015-04-29
Posts: 18

Getty respawning automatically?

I have always had systemd configured to not clear boot messages. Also, I have the '\4{wlp3s0}' escape sequence in my /etc/issue, which shows the IP address assigned to my wireless interface. I'm used to not seeing the IP address in the issue message right after boot, because systemd fires up getty before the network has been completely set up. This is ok.

However, since something like two days ago, I'm noticing something very strange with getty. The first time I noticed this new behaviour, I only noticed that the boot messages had been cleared, and that the IP address was being shown after boot. I restarted the machine, and then I was able to notice that, at first, everything happens normally right after boot: the boot messages do not disappear, and getty prints the issue message without the IP address. Then, one second later, the screen gets cleared, and a new issue message appears, this time showing my IP address.

This looks like getty could be getting killed by something, and then respawning. What could be causing this, or what else could be happening?

EDIT: I just made some tests, and noticed two things: (1) if I quickly type my username before the screen clearing up, but don't hit enter, the screen does not get cleared, and getty does not get killed. As if this automatic respawning were a feature, instead of a bug. (2) Once, just now, I could see it respawning two times in a row: in the first, the screen was cleared, but the network was still down; and in the second time, the IP address suddenly appeared where it should be. Either it is respawning automatically every few seconds (though I don't see the screen flicker as I do in the first two times), or it is detecting a new information (IP address that wasn't available) and then respawns in response to the network having been set up. Maybe I'm going a little nuts here hehehe I just want to know what the hell's happening :P

Last edited by fofoni (2015-09-23 06:34:51)

Offline

#2 2015-12-20 06:57:26

fofoni
Member
From: Rio de Janeiro
Registered: 2015-04-29
Posts: 18

Re: Getty respawning automatically?

UPDATE: Three months later, the problem remains. Two things have happened:

  1. I have posted this question to the Unix & Linux Stack Exchange. I have put a lot of extra information there. No answer appeared, but some discussion in the comments made me realize that getty is not respawning.

  2. This bug made me realize that netctl is to blame. After the update that triggered the bug, the problem was gone (there was no clearing of the boot messages anymore). After I fixed the bug, the problem was back. Then, I tried manually disabling netctl-auto, and voilà, the problem was gone. When I enable it back, the problem returns.

I'll repeat here the question I have asked there on Unix.SE: why on Earth would netctl cause the screen to be cleared, and a new /etc/issue message to be displayed?

Last edited by fofoni (2015-12-20 07:00:22)

Offline

Board footer

Powered by FluxBB