You are not logged in.

#1 2015-09-29 12:36:13

Raphi111
Member
Registered: 2012-07-28
Posts: 12

[SOLVED] Why isn't acpi_osi=Linux set by default

A little background:

I installed Arch Linux on an old eeepc a few years ago and I remember all special function keys working right after the installation.
However I recently did a fresh install of Arch Linux on that same eeepc and I couldn't get the wifi toggle working. I've been investigating for hours and tried a lot of fixes but none of them worked ( blacklisting asus_nb_wmi or changing it's WAPF value was suggested but the module isn't running on my eeepc).
All I was able to do is to soft block/unblock wlan using rfkill but in that case the led doesn't turn off while wifi is of and another problem is that sometimes the wifi gets hard blocked (if running another OS that is able to hard block/unblock it for example) and I'm not able to turn it on while on Arch Linux.
I guess using this script could be a workaround if it's able to soft block the wifi and somehow setting the led state accordingly, but it handles a lot of eeepc, I find it confusing and I find this solution quite artificial.

After reading lots of forums where other users had similar problems I finally tried something I didn't believe would be working. I added "acpi_osi=Linux" in line GRUB_CMLINE_LINUX_DEFAULT in grub's config.

As I understand it this parameter tells the BIOS that it's referring to Linux, as it doesn't recognize the OS as soon as it's not Windows



So my question is: why isn't the acpi_osi parameter set to Linux by default, so that the ACPI BIOS know who it's talking to ?

Please forgive me if I didn't post in the right subforum as I'm not quiet sure if it's Kernel/Hardware related or not and feel free to move it.

Last edited by Raphi111 (2015-10-14 15:10:55)

Offline

#2 2015-09-29 12:49:41

Raynman
Member
Registered: 2011-10-22
Posts: 1,442

Re: [SOLVED] Why isn't acpi_osi=Linux set by default

Offline

Board footer

Powered by FluxBB