You are not logged in.

#1 2015-10-06 05:33:41

konstantinusz
Banned
Registered: 2015-09-30
Posts: 14

I always get 'error: GPGME error: Invalid crypto engine' error

I tried to make a full system upgrade, but it didn't succeeded, because of missing keys. Then I reinstalled "gnupg" package. Then I am unable to install anything becasue I always get:

error: GPGME error: Invalid crypto engine

And similar error messages for every already downloaded package:

File /var/cache/pacman/pkg/linux-api-headers-4.1.4-1-i686.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).

Last edited by konstantinusz (2015-10-06 05:37:08)

Offline

#2 2015-10-06 06:22:47

mauritiusdadd
Member
From: Benevento, Italy
Registered: 2013-10-27
Posts: 776

Re: I always get 'error: GPGME error: Invalid crypto engine' error

konstantinusz wrote:

I tried to make a full system upgrade, but it didn't succeeded, because of missing keys. Then I reinstalled "gnupg" package.

If you run pacman -Syu but you actually didn't update the system and after that you used pacman -S gnupg, then you have probably updated gnupg without its dependencies: this is a partial update, and it is not supported. Next time, if you think you need to update the pacman keys, just use pacman-key...

However, let's check the status of gnupg: can you post the output of the following command?

pacman -Qi gnupg gpgme libgcrypt

registered linux user #588260github

-- When you have eliminated the impossible, whatever remains, however improbable, must be the truth -- Spock | Sherlock Holmes

Offline

#3 2015-10-06 06:32:28

konstantinusz
Banned
Registered: 2015-09-30
Posts: 14

Re: I always get 'error: GPGME error: Invalid crypto engine' error

"error: package 'gnupg' was not found " appears because I removed gnupg before.

error: package 'gnupg' was not found
Name           : gpgme
Version        : 1.4.3-1
Description    : A C wrapper library for GnuPG
Architecture   : i686
URL            : http://www.gnupg.org/related_software/gpgme/
Licenses       : GPL
Groups         : None
Provides       : None
Depends On     : libgpg-error  pth  gnupg>=2
Optional Deps  : None
Required By    : pacman
Optional For   : None
Conflicts With : None
Replaces       : None
Installed Size : 708.00 KiB
Packager       : Tobias Powalowski <tpowa@archlinux.org>
Build Date     : Fri 16 Aug 2013 01:01:20 PM CEST
Install Date   : Tue 11 Feb 2014 12:09:35 AM CET
Install Reason : Installed as a dependency for another package
Install Script : Yes
Validated By   : Signature

Name           : libgcrypt
Version        : 1.6.1-1
Description    : General purpose cryptographic library based on the code from GnuPG
Architecture   : i686
URL            : http://www.gnupg.org
Licenses       : LGPL
Groups         : None
Provides       : None
Depends On     : libgpg-error>=1.10-2
Optional Deps  : None
Required By    : chromium  cryptsetup  gcr  libgnome-keyring  libimobiledevice  libsecret  libxslt  systemd
                 xorg-server
Optional For   : None
Conflicts With : None
Replaces       : None
Installed Size : 880.00 KiB
Packager       : Andreas Radke <andyrtr@archlinux.org>
Build Date     : Wed 29 Jan 2014 05:45:08 PM CET
Install Date   : Tue 11 Feb 2014 12:09:10 AM CET
Install Reason : Installed as a dependency for another package
Install Script : Yes
Validated By   : Signature

Last edited by konstantinusz (2015-10-06 06:33:21)

Offline

#4 2015-10-06 06:36:05

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,497

Re: I always get 'error: GPGME error: Invalid crypto engine' error

"error: package 'gnupg' was not found" is clearly the problem. You need that.

Last edited by Scimmia (2015-10-06 06:36:27)

Offline

#5 2015-10-06 06:36:21

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,315
Website

Re: I always get 'error: GPGME error: Invalid crypto engine' error

So, you are not running Arch, but Manjaro?


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#6 2015-10-06 06:48:15

konstantinusz
Banned
Registered: 2015-09-30
Posts: 14

Re: I always get 'error: GPGME error: Invalid crypto engine' error

I am using Arch Linux, my other PC is disfunctioning due to memory problems, doesn't recognize memory modules. So I had to assemble another PC from old parts, and I fortunately found an old install CD in the drawer, so I was able to install Arch Linux, but really old installation media. Maybe this is the problem.

Offline

#7 2015-10-06 06:49:21

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,497

Re: I always get 'error: GPGME error: Invalid crypto engine' error

No, that is not the problem. The problem right now is that you uninstalled gnupg.

Edit: Unless this install disk was from before mid 2012, then that would be a problem.

Last edited by Scimmia (2015-10-06 06:52:43)

Offline

#8 2015-10-06 06:52:33

konstantinusz
Banned
Registered: 2015-09-30
Posts: 14

Re: I always get 'error: GPGME error: Invalid crypto engine' error

Yes, I uninstalled, but after I realized that problem I am asking for.

Offline

#9 2015-10-06 06:55:41

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,497

Re: I always get 'error: GPGME error: Invalid crypto engine' error

So reinstall it from the cache, the version that would have been installed with that version of gpgme.

Offline

#10 2015-10-06 07:04:06

konstantinusz
Banned
Registered: 2015-09-30
Posts: 14

Re: I always get 'error: GPGME error: Invalid crypto engine' error

Thx, but is there a way to omit the PGP signature check?

Last edited by konstantinusz (2015-10-06 07:05:36)

Offline

#11 2015-10-06 07:07:35

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,497

Re: I always get 'error: GPGME error: Invalid crypto engine' error

By default, installation of local packages doesn't require a PGP check, it's set to "optional". This is set in pacman.conf.

Offline

#12 2015-10-06 07:12:36

konstantinusz
Banned
Registered: 2015-09-30
Posts: 14

Re: I always get 'error: GPGME error: Invalid crypto engine' error

Interesting, I get this error messages:

sudo pacman -U gpgme-1.6.0-1-i686.pkg.tar.xz
loading packages...
resolving dependencies...
looking for conflicting packages...

Packages (2) gnupg-2.1.8-4  gpgme-1.6.0-1

Total Installed Size:  9.73 MiB
Net Upgrade Size:      9.04 MiB

:: Proceed with installation? [Y/n] 
(2/2) checking keys in keyring                       [############################] 100%
error: GPGME error: Invalid crypto engine
(1/2) checking package integrity                     [############################] 100%
error: GPGME error: Invalid crypto engine
error: gnupg: missing required signature
:: File /var/cache/pacman/pkg/gnupg-2.1.8-4-i686.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] 

Offline

#13 2015-10-06 07:13:37

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,497

Re: I always get 'error: GPGME error: Invalid crypto engine' error

*sigh*, I'm out.

Offline

#14 2015-10-06 08:13:53

mauritiusdadd
Member
From: Benevento, Italy
Registered: 2013-10-27
Posts: 776

Re: I always get 'error: GPGME error: Invalid crypto engine' error

You could try to temporarly disable the signature checking (see https://wiki.archlinux.org/index.php/Pa … e_checking). If that does not work either, as I suspect,  your last resort is to use pacman from a live media: beware, do not chroot into the broken system, use "pacman --root <mountpoint> -Syu" instead.

Last edited by mauritiusdadd (2015-10-06 08:14:53)


registered linux user #588260github

-- When you have eliminated the impossible, whatever remains, however improbable, must be the truth -- Spock | Sherlock Holmes

Offline

Board footer

Powered by FluxBB