You are not logged in.

#1 2006-04-06 09:16:28

bravo90078
Member
Registered: 2005-04-22
Posts: 18

p4_clockmod & kernel 2.6.16.1-7

It's not that big of a deal, but I upgraded yesterday from 2.6.15 to the current kernel in the repo and there's a quirk with p4_clockmod.

Previously all of my CPU frequency settings were available for me to use with cpufrequtils. I upgrade to the newest kernel and now only 2 settings are available. I thought perhaps it might have been cpufrequtils since it was recently updated. But I reverted to the previous version of cpufrequtils and still the same.

Any thoughts on what the problem might be?

processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) Pentium(R) 4 CPU 2.40GHz
stepping        : 9
cpu MHz         : 2099.947
cache size      : 512 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe cid xtpr
bogomips        : 4793.09

Offline

#2 2006-04-07 03:29:55

learner
Member
Registered: 2006-01-14
Posts: 21

Re: p4_clockmod & kernel 2.6.16.1-7

have you check your rc.conf, when i previously install a extra kernel, it replaces that file with a new rc.conf, and backup the one old as rc.confpacsave

Offline

#3 2006-04-07 07:22:39

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: p4_clockmod & kernel 2.6.16.1-7

check out kernel -8 i removed the crappy acpi patch again

Offline

#4 2006-04-07 09:07:29

bravo90078
Member
Registered: 2005-04-22
Posts: 18

Re: p4_clockmod & kernel 2.6.16.1-7

tried -8. Still the same thing...

Ahh well.. back to full speed cpu then I guess.. :-)

Offline

#5 2006-04-07 09:50:20

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: p4_clockmod & kernel 2.6.16.1-7

you could try if removing the cpufreq-2.6.17 patch from kernel does solve your issue.

Offline

#6 2006-04-11 11:42:53

Blind
Member
From: Desert mountain
Registered: 2005-02-06
Posts: 380

Re: p4_clockmod & kernel 2.6.16.1-7

Could that be due to the compiled in 'performance' scaling governor? E.g. this is the kconfig26 from the latest 2.6.16.3:

#
# CPU Frequency scaling
#
CONFIG_CPU_FREQ=y
CONFIG_CPU_FREQ_TABLE=m
# CONFIG_CPU_FREQ_DEBUG is not set
CONFIG_CPU_FREQ_STAT=m
CONFIG_CPU_FREQ_STAT_DETAILS=y
CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE=y
# CONFIG_CPU_FREQ_DEFAULT_GOV_USERSPACE is not set
CONFIG_CPU_FREQ_GOV_PERFORMANCE=y
CONFIG_CPU_FREQ_GOV_POWERSAVE=m
CONFIG_CPU_FREQ_GOV_USERSPACE=m
CONFIG_CPU_FREQ_GOV_ONDEMAND=m
CONFIG_CPU_FREQ_GOV_CONSERVATIVE=m

Mmmmh. I am not much into this. Can you change the compiled in governor with a module one? So, would it make sense to even compile the others as modules?
Cheers,
Blind

Offline

#7 2006-04-11 11:52:00

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: p4_clockmod & kernel 2.6.16.1-7

coud you try to change those lines?
you can only set one or the other to y module is not possible.

Offline

#8 2006-04-11 12:15:14

Blind
Member
From: Desert mountain
Registered: 2005-02-06
Posts: 380

Re: p4_clockmod & kernel 2.6.16.1-7

oohhh, yeah, you are right!

...possibly you cannot change it because of

# CONFIG_CPU_FREQ_DEFAULT_GOV_USERSPACE is not set

I think you have to make the governor a userspace thing. Only then it makes sense to compile all governors as module. After having done that you can change the governor by

echo -n "ondemand" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

which (with 'ondemand') changes the frequencies according to whether you need the power of the CPU or not. 'performance' probably does not allow the change of the frequency because it is optimized for performance.

Cheers,
Blind

Offline

#9 2006-04-24 15:27:35

synorgy
Member
From: $HOME
Registered: 2005-07-11
Posts: 272
Website

Re: p4_clockmod & kernel 2.6.16.1-7

I have nearly the exact same problem. You can see what I have attempted to do to fix this (to no avail) at http://www.linuxquestions.org/questions … p?t=438154

Hope some of this helps you. If anyone manages to fix this, please let me know. (You can email me, message me on AIM - anxemptyxpromise or post into that LQ topic)


"Unix is basically a simple operating system, but you have to be a genius to understand the simplicity." (Dennis Ritchie)

Offline

#10 2006-04-25 12:14:08

Blind
Member
From: Desert mountain
Registered: 2005-02-06
Posts: 380

Re: p4_clockmod & kernel 2.6.16.1-7

EITHER compile the kernel with these options.
It should work again.

#
# CPU Frequency scaling
#
CONFIG_CPU_FREQ=y
CONFIG_CPU_FREQ_TABLE=y
# CONFIG_CPU_FREQ_DEBUG is not set
CONFIG_CPU_FREQ_STAT=y
CONFIG_CPU_FREQ_STAT_DETAILS=y
# CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE is not set
CONFIG_CPU_FREQ_DEFAULT_GOV_USERSPACE=y
CONFIG_CPU_FREQ_GOV_PERFORMANCE=y
CONFIG_CPU_FREQ_GOV_POWERSAVE=y
CONFIG_CPU_FREQ_GOV_USERSPACE=y
CONFIG_CPU_FREQ_GOV_ONDEMAND=y
CONFIG_CPU_FREQ_GOV_CONSERVATIVE=y

you should also be able to change the governor then.
try:

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors

which gives you the available governors.

In the stock kernel only 'performance' is ultimatively available if you dont do a

modprobe cpufreq_ondemand

which brings me to the
OR:
you can modprobe all the governors and do a

echo -n "ondemand" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

to load e.g. the 'ondemand' governor. Probably your problems are solved already then.
I think tpowa makes all the governors a module to keep the kernel lean. I think that is just fine, since you can modprobe the other governors. And 'performance' is good to start with in the first place.
Cheers,
Blind

UPDATE:
Nevermind the 'OR'! The frequency table is not updated for some reason when the governor is changed...because it is not configured to be userspace? Recompiling the kernel works for me, though.

Offline

#11 2006-05-03 14:59:41

synorgy
Member
From: $HOME
Registered: 2005-07-11
Posts: 272
Website

Re: p4_clockmod & kernel 2.6.16.1-7

Hmm..It seems that compiling all of the govenors into the kernel has disabled scaling altogether for me. I'll work on it again when I get time (it is currently finals week, and I'm a bit overloaded)


"Unix is basically a simple operating system, but you have to be a genius to understand the simplicity." (Dennis Ritchie)

Offline

Board footer

Powered by FluxBB