You are not logged in.

#1 2015-10-13 20:07:29

rlees85
Member
From: Daventry, UK
Registered: 2015-04-29
Posts: 95
Website

GVFS mount points missing in /run/user/$UID/gvfs

It seems with the introduction of Gnome 3.18 and GVFS 1.26 the powers that be have done away with something that it looks like only I ever use... again...

Previously, when samba shares (or anything else controlled by GVFS) was mounted, a way of accessing it from the command line would be to go to the following folder

/run/user/$UID/gvfs

Within this folder, would be folders with long complicated names with lots of symbols that would basically be your GVFS mount points.

Now, after the recent batch of updates, if you mount any samba (or any other GVFS) mounts, /run/user/$UID/gvfs remains completely empty......

I have a NAS and a large internal hard disk in my PC. The NAS is my server, the internal hard disk in the PC acts as a backup destination. The only sensible way to do this is using RSYNC. RSYNC would happily copy from /run/user/$UID/gvfs/[blahblah]. RSYNC does NOT happily copy from "smb://nas/folder/".

Mounting my samba shares in /etc/fstab or SystemD mount units is not a solution as they are system-level mounts when I need per-user mounts/credentials.

There just MUST be a way of achieving this simple goal in Linux... Any help would be greatly appreciated!

Offline

#2 2015-10-14 00:10:25

bnb2235
Member
Registered: 2011-02-13
Posts: 119

Re: GVFS mount points missing in /run/user/$UID/gvfs

For what it is worth, I also see a break in the system. I have a "temp" folder mounted from samba, and a "scans" folder mounted from samba via gvfs. In the scans folder are pdf files from the printer. In the temp folder are anything including jpg and xls.
qpdfview, GpicView, Pinta, Gimp all fail to open files from these gvfs mounted samba shares. Gnome apps work fine (e.g. evince, Image Viewer) and also LibreOffice works too.

A sample error while opening a picture with GpicView:
Failed to open file '/run/user/1251/gvfs/smb-share:server=nas.smith.int,share=temp/DSCF7627-cropped.jpg': No such file or directory

Offline

#3 2015-10-14 14:41:21

rlees85
Member
From: Daventry, UK
Registered: 2015-04-29
Posts: 95
Website

Re: GVFS mount points missing in /run/user/$UID/gvfs

To be honest I have never liked the GVFS way of doing CIFS anyway. Last night I managed to put together an epic script that uses the standard mount way but with a few differences....

It checks to see if the mountpoints are active, if they are it unmounts them first (after giving a warning)

It creates a temporary creds file on /tmp (perms at 600), with username set to $USER and the password pulled from the gnome keyring.

The mounts are carried out using the temporary creds file which is then immediately removed again

The mounts have UID set to $UID and dir_mode 0700 file_mode 0600 so the user doing the mount is the only one who can access it (and root ofc)

The mounts have nounix in the options so the NAS managers the permissions itself (which is what I want)


So I think its secure enough. EVERY app works fine with it as it looks like its on the file system, no weird GVFS black magic. Its 'per user' but would not work in a mutli-user environment unless each user had their own set of mount points. Everything gets unmounted at shutdown.

Anyone wants a copy of this I'll post it

Not marking as solved as the issue with GVFS is not solved...

Offline

#4 2015-10-14 15:22:30

DimitrisC
Member
Registered: 2015-10-09
Posts: 3

Re: GVFS mount points missing in /run/user/$UID/gvfs

I think the problem I am having relates to this thread.

I updated the system yesterday and my NAS shares stopped showing in Nautilus.

I can navigate to the samba share using CTRL + L in Nautilus and typing "smb://" but when I try to play a file in VLC I get the an error that the file is missing from /run/user/1000/ etc. 
It seems that the samba share is not properly being mounted at that location although by manually navigating to smb:// is shown as mounted in Nautilus.

I am not sure if it was the gvfs-smb package update that borked my samba share but I would be greatfull If anyone here can provide any clues as to solve this issue. Thanks.

Offline

#5 2015-10-15 16:09:12

kyak
Member
Registered: 2012-01-20
Posts: 29

Re: GVFS mount points missing in /run/user/$UID/gvfs

Same thing here. gvfs mount points are empty for sftp shares. It used to work fine before..

Offline

#6 2015-10-15 19:01:12

saivert
Member
Registered: 2014-06-13
Posts: 19

Re: GVFS mount points missing in /run/user/$UID/gvfs

Offline

#7 2016-09-28 01:59:04

ddelpino
Member
Registered: 2011-03-07
Posts: 21

Re: GVFS mount points missing in /run/user/$UID/gvfs

This script solve it, for now...

#!/bin/bash

# Add to Cron
# */1 * * * * /root/fixGvfs

w | grep -v root | tail -n +3 | awk '{print $1}' > /tmp/fixGvfsUsers

while read usuario
do
  id=$(id -u $usuario)
  if [ ! -f "/tmp/fixGvfs${id}" ]; then
    umount /run/user/${id}/gvfs
    if [ $? -eq 0 ]; then
      su - $usuario -c "/usr/bin/pkill gvfs*"
      touch "/tmp/fixGvfs${id}"
    fi
  fi
done < /tmp/fixGvfsUsers

Offline

Board footer

Powered by FluxBB