You are not logged in.

#1 2006-04-06 23:46:48

mcmillan
Member
Registered: 2006-04-06
Posts: 703

Problem Making Devilspie Package

I had devil's pie working in Arch, but had to do a reinstall of my system and am having trouble building the package this time. 

checking for WNCK... configure: error:  Package requirements (glib-2.0 >= 2.9.1
        gdk-2.0
        libwnck-1.0 >= 0.17) were not met:


No package 'glib-2.0' found
No package 'gdk-2.0' found
No package 'libwnck-1.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables WNCK_CFLAGS
and WNCK_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

For glib, I have 2.10, I'm wondering if there might be an issue since the package is called glib2, there's also another package called glib which is only 1.2
For libwnch I have 2.14
I didn't have gdk, and couldn't find it in the repositories or in aur, but found this which I tried compiling. It seems to be a lower version though, and didn't work with that.

I'm not sure how to go about modifying those variables it mentions, and I don't have a man entry for pkg-config.

Don't suppose anyone else has gotten similar errors or knows how to proceed from here?

Offline

#2 2006-04-06 23:51:47

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: Problem Making Devilspie Package

Is pkgconfig installed? If not, install it:
pacman -S pkgconfig
and try again to build devilspie.

Offline

#3 2006-04-06 23:59:05

mcmillan
Member
Registered: 2006-04-06
Posts: 703

Re: Problem Making Devilspie Package

That  did it, must have forgotten to reinstall that package. Thanks a lot for the quick answer

Offline

Board footer

Powered by FluxBB