You are not logged in.

#1 2015-11-06 21:21:21

nuew
Member
Registered: 2015-11-06
Posts: 2

[SOLVED] JPEGs don't work.

Hi! I recently did a spring cleaning, and after a reboot, (for no apparent reason, as I did nothing relating to images), JPEG's don't work anymore in programs that use libjpeg-turbo (Firefox and GIMP still work).

Here is the output of some commands, Jpegvergroessert.jpg being an image from wikipedia:

$ uname -a
Linux nuew-linux 4.2.5-1-ARCH #1 SMP PREEMPT Tue Oct 27 08:13:28 CET 2015 x86_64 GNU/Linux
$ file Jpegvergroessert.jpg
Jpegvergroessert.jpg: JPEG image data, JFIF standard 1.01, resolution (DPI), density 300x300, segment length 16, baseline, precision 8, 192x256, frames 3

However, opening it in gpicview produces a black screen with the following error message: "Couldn't recognize the image file format for file '/home/nuew/Desktop/Jpegvergroessert.jpg'". Similarly, my desktop background (via pcmanfm), a jpeg, doesn't display, leaving just a black screen.

If you need any more information, I will be happy to provide it, and any help, will, of course, be appreciated.

Last edited by nuew (2015-11-08 18:00:14)

Offline

#2 2015-11-07 16:42:58

nuew
Member
Registered: 2015-11-06
Posts: 2

Re: [SOLVED] JPEGs don't work.

I fixed it by reinstalling gdk-pixbuf2 and restarting.

Offline

#3 2015-11-08 17:38:46

twelveeighty
Member
From: Alberta, Canada
Registered: 2011-09-04
Posts: 957

Re: [SOLVED] JPEGs don't work.

Please remember to edit your post and mark the subject as [SOLVED].

Offline

Board footer

Powered by FluxBB