You are not logged in.

#1 2006-04-08 23:09:02

hussam
Member
Registered: 2006-03-26
Posts: 527
Website

Digital camera not working anymore

I'm pretty sure this worked at least once since I installed archlinux.
But now, whenever I plug in my usb digital camera, I get the usual kde dialog
and I open the digital camera in konqueror, but all I see inside is a blank
0k file.
EDIT:..
also lshwd outputs:
001:011 USB Imaging: KODAK EasyShare CX7310 Digital Camera (unknown)

The follwing also looked weird. ( btw, I have only 2 usb ports on this P3 )

ls -lR /proc/bus/usb

/proc/bus/usb:
total 0
dr-xr-xr-x  2 root root 0 2006-04-09 04:05 001
dr-xr-xr-x  2 root root 0 2006-04-09 04:05 002
-r--r--r--  1 root root 0 2006-04-09 01:13 devices

/proc/bus/usb/001:
total 0
-rw-r--r--  1 root root 43 2006-04-09 04:05 001
-rw-r--r--  1 root root 50 2006-04-09 01:13 005

/proc/bus/usb/002:
total 0
-rw-r--r--  1 root root 43 2006-04-09 04:05 001

Offline

#2 2006-04-09 10:40:23

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: Digital camera not working anymore

dunno if it is related, but I had a problem connecting to my canon ixus 50 with f-spot in gnome.
I found out it was a bug in libgphoto2 Although I think this bug was related to canon cameras only, you still may want to try it.
The fix I found is here: http://bugs.archlinux.org/task/4293

Offline

#3 2006-04-09 20:12:49

hussam
Member
Registered: 2006-03-26
Posts: 527
Website

Re: Digital camera not working anymore

does that mean I have to rebuild the kernel?

Offline

#4 2006-04-09 21:52:07

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: Digital camera not working anymore

hussam wrote:

does that mean I have to rebuild the kernel?

no, that means that you have to apply the patch when building, so in the PKGBUILD.
Save the patch linked in the bug report as gphoto2-2.1.99-canon-segv.patch, and use the following PKGBUILD

pkgname=libgphoto2
pkgver=2.1.99
pkgrel=1
pkgdesc="The core of gphoto2 software. It is a portable library to gives access to more than 400 digital cameras."
url="http://www.gphoto.org"
depends=(glibc libusb libexif libjpeg)
conflicts=()
backup=(etc/udev/rules.d/gphoto.rules)
source=(http://dl.sourceforge.net/gphoto/$pkgname-$pkgver.tar.gz 
    convert-usermap-libgphoto2.sh gphoto2-2.1.99-canon-segv.patch)
install=(libgphoto2.install)

build() {
  cd $startdir/src/$pkgname-$pkgver

  # canon-segv patch
  patch -p0 < $startdir/src/gphoto2-2.1.99-canon-segv.patch || return 1

  ./configure --prefix=/usr --with-exif
  make || return 1
  make prefix=$startdir/pkg/usr install
  mkdir -p $startdir/pkg/usr/share/libgphoto2/$pkgver/linux-hotplug
  cp -r packaging/linux-hotplug/usb* $startdir/pkg/usr/share/libgphoto2/$pkgver/linux-hotplug
  # install udev rules
  $startdir/src/$pkgname-$pkgver/packaging/linux-hotplug/print-usb-usermap >> $startdir/src/gphoto.usermap
  $startdir/src/convert-usermap-libgphoto2.sh $startdir/src/gphoto.usermap
  sed -i -e 's/SYSFS{idVendor}=="0000"/#SYSFS{idVendor}=="0000"/g' gphoto.rules
  install -D -m 644 gphoto.rules $startdir/pkg/etc/udev/rules.d/gphoto.rules
  #libtoolslay
  find $startdir/pkg -name '*.la' -exec rm {} ;
}

but as I said, I don't know if it is related to your problem

Offline

#5 2006-04-09 22:25:55

hussam
Member
Registered: 2006-03-26
Posts: 527
Website

Re: Digital camera not working anymore

Ok thanks for the help. I installed digikam and I can now access the  digital camera using digikam. I still can't access it from konqueror like I did in kubuntu. But it works fine from within digikam.
Thanks for the help. smile

Offline

Board footer

Powered by FluxBB