You are not logged in.

#1 2015-11-13 03:42:27

stevepa
Member
From: Texas USA
Registered: 2012-02-12
Posts: 113

[solved]Thinkpad T60 - boots to blank screen

Problem: After the grub menu appears, system flashes messages and then screen goes blank. Efforts to get to a working screen have failed, so I have to power off. Note this problem occurs before I can even login, and also that I do not use a display manager.


Review of journalctl -b -1 shows nothing odd as far as I can see. In fact, I have seen no evidence of an error message anywhere.

I am not sure when this problem started, but I believe it was in the last two weeks.

The workaround has been to add the kernel parameter "nomodeset" , which does boot into a working system.

Installation of the linux-lts kernel still requires the nomodeset parameter. Installing alternative kernels does not seem to fix the problem.

This laptop has worked fine for a long time and the fact that this bone standard "iconic" laptop is having this problem is confusing me.

My system:
Lenovo T6VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV515/M52 [Mobility Radeon X1300]
Kernel: 4.2.5-1-ARCH #1 SMP PREEMPT Tue Oct 27 08:28:41 CET 2015 i686 GNU/Linux
Video Driver: xf86-video-ati
DE: gnome 3.18.2
Update status: fully updated.

QUESTION: I don't like the necessity of using nomodeset as it should not be required. How should I proceed to troubleshoot this issue?

Also note, my other laptop T60p, ATI graphics, as a very similar issue but in that case, I can not start X (it complains about nomodeset).

Ideas?

Last edited by stevepa (2015-11-13 18:16:29)


Arch - LVM - ext4 - gnome (T60p 14.1 1400p  x86_64), (T60 15 flexview 1400p i686)

Offline

#2 2015-11-13 14:03:35

c0mm0ner
Member
Registered: 2015-11-09
Posts: 93

Re: [solved]Thinkpad T60 - boots to blank screen

Would you mind posting the logs as well as your kernel command line nevertheless?

Offline

#3 2015-11-13 14:40:17

stevepa
Member
From: Texas USA
Registered: 2012-02-12
Posts: 113

Re: [solved]Thinkpad T60 - boots to blank screen

c0mm0ner wrote:

Would you mind posting the logs as well as your kernel command line nevertheless?

Do you want the complete journalctl log from a failing boot? (A lot of lines).
Kernel line is stock but will post.

I am at work, but can post it within 4 hours.

Thanks for the reply


Arch - LVM - ext4 - gnome (T60p 14.1 1400p  x86_64), (T60 15 flexview 1400p i686)

Offline

#4 2015-11-13 15:20:47

TheChickenMan
Member
From: United States
Registered: 2015-07-25
Posts: 353

Re: [solved]Thinkpad T60 - boots to blank screen

There is a bug in the current kernel and lts kernel with the radeon driver. You can fix it for now by reverting to kernel version 4.2.3-1.
https://bugs.archlinux.org/task/46902?o … ed%5B0%5D=

Last edited by TheChickenMan (2015-11-13 15:21:11)


If quantum mechanics hasn't profoundly shocked you, you haven't understood it yet.
Niels Bohr

Offline

#5 2015-11-13 18:14:08

stevepa
Member
From: Texas USA
Registered: 2012-02-12
Posts: 113

Re: [solved]Thinkpad T60 - boots to blank screen

TheChickenMan wrote:

There is a bug in the current kernel and lts kernel with the radeon driver. You can fix it for now by reverting to kernel version 4.2.3-1.
https://bugs.archlinux.org/task/46902?o … ed%5B0%5D=

This worked! Appreciate it. Will try this on my other nonfunctional laptop.

What I think is strange is why the lts kernel still would not boot without the nomodeset parameter...


Oh, well. Will just wait for the next released kernel.

Tks

Update: Downgrading the the kernel to 4.2.3-1 works for:
1. Lenovo Thinkpad T60
2. Lenovo Thinkpad T60p

Last edited by stevepa (2015-11-14 19:50:38)


Arch - LVM - ext4 - gnome (T60p 14.1 1400p  x86_64), (T60 15 flexview 1400p i686)

Offline

Board footer

Powered by FluxBB