You are not logged in.

#1 2015-11-20 18:22:16

gccpy
Member
Registered: 2015-09-16
Posts: 9

Xfce problems after monitor turn off with nvidia

When using nvidia driver for X11, turning monitor off and on, I get a "no signal" message. Monitor is connected over DisplayPort.

To test the possible causes I switched to nouveau driver, but the problem is even stranger with it. When monitor is turned on again, xfce appears, but desktop wallpaper resets to default one. The mouse cursor becomes invisible (mouse is usable, but its always displayed in the position that it was in before turn off). If I switch to another tty and back to one with X11 I get "no signal" again.

I'm not sure where to even start with this problem, any feedback is appreciated.

Last edited by gccpy (2015-11-21 13:49:05)

Offline

#2 2015-11-21 00:27:05

unipan
Member
Registered: 2015-11-09
Posts: 14

Re: Xfce problems after monitor turn off with nvidia

Could you tell me which GPU do you have and which Nvidia driver do you use?
And how are your xorg.conf and xinitrc files?

You can first try to uninstall noueau and install a matching driver from here :  http://www.nvidia.fr/Download/index.aspx
Before doing this, rename your xorg.conf file and when the nvidia installation runs say yes to the automatic xorg configuration (it's on "no" by default").

So you'll have fresh drivers and X setup

The more informations you provide, the more we can help.

Last edited by unipan (2015-11-21 00:37:25)


Archnewbie

Offline

#3 2015-11-21 00:54:58

loqs
Member
Registered: 2014-03-06
Posts: 17,714

Re: Xfce problems after monitor turn off with nvidia

unipan wrote:

You can first try to uninstall noueau and install a matching driver from here :  http://www.nvidia.fr/Download/index.aspx
Before doing this, rename your xorg.conf file and when the nvidia installation runs say yes to the automatic xorg configuration (it's on "no" by default").

@unipan did you miss the warning on the wiki?
Installing

Warning: Avoid installing the NVIDIA driver through the package provided from the NVIDIA website. Installation through pacman allows upgrading the driver together with the rest of the system.

Offline

#4 2015-11-21 01:04:28

unipan
Member
Registered: 2015-11-09
Posts: 14

Re: Xfce problems after monitor turn off with nvidia

Official packages didn't work for me. Packages from nvidia did.


Archnewbie

Offline

#5 2015-11-21 11:00:57

gccpy
Member
Registered: 2015-09-16
Posts: 9

Re: Xfce problems after monitor turn off with nvidia

unipan wrote:

And how are your xorg.conf and xinitrc files?

Removed my 20-nvidia.conf and .xinitrc, and to my surprise monitor turned on correctly with both nvidia and nouveau. Tested with fluxbox and dwm, and the behaviour is same -- monitor works (or at least it does at first glance). It seems xfce is doing something it shouldn't, going to search for possible causes with xfce, and then test the official nvidia driver to be sure.

Offline

#6 2015-11-21 13:33:44

gccpy
Member
Registered: 2015-09-16
Posts: 9

Re: Xfce problems after monitor turn off with nvidia

unipan wrote:

You can first try to uninstall noueau and install a matching driver from here :  http://www.nvidia.fr/Download/index.aspx
Before doing this, rename your xorg.conf file and when the nvidia installation runs say yes to the automatic xorg configuration (it's on "no" by default").

So you'll have fresh drivers and X setup

The downloaded nvidia driver works exactly like pacman driver. Problem remains.

For those curious, my card is GTX 670 and downloaded driver version is 352.63 (pacman has 355.11)

Offline

#7 2015-11-21 15:01:24

toz
Member
Registered: 2011-10-28
Posts: 497

Re: Xfce problems after monitor turn off with nvidia

gccpy wrote:

It seems xfce is doing something it shouldn't, going to search for possible causes with xfce

I recall seeing a few bug reports in Xfce's bugzilla that "may be" related to the same issue. Looks like they're still trying to narrow it down.
- https://bugzilla.xfce.org/show_bug.cgi?id=11627
- https://bugzilla.xfce.org/show_bug.cgi?id=11696
- https://bugzilla.xfce.org/show_bug.cgi?id=8735

You can also run xfce4-power-manager in debug mode. First kill the xfce4-power-manager process then:

xfce4-power-manager --no-daemon --debug

...might yield some helpful information.

Offline

#8 2015-11-22 13:47:02

gccpy
Member
Registered: 2015-09-16
Posts: 9

Re: Xfce problems after monitor turn off with nvidia

toz wrote:

You can also run xfce4-power-manager in debug mode. First kill the xfce4-power-manager process then:

xfce4-power-manager --no-daemon --debug

...might yield some helpful information.

I redirected output of the command to a file, and after monitor on/off test, it had an error:

xfce4-power-manager: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.

Offline

#9 2015-11-22 15:08:56

toz
Member
Registered: 2011-10-28
Posts: 497

Re: Xfce problems after monitor turn off with nvidia

Interesting. Does this error happen at the exact time that the monitor is turned off and on?

What if you killed the xfce4-power-manager process completely and tried to manipulate the screens via xrandr manually as you turn on and off the monitor? If this works, then it would infer that there is a bug in the xfce4-power-manager code.

Offline

#10 2015-11-22 16:27:16

gccpy
Member
Registered: 2015-09-16
Posts: 9

Re: Xfce problems after monitor turn off with nvidia

toz wrote:

Interesting. Does this error happen at the exact time that the monitor is turned off and on?

Did some checking, I posted a misleading error message, sorry.
Message appears every time i close X11, when monitor is on/off nothing particular is written to the power manager output.

toz wrote:

What if you killed the xfce4-power-manager process completely and tried to manipulate the screens via xrandr manually as you turn on and off the monitor? If this works, then it would infer that there is a bug in the xfce4-power-manager code.

Created a keyboard shortcut for

xrandr --output DP-1 --auto

It turns on my monitor (though no sound through it), at least it allows me to finish my work and close open programs instead of restarting X11. Doesn't solve the problem, but enough of a workaround, thank you.

Offline

Board footer

Powered by FluxBB