You are not logged in.

#1 2015-12-08 12:55:18

ripel
Member
Registered: 2015-10-23
Posts: 10

startx works but xinit does not

Hi, I don't have a display manager and I have been using startx for login to my DE. I tried xinit and failed to start session. I don't understand why startx is just working fine but xinit fails. Aren't they both use the ~/.xinitrc file? Here is the output of Xorg.0.log:

 [    38.740] 
X.Org X Server 1.18.0
Release Date: 2015-11-09
[    38.740] X Protocol Version 11, Revision 0
[    38.740] Build Operating System: Linux 4.2.3-1-ARCH x86_64 
[    38.740] Current Operating System: Linux ideapc 4.2.5-1-ARCH #1 SMP PREEMPT Tue Oct 27 08:13:28 CET 2015 x86_64
[    38.740] Kernel command line: initrd=\intel-ucode.img initrd=\initramfs-linux.img root=/dev/sda6 rw quiet
[    38.740] Build Date: 18 November 2015  08:07:09AM
[    38.740]  
[    38.740] Current version of pixman: 0.32.8
[    38.740] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    38.740] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    38.740] (==) Log file: "/home/serpil/.local/share/xorg/Xorg.0.log", Time: Tue Dec  8 14:46:55 2015
[    38.786] (==) Using config file: "/etc/X11/xorg.conf"
[    38.786] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    38.786] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    38.815] (==) ServerLayout "X.org Configured"
[    38.815] (**) |-->Screen "Screen0" (0)
[    38.815] (**) |   |-->Monitor "Monitor0"
[    38.816] (**) |   |-->Device "Card0"
[    38.816] (**) |   |-->GPUDevice "Nvidia Card"
[    38.816] (**) |   |-->GPUDevice "Card0"
[    38.816] (**) |-->Input Device "Mouse0"
[    38.816] (**) |-->Input Device "Keyboard0"
[    38.816] (==) Automatically adding devices
[    38.816] (==) Automatically enabling devices
[    38.816] (==) Automatically adding GPU devices
[    38.816] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    38.854] (**) FontPath set to:
	/usr/share/fonts/misc/,
	/usr/share/fonts/TTF/,
	/usr/share/fonts/OTF/,
	/usr/share/fonts/Type1/,
	/usr/share/fonts/100dpi/,
	/usr/share/fonts/75dpi/,
	/usr/share/fonts/misc/,
	/usr/share/fonts/TTF/,
	/usr/share/fonts/OTF/,
	/usr/share/fonts/Type1/,
	/usr/share/fonts/100dpi/,
	/usr/share/fonts/75dpi/
[    38.854] (**) ModulePath set to "/usr/lib/xorg/modules"
[    38.854] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    38.854] (WW) Disabling Mouse0
[    38.854] (WW) Disabling Keyboard0
[    38.854] (II) Loader magic: 0x819d40
[    38.854] (II) Module ABI versions:
[    38.854] 	X.Org ANSI C Emulation: 0.4
[    38.854] 	X.Org Video Driver: 20.0
[    38.854] 	X.Org XInput driver : 22.1
[    38.854] 	X.Org Server Extension : 9.0
[    38.857] (II) systemd-logind: took control of session /org/freedesktop/login1/session/c1
[    38.857] (II) xfree86: Adding drm device (/dev/dri/card0)
[    38.858] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 8 paused 0
[    38.961] (--) PCI:*(0:0:2:0) 8086:0a16:17aa:3978 rev 9, Mem @ 0xf3000000/4194304, 0xd0000000/268435456, I/O @ 0x00005000/64
[    38.961] (II) Open ACPI successful (/var/run/acpid.socket)
[    38.961] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[    38.961] (II) LoadModule: "glx"
[    38.991] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    39.115] (II) Module glx: vendor="X.Org Foundation"
[    39.115] 	compiled for 1.18.0, module version = 1.0.0
[    39.115] 	ABI class: X.Org Server Extension, version 9.0
[    39.115] (==) AIGLX enabled
[    39.115] (II) LoadModule: "intel"
[    39.125] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    39.178] (II) Module intel: vendor="X.Org Foundation"
[    39.178] 	compiled for 1.18.0, module version = 2.99.917
[    39.178] 	Module class: X.Org Video Driver
[    39.178] 	ABI class: X.Org Video Driver, version 20.0
[    39.178] (II) LoadModule: "nvidia"
[    39.178] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    39.276] (II) Module nvidia: vendor="NVIDIA Corporation"
[    39.276] 	compiled for 4.0.2, module version = 1.0.0
[    39.276] 	Module class: X.Org Video Driver
[    39.276] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
	i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
	915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
	Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
	GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[    39.277] (II) intel: Driver for Intel(R) HD Graphics: 2000-6000
[    39.277] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100, 6100
[    39.277] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200, 6200, P6300
[    39.277] (II) NVIDIA dlloader X Driver  358.16  Mon Nov 16 18:32:40 PST 2015
[    39.277] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    39.278] (EE) 
Fatal server error:
[    39.278] (EE) parse_vt_settings: Cannot open /dev/tty0 (No such file or directory)
[    39.278] (EE) 
[    39.278] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[    39.278] (EE) Please also check the log file at "/home/serpil/.local/share/xorg/Xorg.0.log" for additional information.
[    39.278] (EE)  

and my ~/.xinitrc:

 #!/bin/sh

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/.Xresources
sysmodmap=/etc/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then







    xrdb -merge $sysresources

fi

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f "$userresources" ]; then







    xrdb -merge "$userresources"

fi

if [ -f "$usermodmap" ]; then
    xmodmap "$usermodmap"
fi

# start some nice programs

if [ -d /etc/X11/xinit/xinitrc.d ] ; then
 for f in /etc/X11/xinit/xinitrc.d/?*.sh ; do
  [ -x "$f" ] && . "$f"
 done
 unset f
fi

# twm &
# xclock -geometry 50x50-1+1 &
# xterm -geometry 80x50+494+51 &
# xterm -geometry 80x20+494-0 &
# exec xterm -geometry 80x66+0+0 -name login

session=${1:-gnome}

case $session in
    awesome           ) exec awesome;;
    bspwm             ) exec bspwm;;
    catwm             ) exec catwm;;
    cinnamon          ) exec cinnamon-session;;
    dwm               ) exec dwm;;
    enlightenment     ) exec enlightenment_start;;
    ede               ) exec startede;;
    fluxbox           ) exec startfluxbox;;
    gnome             ) exec gnome-session;;
    gnome-classic     ) exec gnome-session --session=gnome-classic;;
    i3|i3wm           ) exec i3;;
    icewm             ) exec icewm-session;;
    jwm               ) exec jwm;;
    kde               ) exec startkde;;
    lxde		) exec startlxde;;
    lxqt		) exec startlxqt;;
    mate              ) exec mate-session;;
    monster|monsterwm ) exec monsterwm;;
    notion            ) exec notion;;
    openbox           ) exec openbox-session;;
    unity             ) exec unity;;
    xfce|xfce4        ) exec startxfce4;;
    xmonad            ) exec xmonad;;
    # No known session, try to run it as command
    *) exec $1;;
esac 

I also copied /etc/X11/xinit/xserverrc to my home folder.

#!/bin/sh
exec /usr/bin/X -nolisten tcp "$@"

Should I need to modify ~/.xserverrc file? Is that the problem?

Offline

#2 2015-12-08 12:58:51

Awebb
Member
Registered: 2010-05-06
Posts: 5,314

Re: startx works but xinit does not

What command line did you use to start X with xinit? xinit needs a few arguments, that's why we have startx.

Offline

#3 2015-12-08 13:02:11

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 22,274
Website

Re: startx works but xinit does not

(EE) parse_vt_settings: Cannot open /dev/tty0 (No such file or directory)

You didn't specify a tty.

Nor did you read the wiki which makes the need to do so explicitly clear and provides the exact xinit command you should use.

Please search before posting.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#4 2015-12-08 15:24:23

ripel
Member
Registered: 2015-10-23
Posts: 10

Re: startx works but xinit does not

Sure, I read wiki before and when I tried

 xinit -- :1 -nolisten tcp vt$XDG_VTNR 

it worked fine. But then I configured my ~/.xinitrc file and just type

xinit

as said in https://wiki.archlinux.org/index.php/Xi … FWM_choice
xinit is faster but if i need to pass these arguments everytime to login using xinit then startx is easier. It would be nice if just typing "xinit" is enough.

edit: I just noticed the fault in my xinitrc. I already renamed the files in /etc/X11/xinit/xinitrc.d before but i haven't noticed the "*.sh" line in if block. i edited it.

Last edited by ripel (2015-12-08 15:52:52)

Offline

#5 2015-12-08 15:57:25

TheChickenMan
Member
From: United States
Registered: 2015-07-25
Posts: 353

Re: startx works but xinit does not

You could also make an alias for startx so that you type whatever you would like.


If quantum mechanics hasn't profoundly shocked you, you haven't understood it yet.
Niels Bohr

Offline

#6 2015-12-08 18:43:23

ripel
Member
Registered: 2015-10-23
Posts: 10

Re: startx works but xinit does not

TheChickenMan wrote:

You could also make an alias for startx so that you type whatever you would like.

making an alias for startx didnt help either. I made it as:

 alias startx='xinit -- :1 -nolisten tcp vt$XDG_VTNR'

but it took almost longer than normal. I just hoped for a less slower login.

Offline

#7 2015-12-08 19:11:40

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 22,274
Website

Re: startx works but xinit does not

Do you really have 23 WMs installed?


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#8 2015-12-08 19:43:50

drcouzelis
Member
From: Connecticut, USA
Registered: 2009-11-09
Posts: 4,034
Website

Re: startx works but xinit does not

ripel wrote:

xinit is faster

How much faster are we talking? Like, new-SSD-installed faster? Or Gentoo-binary-compiled-just-for-my-machine faster?

Offline

#9 2015-12-09 00:19:12

ripel
Member
Registered: 2015-10-23
Posts: 10

Re: startx works but xinit does not

Trilby wrote:

Do you really have 23 WMs installed?

No, I haven't, I only have 3 right now. Would it be trouble to have all of them in my .xinitrc? Earlier I had only the ones I'm using currently but timing was still same. Putting all of them really didn't make any difference and I like trying and figuring out things. I switch between different DE's occasionly.
I thought; ~/.xserverrc file is the key here maybe if I modify this file then typing "xinit" would work without arguments. That's the reason I made this topic. I understand, I have to use either startx or xinit with arguments as said in https://wiki.archlinux.org/index.php/Xi … figuration. Thank you all for helping.

Last edited by ripel (2015-12-09 00:20:26)

Offline

#10 2016-06-08 10:03:26

imran27
Member
From: Mumbai, India
Registered: 2015-12-15
Posts: 6

Re: startx works but xinit does not

Something which I did and made it working.

Copy xserverrc from /etc/X11/xinit/xserverrc to your home and add a parameter telling the command about the vt number to use i.e. add vt${XDG_VTNR} before "$@" and it should work fine.

Your final ~/.xserverrc should look like:

#!/bin/sh
exec /usr/bin/X -nolisten tcp vt${XDG_VTNR} "${@}"

Last edited by imran27 (2016-06-08 10:04:39)

Offline

Board footer

Powered by FluxBB