You are not logged in.

#1 2015-12-14 10:38:23

davy_crockett
Member
Registered: 2015-10-21
Posts: 73

[SOLVED] Truecrypt stopped working

Hi there,

I was using Truecrypt fine on Wednesday the 9th of December and sometime between then and now I ran pacman -Syu and one of the packages it "upgraded" was truecrypt. I'm not sure how, as the last release has always been 1.71, although I noticed the package is described in pacman as truecrypt 1:7.1a-3. I think the -3 on the end might've been what's changed.

Since I rebooted my computer, I haven't been able to mount any of my truecrypt volumes from my external or external hard drives using truecrypt. I can mount them in Windows using truecrypt without any issues. I can also mount them in arch linux using cryptsetup, although truecrypt is my preferred method. It will say "incorrect password or not a truecrypt volume". If I try selecting the device in truecrypt and mounting it manually it will say "invalid characters encountered". It will do the same if I try and mount a device through the command line.

What might be causing this? I have several truecrypt volumes and they all do exactly the same thing on linux, yet they mount fine in Windows. I could install truecrypt manually, I have the linux installation file for it. Should I remove the copy from pacman and install it manually?

Last edited by davy_crockett (2016-01-23 07:36:34)

Offline

#2 2015-12-14 10:47:22

LCvanDinteren
Member
From: Netherlands
Registered: 2015-10-27
Posts: 153

Re: [SOLVED] Truecrypt stopped working

As a temporary fix you might want to downgrade truecrypt.

Offline

#3 2015-12-14 15:22:09

drcouzelis
Member
From: Connecticut, USA
Registered: 2009-11-09
Posts: 4,057
Website

Re: [SOLVED] Truecrypt stopped working

davy_crockett wrote:

I'm not sure how, as the last release has always been 1.71, although I noticed the package is described in pacman as truecrypt 1:7.1a-3. I think the -3 on the end might've been what's changed.

The reason for the change is because of the recent changes to GCC and the C++ ABI. TrueCrypt hasn't changed, it was just rebuilt.

If you did a partial upgrade or are using a package that hasn't been recompiled for the new ABI (such as from the AUR) then that could cause TrueCrypt not to work.

...Hmmm, I wonder if my TrueCrypt volume still works. I haven't mounted it since the upgrade. I should try that when I get home. big_smile

Offline

#4 2015-12-14 17:14:34

jjacky
Member
Registered: 2011-11-09
Posts: 347
Website

Re: [SOLVED] Truecrypt stopped working

Seems to be a problem with truecrypt & the new ABI: https://bugs.archlinux.org/task/47325
As you said, using cryptsetup it works fine; And if you really want to use truecrypt, downgrading to the previous package seems indeed to do the trick.

Offline

#5 2015-12-30 07:34:10

davy_crockett
Member
Registered: 2015-10-21
Posts: 73

Re: [SOLVED] Truecrypt stopped working

Thanks, apologies for the late reply; I've been away for Christmas. Downgrading the package seemed to do the trick. Another question I have - when mounting truecrypt volumes using cryptsetup, how do I mount the container using the mount command so it has the permissions of my standard user account? If I do the following it mounts with root user permissions and then I can't access any of its files:

sudo cryptsetup --type tcrypt open container-to-mount data
sudo mount /dev/mapper/data /mnt/truecrypt1

I can mount it successfully as a standard user by only running the first line and then clicking on the device in dolphin and it automatically mounts it with my standard user permissions. However it doesn't mount it to the /mnt/truecrypt1 directory. Out of curiosity how can I mount it to /mnt/truecrypt1 and have the permissions of my standard user account rather than root?

Offline

#6 2015-12-30 18:22:13

tom.ty89
Member
Registered: 2012-11-15
Posts: 896

Re: [SOLVED] Truecrypt stopped working

Windows filesystems? mount -o uid=*,gid=*?

Offline

#7 2015-12-31 00:30:16

davy_crockett
Member
Registered: 2015-10-21
Posts: 73

Re: [SOLVED] Truecrypt stopped working

Thanks.

I was thinking about adding the commands cryptsetup and mount to the /etc/sudoers file for standard user accounts that are members of the group truecrypt (I created a group so they wouldn't need to enter their password to mount truecrypt volumes using truecrypt). I wanted to do this so they don't need to use sudo or enter their password to mount truecrypt and luks volumes using cryptsetup and mount either. I understand there's a security risk involved with the entire cryptsetup command as it can be used to wipe and encrypt system volumes. Is there any security risk involved with not requiring sudo for mount? Is there a way I can avoid requiring sudo for cryptsetup only to open volumes and not create them? What would be the best practice for doing this?

I have this in my /etc/sudoers:

# Users in the truecrypt group are allowed to run Truecrypt as root
%truecrypt ALL=(root) NOPASSWD:/usr/bin/truecrypt

Last edited by davy_crockett (2015-12-31 00:34:30)

Offline

#8 2015-12-31 00:39:20

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 3,840

Re: [SOLVED] Truecrypt stopped working

davy_crockett wrote:

Is there a way I can avoid requiring sudo for cryptsetup only to open volumes and not create them?

You can't avoid using sudo but you can set it up to not require a password for just opening.
Add the following to your sudoers file...

%users ALL=(ALL) NOPASSWD: /usr/bin/cryptsetup open

No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#9 2015-12-31 01:17:01

davy_crockett
Member
Registered: 2015-10-21
Posts: 73

Re: [SOLVED] Truecrypt stopped working

I have the following commands in my /etc/sudoers file:

%truecrypt ALL=(root) NOPASSWD:/usr/bin/truecrypt
%truecrypt ALL=(root) NOPASSWD:/usr/bin/cryptsetup open
%truecrypt ALL=(root) NOPASSWD:/usr/bin/mount
%truecrypt ALL=(root) NOPASSWD:/usr/bin/umount

Is there any security risk here? I've added standard user accounts that I want to be able to mount encrypted volumes to the group truecrypt. What is the difference between specifying ALL=(ALL) and ALL=(root)?

Offline

#10 2015-12-31 01:39:20

Ropid
Member
Registered: 2015-03-09
Posts: 783

Re: [SOLVED] Truecrypt stopped working

That "=(ALL)" and "=(root)" has to do with the parameter "-u" that sudo has. You can use that "-u" to choose as what user a command should be run as. When you don't use "-u", then root is the default. With "=(ALL)", you are allowed to choose any user for that "-u", with "=(root)", it can only be root.

Offline

#11 2016-01-03 03:28:00

drcouzelis
Member
From: Connecticut, USA
Registered: 2009-11-09
Posts: 4,057
Website

Re: [SOLVED] Truecrypt stopped working

drcouzelis wrote:

...Hmmm, I wonder if my TrueCrypt volume still works. I haven't mounted it since the upgrade. I should try that when I get home. big_smile

Sorry to be a little off topic, but I thought it might help to follow up:

Turns out I've been using "tcplay" so the TrueCrypt update didn't affect me. hmm

Offline

Board footer

Powered by FluxBB