You are not logged in.

#1 2015-12-25 13:26:50

Lord Bo
Member
Registered: 2012-11-11
Posts: 160

Correct way to start PulseAudio?

I recently installed pulseaudio (and pulseaudio-alsa). Reading the wiki I thought, that PulseAudio would be started automatically for each user. I started pavucontrol and it just waited for pulseaudio being started, so PulseAudio wasn't started automatically. Also "systemctl | grep pulse" outputs nothing and I tried to enable pulseaudio.socket - No such file or directory -, so I assume that the pulseaudio.socket service file is missing. Is PulseAudio no longer to be started by systemd?

I then put "autospawn=yes" into /etc/pulse/client.conf. This however caused another error to occeur with pavucontrol (complains about a wrong configuration).

However starting pulseaudio manually (pulseaudio --start) works.

Does anyone know the correct way to start it at startup?

Last edited by Lord Bo (2015-12-25 13:28:55)

Offline

#2 2015-12-26 01:19:40

twelveeighty
Member
From: Alberta, Canada
Registered: 2011-09-04
Posts: 825

Re: Correct way to start PulseAudio?

Pulse installs a .desktop file in /etc/xdg/autostart/pulseaudio.desktop which runs "start-pulseaudio-x11". If you don't run a DE that automatically starts the .desktop files in that folder on log-in then you will have to find another way to auto-launch that app.

Offline

#3 2015-12-26 02:03:59

tom.ty89
Member
Registered: 2012-11-15
Posts: 897

Re: Correct way to start PulseAudio?

Socket is enabled by default:

systemctl --user status pulseaudio.socket

If you want pulseaudio to start right after login:

systemctl --user enable pulseaudio

Offline

Board footer

Powered by FluxBB