You are not logged in.

#1 2016-01-01 19:25:28

Registered: 2014-01-17
Posts: 10

Speakers unavailable on Lenovo Yoga 2 / headphones ok

I have a problem after I left my headphones plugged in when suspended my laptop.
My speakers are shown in Pavucontrol as "(unavailable)" but the headphones work fine.
I tried to unmute the speakers, also tried alsamixer or anything but with no success.
Here is my pacmd list-sinks

[david@naranja ~]$ pacmd list-sinks 
1 sink(s) available.
  * index: 8
	name: <alsa_output.pci-0000_00_1b.0.analog-stereo>
	driver: <module-alsa-card.c>
	state: IDLE
	suspend cause: 
	priority: 9959
	volume: front-left: 7010 /  11% / -58.25 dB,   front-right: 7010 /  11% / -58.25 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 33.85 ms
	max request: 6 KiB
	max rewind: 344 KiB
	monitor source: 10
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	used by: 0
	linked by: 1
	configured latency: 40.00 ms; range is 0.50 .. 2000.00 ms
	card: 0 <alsa_card.pci-0000_00_1b.0>
	module: 6
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix" = "ID 5114 Analog" = "ID 5114 Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xd0710000 irq 91"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1b.0"
		sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
		device.bus = "pci" = "8086" = "Intel Corporation" = "0f04" = "Atom Processor Z36xxx/Z37xxx Series High Definition Audio Controller"
		device.form_factor = "internal"
		device.string = "front:0"
		device.buffering.buffer_size = "352800"
		device.buffering.fragment_size = "176400"
		device.access_mode = "mmap+timer" = "analog-stereo"
		device.profile.description = "Analog Stereo"
		device.description = "Built-in Audio Analog Stereo"
		alsa.mixer_name = "Intel ID 2882"
		alsa.components = "HDA:14f15114,17aa3801,00100100 HDA:80862882,80860101,00100000"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
		analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: no)
				device.icon_name = "audio-speakers"
		analog-output-headphones: Headphones (priority 9000, latency offset 0 usec, available: yes)
				device.icon_name = "audio-headphones"
	active port: <analog-output-headphones>

I recently upgraded the kernel to 4.3.3 but I had the problem before
I also removed the files from ~/.config/pulse and /var/lib/alsa

I noticed in that output that analog outputs speaker is shown as "available: no"


#2 2021-02-16 00:00:17

Registered: 2021-02-15
Posts: 1

Re: Speakers unavailable on Lenovo Yoga 2 / headphones ok

I have a Lenovo Yoga 2 Pro too...
And I have the same exact problem.
The problem started like this: I was with my friends and the audio of my laptop (e.i. speakers) was working just fine. I went to another room for 5minutes and when I came back the speakers weren't working and now I don't have my audio working... I don't know what my friends did, but they did something and it made the sound on my laptop not work anymore. And since my friends aren't familiar with linux they don't have a clue on what they did that made my laptop like this!
Please, please for the love of god help me! in the 10-11 years that I've been working with GNU/Linux I have fixed all the problems that occurred to me, but this one I just can't figure out, already tried several thing but they didn't help. So please help me people I really need your help right now.
Thanks in advance.


Board footer

Powered by FluxBB