You are not logged in.

#1 2016-01-18 19:10:32

Registered: 2009-07-12
Posts: 36

Another instance of notify-osd already running


Some time ago I've installed notify-osd-customizablefrom AUR which has always worked as expected. Recently I've switched to the Pantheon Shell from Elementary OS which comes with its own own notification daemon in window manager Gala. Since then I've been able to disable the new one, but I can't get the command "notify-send" to work... That is: when using my own user. If I use sudo to execute the command it does work. I tried searching the forum and Google for a solution, but without a real solution, though I've found the following topic:

In the last posts there's a discussion about a file of Dbus being loaded after the Dbus service unit for the notification daemon, but these last posts are only a workaround, no real solution.
Does anyone know what might be the cause of this problem?

I ran following commands to obtain more information, some of them might be irrelevant:

- manually starting the executable of the notification-daemon results in:

cd /usr/lib/notify-osd-customizable

reading settings from '/home/wesley/.notify-osd'

** (notify-osd:1867): WARNING **: Another instance has already registered org.freedesktop.Notifications

** (notify-osd:1867): WARNING **: Could not register instance

- the Dbus service unit is still correct:

$ cat /usr/share/dbus-1/services/org.freedesktop.Notifications.service

[D-BUS Service]

Like the topic I mentioned earlier suggests: if I run "export $(dbus-launch)" and repeat the "notify-send" command it does work.

- If I check "echo $DBUS_SESSION_BUS_ADDRESS" it results in:


- My ~/.xinitrc file looks like this:

# ~/.xinitrc
# Executed by startx (run your window manager from here)

if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  unset f

# exec gnome-session
# exec startkde
#exec startxfce4
# ...or the Window Manager of your choice

exec gnome-session --session pantheon

- If I run "journalctl -b" I find nothing referring to org.freedesktop.Notifications, but I do find results for some of the other Dbus service units.

Thanks in advance!

Last edited by VenomGameworld (2016-01-18 19:12:02)


#2 2016-01-19 20:26:29

Registered: 2009-07-12
Posts: 36

Re: Another instance of notify-osd already running

Strange thing is that when I execute "export $(dbus-launch)" the notifications work afterwards... I would think this command is part of those in the /etc/X11/xinit/xinitrc.d/ directory so why isn't this executed at boot time?


#3 2016-04-06 17:54:21

Registered: 2013-02-13
Posts: 17

Re: Another instance of notify-osd already running

I have the same problem. dbus-launch /usr/lib/notify-osd/notify-osd, does work, I guess a different instance. At some point I stopped launching my window manager (xmonad) with dbus-launch because systemd. Not sure how to see what is registering with it, or why you can't register multiple listeners to registered org.freedesktop.Notifications


Board footer

Powered by FluxBB