You are not logged in.

#1 2006-04-24 16:24:55

From: Poland
Registered: 2005-10-12
Posts: 352

gphoto2 problem [SOLVED]

I don't know what is happening, but suddenly (or rather after one of the updates),camera support stopped working.

Now, digikam is complaining that it cannot access the camera, though I know it got recognized successfully. The usb mountpoints are set up, and gphoto2 sees the camera as both root and normal user.

[neuro@wintermute:~] gphoto2 --summary -a
Detected a 'Canon:PowerShot A95 (normal mode)'.
Camera summary:

Camera identification:
  Model: Canon:PowerShot A95 (normal mode)
  Owner: MW

Power status: on battery (power OK)

Flash disk information:
  Drive D:
      499'672 bytes total
      418'272 bytes available

Time: 2006-04-24 18:21:03 (host time +0 seconds)

Abilities for camera             : Canon PowerShot A95 (normal mode)
Serial port support              : no
USB support                      : yes
Capture choices                  :
                                 : Image
                                 : Preview
Configuration support            : yes
Delete files on camera support   : yes
File preview (thumbnail) support : yes
File upload support              : no

The thing is, I cannot download anything. No images, not even the thumbnails. I get this wicked error, and don't really know what it means. It never happened before.

While trying to download all files from the image folder, I get:

[neuro@wintermute:~/photo] gphoto2 -f '/DCIM/100CANON' -P
Detected a 'Canon:PowerShot A95 (normal mode)'.
Downloading 'IMG_0001.JPG' from folder '/DCIM/100CANON'...
gphoto2: symbol lookup error: gphoto2: undefined symbol: GP_SYSTEM_IS_FILE

As for more details, when runnign with --debug I get

9.348179 canon/usb.c(2): canon_usb_dialogue: camera reports 0x14 bytes (0x54 total)
9.348193 gphoto2-port(2): Reading 20=0x14 bytes from port...
9.349084 gphoto2-port(3): Hexdump of 20 = 0x14 bytes follows:
0000  02 00 00 00 0e 00 00 21-14 00 00 00 09 00 00 00  .......!........
0010  00 00 00 00            -                         ....

9.349161 libgphoto2/gphoto2-filesys.c(2): Adding file 'IMG_0001.JPG' to folder '/DCIM/100CANON' (type 1)...
9.349777 libgphoto2/gphoto2-filesys.c(2): Adding file 'IMG_0001.JPG' from folder '/DCIM/100CANON' to the fscache LRU list (type 1)...
9.350672 libgphoto2/gphoto2-filesys.c(2): File 'IMG_0001.JPG' from folder '/DCIM/100CANON' added in fscache LRU list.
9.350687 libgphoto2/gphoto2-filesys.c(2): Checking fscache LRU list integrity...
9.350696 libgphoto2/gphoto2-filesys.c(2): fscache LRU list ok with 1 items (1242846 bytes)
9.350717 libgphoto2/gphoto2-filesys.c(2): File does not contain mtime. Trying information on the file...
9.350732 libgphoto2/gphoto2-filesys.c(2): Getting information about 'IMG_0001.JPG' in '/DCIM/100C
gphoto2: symbol lookup error: gphoto2: undefined symbol: GP_SYSTEM_IS_FILE

Any ideas what went wrong?


#2 2006-04-24 17:05:49

From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,263

Re: gphoto2 problem [SOLVED]

pacman -Qi libgphoto2?


#3 2006-04-24 17:35:30

From: Poland
Registered: 2005-10-12
Posts: 352

Re: gphoto2 problem [SOLVED]

Alright, I was using libgphoto2 2.1.99-2. This problem accured there.
After doing today's update, I've noticed that ligphoto was reverted to 2.1.6-6. This fixed the problem with both gphoto2 and digikam.

On the topic of the GP_SYSTEM_IS_FILE error, I've found this useful.


Board footer

Powered by FluxBB