You are not logged in.

#1 2016-03-12 17:03:26

JayDoe
Member
Registered: 2014-09-20
Posts: 27

GDM not starting after exchange of graphic card

Hi,
my Nvidia Geforce broke, so I had to switch to my internal Intel graphic card. I installed the driver xf86-video-intel and replaced the nvidia-libgl / lib32-nvidia-libgl with (lib32-)mesa-libgl.
I removed the Xorg Nvidia configuration and created a new for Intel like it is described in the wiki.
> systemctl status gdm shows, that gdm is running, but with a couple of errors in the log:

gdm[537]: Child process -16483 was already dead.
gdm[537]: Child process -16466 was already dead.
gdm[537]: Unable to kill session worker process
gdm[537]: GdmDisplay: display lasted 0,189795 seconds
gdm[537]: Could not start command '/usr/lib/gdm/gdm-session-worker': Too many open files
gdm[537]: GLib: g_child_watch_add_full: assertion 'pid > 0' failed

During boot, the boot sequence stops at  "Reached target Grapical Interface". The terminal is available.

And idea what to do?

Thanks,
JayDoe

Last edited by JayDoe (2016-03-12 17:13:18)

Offline

#2 2016-03-14 23:50:45

mmarzantowicz
Member
Registered: 2015-12-28
Posts: 32

Re: GDM not starting after exchange of graphic card

Try to disable Wayland for GDM in /etc/gdm/custom.conf:

WaylandEnable=false

Offline

#3 2016-03-15 18:45:15

JayDoe
Member
Registered: 2014-09-20
Posts: 27

Re: GDM not starting after exchange of graphic card

Did not work. I already reinstalled all drivers, xorg, gdm (not gnome), but when I run

$ systemctl start gdm

I just get a blinking cursor. If I try to switch to another tty, I get a blining overlay from the gdm tty, making it very hard to type in anything (but it is possible). I cannot stop gdm with Ctrl+C or so.

Offline

#4 2016-03-15 18:49:02

ugjka
Member
Registered: 2014-04-01
Posts: 1,682

Re: GDM not starting after exchange of graphic card

Disable gdm and try starting gnome manually from your user startx /usr/bin/gnome-session

If it doesn't work check ~/.local/share/xorg/Xorg.0.log

Last edited by ugjka (2016-03-15 18:51:47)

Offline

#5 2016-03-16 20:18:51

JayDoe
Member
Registered: 2014-09-20
Posts: 27

Re: GDM not starting after exchange of graphic card

Hi,
I tried to start gnome by using startx /usr/bin/gnome-session. It fails. But I can see in the log, that no Nvidia drivers are present anymore and the Intel driver i915.ko is loaded (I'm using an Intel i5-2400, so I guess it's fine).

I pasted the logfile:

[    82.994] 
X.Org X Server 1.18.1
Release Date: 2016-02-08
[    82.994] X Protocol Version 11, Revision 0
[    82.994] Build Operating System: Linux 4.2.5-1-ARCH x86_64 
[    82.994] Current Operating System: Linux desktop 4.4.5-1-ARCH #1 SMP PREEMPT Thu Mar 10 07:38:19 CET 2016 x86_64
[    82.994] Kernel command line: 
[    82.995] Build Date: 11 February 2016  09:57:03AM
[    82.996]  
[    82.997] Current version of pixman: 0.34.0
[    82.999] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    82.999] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    83.003] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Mar 16 21:12:05 2016
[    83.004] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    83.005] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    83.006] (==) No Layout section.  Using the first Screen section.
[    83.006] (==) No screen section available. Using defaults.
[    83.006] (**) |-->Screen "Default Screen Section" (0)
[    83.006] (**) |   |-->Monitor "<default monitor>"
[    83.007] (==) No device specified for screen "Default Screen Section".
	Using the first device section listed.
[    83.007] (**) |   |-->Device "Intel Graphics"
[    83.007] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[    83.007] (==) Automatically adding devices
[    83.007] (==) Automatically enabling devices
[    83.007] (==) Automatically adding GPU devices
[    83.007] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    83.008] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    83.008] 	Entry deleted from font path.
[    83.008] 	(Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    83.008] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    83.008] 	Entry deleted from font path.
[    83.008] 	(Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    83.008] (==) FontPath set to:
	/usr/share/fonts/misc/,
	/usr/share/fonts/TTF/,
	/usr/share/fonts/OTF/,
	/usr/share/fonts/Type1/
[    83.008] (==) ModulePath set to "/usr/lib/xorg/modules"
[    83.008] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    83.008] (II) Loader magic: 0x81ad60
[    83.008] (II) Module ABI versions:
[    83.008] 	X.Org ANSI C Emulation: 0.4
[    83.008] 	X.Org Video Driver: 20.0
[    83.008] 	X.Org XInput driver : 22.1
[    83.008] 	X.Org Server Extension : 9.0
[    83.009] (++) using VT number 1

[    83.009] (--) controlling tty is VT number 1, auto-enabling KeepTty
[    83.011] (II) systemd-logind: took control of session /org/freedesktop/login1/session/c1
[    83.013] (--) PCI:*(0:0:2:0) 8086:0102:1043:844d rev 9, Mem @ 0xf7400000/4194304, 0xe0000000/268435456, I/O @ 0x0000f000/64
[    83.013] (II) Open ACPI successful (/var/run/acpid.socket)
[    83.013] (II) LoadModule: "glx"
[    83.014] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    83.017] (II) Module glx: vendor="X.Org Foundation"
[    83.017] 	compiled for 1.18.1, module version = 1.0.0
[    83.017] 	ABI class: X.Org Server Extension, version 9.0
[    83.017] (==) AIGLX enabled
[    83.017] (II) LoadModule: "intel"
[    83.017] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    83.020] (II) Module intel: vendor="X.Org Foundation"
[    83.021] 	compiled for 1.18.1, module version = 2.99.917
[    83.021] 	Module class: X.Org Video Driver
[    83.021] 	ABI class: X.Org Video Driver, version 20.0
[    83.021] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
	i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
	915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
	Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
	GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[    83.021] (II) intel: Driver for Intel(R) HD Graphics: 2000-6000
[    83.021] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100, 6100
[    83.021] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200, 6200, P6300
[    85.037] intel: waited 2020 ms for i915.ko driver to load
[    85.044] (EE) No devices detected.
[    85.044] (EE) 
Fatal server error:
[    85.044] (EE) no screens found(EE) 
[    85.044] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[    85.044] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    85.044] (EE) 

Offline

#6 2016-03-16 23:11:52

DeadMetaler
Member
Registered: 2016-03-16
Posts: 42

Re: GDM not starting after exchange of graphic card

Delete all nvidia packages or try to boot without xorg.conf.

Offline

#7 2016-03-18 07:23:04

JayDoe
Member
Registered: 2014-09-20
Posts: 27

Re: GDM not starting after exchange of graphic card

The nvidia packages are already removed. Booting without xorg.conf didn't work out.

But I found, that the i915 module isn't loaded. modprobe i915 doesn't work...

Offline

#8 2016-03-18 21:31:06

DeadMetaler
Member
Registered: 2016-03-16
Posts: 42

Re: GDM not starting after exchange of graphic card

JayDoe wrote:

The nvidia packages are already removed. Booting without xorg.conf didn't work out.

But I found, that the i915 module isn't loaded. modprobe i915 doesn't work...

Try to boot with "nomodeset" kernel comandline, tnen modprobe -v your module.

Offline

#9 2016-03-19 10:49:35

ugjka
Member
Registered: 2014-04-01
Posts: 1,682

Re: GDM not starting after exchange of graphic card

JayDoe wrote:

The nvidia packages are already removed. Booting without xorg.conf didn't work out.

But I found, that the i915 module isn't loaded. modprobe i915 doesn't work...

Hmm, what do you mean modprobe i915 doesn't work? Did you get an error message? Why not share all the details?

Offline

#10 2016-03-19 16:22:35

JayDoe
Member
Registered: 2014-09-20
Posts: 27

Re: GDM not starting after exchange of graphic card

ugjka wrote:
JayDoe wrote:

The nvidia packages are already removed. Booting without xorg.conf didn't work out.

But I found, that the i915 module isn't loaded. modprobe i915 doesn't work...

Hmm, what do you mean modprobe i915 doesn't work? Did you get an error message? Why not share all the details?


I'm sorry, but without GUI it's sometimes hard for me to paste logs, however, I'll try to provide better informations.

I've got an update: I temporary fixed my NVidia Card by annealing it in my oven. It was an independ decision from this problem, because I don't want to spend so much money for a new card at the moment.

- I installed the fixed card, booted and could get into the terminal without any graphical errors. I installed all NVidia drivers again, removed Intel, but still, the Gnome Desktop didn't run.
- I tried to configure Xorg with the minimal configuration from the wiki as well as with nvidia-xconfíg. No result.
- So I decided to remove and reinstall my complete gnome and gdm installation. Here I could achieve a small success: systemctl start gdm still give's me just a blinking cursor, but running startx /usr/bin/gnome-session finally starts a gnome session.

I turned logging on in /etc/gdm/custom.log

I added Xorg.0.log and journalctl -b /usr/bin/gnome-session


Xorg.0.log http://pastebin.com/MU5KuU2U
gnome-session http://pastebin.com/i77JSfHU

Offline

Board footer

Powered by FluxBB