You are not logged in.

#1 2006-04-30 15:31:33

Registered: 2006-04-30
Posts: 8

dual boot - usb fat32 doesn't mount

I am trying to set up a dual boot using arch linux (2.6.15) and windows xp, with the windows boot loader on the MBR. Two weeks ago I set up my first linux system with redhat this way which worked... now I want to do it with arch linux.

in order to do this after installation I have to boot from cd once more and copy the boot sector onto a fat32 partition so I can have boot.ini point to it.

I mount /dev/hda4 (which is where I put my root) on /mnt/sysimage and chroot to there. then:

I get:
mount /mnt/lacie
/dev/sda1 has wrong device number or fs type vfat not supported
(I tried all sda's that are listed in /dev none work)

trying to mount /dev/sda1 without changing root to /mnt/sysimage but just mounting to /mnt/lacie directly gives the same result

/etc/fstab entry:
/dev/sda1   /mnt/lacie  vfat   umask=000    0    0


dmesg when plugging in external usb drive.
usb 4-2: new full speed USB device using ehci_hcd and address 5

so at least it seems to be detected

I only installed base and no extra modules... do I need to load perhaps ehci_hcd, usb_storage, vfat, or some package and how would I have to do that?

Any help would be greatly appreciated.



#2 2006-04-30 16:18:20

Registered: 2006-04-30
Posts: 8

Re: dual boot - usb fat32 doesn't mount

sorry that I didn't figure this out before posting, but I am new to linux, this is the first time I used modprobe. so here it is:

ehci_hcd 31240 0 -Live 0xe0889000
(among others, but no vfat)

#modprobe vfat
#mount /mnt/lacie
mount: special device /dev/sda1 does not exist

Any tips on how to resolve this


#3 2006-05-01 00:47:43

Registered: 2006-04-30
Posts: 8

Re: dual boot - usb fat32 doesn't mount

I loaded the necessary modules
#modprobe vfat
#modprobe usb-storage

and now dmesg showed that the device was detected as /dev/sda1
fdisk -l also showed it.

however now it said
FAT: codepage cp437 not found
mount: Mounting /dev/sda1 on /mnt/lacie failed Invalid argument

I figure this is because the kernel on cd does not contain nls_cp437 and nls_iso8859_1, which are needed here.

I tried
#modprobe nls_cp437
nls_cp437 not found

What I did was find my installation cd from redhat and reboot that one, which I knew could mount my fat32 drive, and apparantly also works now I have arch linux installed. I mounted it there did
#dd if=/dev/hda3 of=/mnt/lacie/linux.bin bs=512 count=1

and made C:boot.ini point to it, to my boot partition for linux.

After booting from harddisk fortunately everything works fine automatically.

But I do wonder, is it really true that arch-0.7.1 install doesn't allow you to use your vfat partitions during install, just because it doesnt have the module nls_cp437 ?????


Board footer

Powered by FluxBB