You are not logged in.

#1 2016-04-12 11:06:16

Dowefu
Member
Registered: 2014-03-25
Posts: 68

GNOME | Annoying airplane mode

Hi.

I don't understand what the “airplane mode“ is? What's the purpose of it? I try to turn it off using the appropriate switch in the network configuration menu, but after reboot it turns on again. I again turn it off, it turns off and also turns on Bluetooth, so that I have also to turn off Bluetooth. And that's on every boot. How can I completely disable or better remove this sticky thing?

Thanks.

Last edited by Dowefu (2016-04-12 11:14:34)

Offline

#2 2016-04-12 13:10:01

Dowefu
Member
Registered: 2014-03-25
Posts: 68

Re: GNOME | Annoying airplane mode

I've got it. Now, in GNOME 3.20, it's completely broken!

Suppose I have two wireless interfaces on my laptop: Wi-Fi and Bluetooth. If I turn on the Airplane mode, it first: turns off both interfaces, and second: remembers their state, so that, when the next time I turn the mode on, the initial state of the interfaces will be restored.

What we have at present time (legend: before activating → after deactivating):

1. Wi-Fi on, BT on → Wi-Fi on, BT on, OK;

2. Wi-Fi off, BT on → Wi-Fi off, BT on, OK;

3. Wi-Fi on, BT off → Wi-Fi on, BT on, Fail;

4. Wi-Fi off, BT off → Wi-Fi off, BT on, Fail.

Besides that, if the mode itself and both interfaces is “off” (AM “off”, Wi-Fi “off”, BT “off”), after the next boot the mode will be turned on automatically. And then, after manually turning it off, Wi-Fi will be set to “off” but BT will be “on” (ignoring the fact, that it was turned off at the beginning).

Moreover, the sections assigned to these facilities at the top panel's right-side drop-down menu aren't contained in it permanently (allowing controlling the facilities easily), but constantly appear and disappear, following some crazy and obscure logic.

Does this situation exist in Arch Linux only or also in other distributions? What can we do about all that? Is there any way to temporary disable the Airplane mode until it will be repaired?

Last edited by Dowefu (2016-04-12 13:16:14)

Offline

#3 2016-04-12 22:15:10

bulletmark
Member
From: Brisbane, Australia
Registered: 2013-10-22
Posts: 480

Re: GNOME | Annoying airplane mode

Actually, prior to GNOME 3.20, wifi/bluetooth, airplane mode, and the hardware switch could all get out of sync etc for me but GNOME 3.20 has fixed everything on my Dell XPS 13 2015 laptop. Also, if I turn bluetooth off in system settings then turning airplane mode on->off does not turn bluetooth back on like it annoyingly used to. So it may be just related to support for the rfkill switch in your model laptop?

Offline

#4 2016-04-12 23:30:05

brittyazel
Member
From: Davis, CA
Registered: 2013-05-11
Posts: 162

Re: GNOME | Annoying airplane mode

What is the model of your laptop, also do you have rfkill installed?


I don't really know what I'm doing.

Offline

#5 2016-04-13 11:08:07

Dowefu
Member
Registered: 2014-03-25
Posts: 68

Re: GNOME | Annoying airplane mode

Sony Vaio E-series, the 2011 model year. It doesn't have any functional keys to control wireless interfaces.

rfkill wasn't installed on my system. I installed it, but nothing have changed.

To recap, there are three issues with the wireless control:

1. The airplane mode is always “on” after boot, regardless its state before;

2. Bluetooth is always “on” after turning off the airplane mode, regardless its state before;

3. Wi-Fi, Bluetooth and the airplane mode sections don't reside permanently at the top panel's right-side drop-down menu, making it impossible to efficiently control the interfaces.

Last edited by Dowefu (2016-04-13 11:15:32)

Offline

#6 2016-04-15 12:19:55

Dowefu
Member
Registered: 2014-03-25
Posts: 68

Re: GNOME | Annoying airplane mode

Dowefu wrote:

Is there any way to temporary disable the Airplane mode until it will be repaired?

Using the dconf-editor:

/org/gnome/settings-daemon/plugins/rfkill = false

Offline

#7 2016-05-15 13:58:05

halogen
Member
Registered: 2014-06-12
Posts: 52

Re: GNOME | Annoying airplane mode

Same problem here, on a Toshiba Portege. I accidentally enabled the darn thing and now whatever I do it's always on by default on boot. I couldn't find a recent bug report, although there are reports for Fedora at https://bugzilla.redhat.com/show_bug.cgi?id=1187954

Last edited by halogen (2016-05-15 14:04:11)

Offline

#8 2016-05-17 04:36:29

berrykerry789
Member
Registered: 2014-08-02
Posts: 11

Re: GNOME | Annoying airplane mode

Do you have TLP installed by any chance?  Not sure if it's still applicable, but a while back (Gnome 3.16 or 3.14) I was having issues with airplane mode being toggled on every reboot, and I could not figure out what the problem was.  Disabling the NetworkManager service fixed the problem for me and TLP automatically starts NetworkManager.

Offline

Board footer

Powered by FluxBB