You are not logged in.

#1 2016-05-06 18:15:13

WishCow
Member
Registered: 2011-01-31
Posts: 57

[solved] Qemu drops into a UEFI shell instead of booting CDROM

TLDR: Instead of seeing the windows installer at boot, I'm dropped into a UEFI shell. Specs and exact commands at the bottom.

I'm trying to set up a virtualized windows installation with qemu, using VGA passthrough, so I could ditch my dedicated windows partition, and generally have an easier life. I have followed the instructions on the arch wiki:

https://wiki.archlinux.org/index.php/PC … h_via_OVMF

I have used vfio-pci, instead of the old pci-stub method. I'm not using the intel arbiter patch, because if I understand it correctly, that is supposed to be used when you are passing in the same vga that you are using on the host (which is not the case for me).

And I successfully got to the point where I have video out from my nvidia gpu, but it does not want to launch the windows installer, I'm just dropped into a UEFI shell, that looks like this:

http://i.imgur.com/UzK9dDt.png

I have read in the wiki's troubleshooting section that if this happens, make sure you have a valid boot media. Ok, so I tried getting the arch linux installer, and booting that, but that gives me the exact same result, so I'm assuming the problem lies elsewhere.

Anyone know what might be the problem?

Specs:
CPU: Intel i5 2600
VGA on the host: The integrated one in the CPU
VGA sent into the VM: Gigabyte GTX970 (GV-N970IXOC-4GD)

Command I'm using to launch qemu:


sudo qemu-system-x86_64 \
    -enable-kvm \
    -m 4096 \
    -cpu host,kvm=off \
    -vga none \
    -device vfio-pci,host=01:00.0 \
    -drive if=pflash,format=raw,readonly,file=/usr/share/edk2.git/ovmf-x64/OVMF_CODE-pure-efi.fd \
    -drive if=pflash,format=raw,file=/tmp/my_vars.fd \
    -device ide-cd,drive=drive-cd-disk1,id=cd-disk1,unit=0,bus=ide.0 \
    -drive file=/home/wishcow/archlinux.iso,id=drive-cd-disk1,if=none,media=cdrom \
    -boot order=d

Mod note: Please don't embed large images into your posts -- https://wiki.archlinux.org/index.php/Fo … s_and_code -- WorMzy

Last edited by WishCow (2016-05-07 10:56:17)

Offline

#2 2016-05-06 20:40:56

Mika79
Member
Registered: 2016-03-28
Posts: 23

Re: [solved] Qemu drops into a UEFI shell instead of booting CDROM

Type exit at the uefi shell and try if the boot manager gets you where you want.

Offline

#3 2016-05-06 21:39:28

WishCow
Member
Registered: 2011-01-31
Posts: 57

Re: [solved] Qemu drops into a UEFI shell instead of booting CDROM

That works, strange. Am I specifying the image incorrectly on the cli?

Offline

#4 2016-05-06 22:14:29

Mika79
Member
Registered: 2016-03-28
Posts: 23

Re: [solved] Qemu drops into a UEFI shell instead of booting CDROM

No looks good to me. Tho I don't know if it will use the second flash image for efi vars or not, I copied the full uefi image (from ovmf-git from the aur) to the VM dir and have it writeable.
The -boot flags are ignored if you don't use the BIOS.

To get rid of the shell just move your OS up in "Boot Maintenance Manager" -> "Boot Options".

Last edited by Mika79 (2016-05-06 22:39:07)

Offline

#5 2016-05-07 10:56:08

WishCow
Member
Registered: 2011-01-31
Posts: 57

Re: [solved] Qemu drops into a UEFI shell instead of booting CDROM

Hmm, it seems like the problem was that I had no "index" flags specified on the device lines, after specifying them it seems to boot without me manually going to the boot menu.

Thanks!

Offline

Board footer

Powered by FluxBB