You are not logged in.

#1 2016-05-07 00:11:30

Malvineous
Member
From: Brisbane, Australia
Registered: 2011-02-03
Posts: 143
Website

[SOLVED] How to disable single-click to open files in GTK chooser?

Hi all,

Is there a way to tweak the GTK file chooser so that when you click on a file or folder that is already selected, it does NOT open it?  I find this very irritating because half the time I double-click on folders to open them, but sometimes I forget I can't double-click on the first folder in the list.  If I do, the double-click opens the folder on the first click, and selects the first file inside the folder on the second click, which is not what I want.

It would be so much easier if it behaved the same way every time like it used to, and you always double-click to open a folder and select a file, and single clicking never does this.

I'm running the Awesome WM, so is there any way to change this settings when you don't have a control panel GUI like other desktop environments provide?

Last edited by Malvineous (2016-05-07 08:50:25)

Offline

#2 2016-05-07 06:49:03

shulamy
Member
From: israel
Registered: 2010-09-11
Posts: 381

Re: [SOLVED] How to disable single-click to open files in GTK chooser?

there should be  a "file management" settings somewhere in every DM.

in mate  for example it's in "behavior" tab.

ezik

Offline

#3 2016-05-07 08:14:20

Malvineous
Member
From: Brisbane, Australia
Registered: 2011-02-03
Posts: 143
Website

Re: [SOLVED] How to disable single-click to open files in GTK chooser?

AwesomeWM doesn't have any, it's just a plain window manager, so I'm not running a full desktop environment.  So there is presumably a Gnome program to set options like this, but I don't know what it might be!  Any ideas?

Offline

#4 2016-05-07 08:41:43

justasug
Member
Registered: 2014-08-03
Posts: 116

Re: [SOLVED] How to disable single-click to open files in GTK chooser?

I don't think it's possible to change that behaviour via settings.
THESE appear to be all of the options which can be changed for the GTK3 file-chooser via gsettings/dconf-editor. There's nothing about double-click mentioned in there which makes me think that the behaviour is hardcoded into GTK3 itself.

Offline

#5 2016-05-07 08:50:00

Malvineous
Member
From: Brisbane, Australia
Registered: 2011-02-03
Posts: 143
Website

Re: [SOLVED] How to disable single-click to open files in GTK chooser?

Aha, that's what I was looking for!  Shame there's no option for it but at least that answers my question.  Many thanks!  I have logged a GTK+ bug report instead.

Offline

#6 2016-05-07 11:27:39

Thorsten Reinbold
Member
From: Germany
Registered: 2011-12-06
Posts: 315

Re: [SOLVED] How to disable single-click to open files in GTK chooser?

Malvineous wrote:

I have logged a GTK+ bug report instead.

Could you post a link to it? Thanks!

Offline

#7 2016-05-07 12:17:15

Malvineous
Member
From: Brisbane, Australia
Registered: 2011-02-03
Posts: 143
Website

Re: [SOLVED] How to disable single-click to open files in GTK chooser?

Offline

Board footer

Powered by FluxBB