You are not logged in.

#1 2016-05-11 21:30:41

PlqnctoN
Member
From: Lyon, France
Registered: 2015-07-29
Posts: 8

Problem with nvidia_drm and Plymouth

Hi!
I was trying to setup plymouth (I'm using an Nvidia GTX 660Ti w/ proprieritary drivers on X.org) and because I was not able to make it work I checked dmesg to see if there was anything strange and I stumble upon this:

[    3.395729] [drm:nvidia_drm_gem_import_nvkms_memory [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to import NVKMS memory to GEM object
[    3.513488] [drm:nvidia_drm_gem_import_nvkms_memory [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to import NVKMS memory to GEM object
[    3.528433] [drm:nvidia_drm_gem_import_nvkms_memory [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to import NVKMS memory to GEM object
[    3.528709] [drm:nvidia_drm_gem_import_nvkms_memory [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to import NVKMS memory to GEM object
[    3.530202] [drm:nvidia_drm_gem_import_nvkms_memory [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to import NVKMS memory to GEM object
[    3.530514] [drm:nvidia_drm_gem_import_nvkms_memory [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to import NVKMS memory to GEM object
[    3.531435] [drm:nvidia_drm_gem_import_nvkms_memory [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to import NVKMS memory to GEM object
[    3.531723] [drm:nvidia_drm_gem_import_nvkms_memory [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to import NVKMS memory to GEM object

I tried to search on Google to see if anyone had the same problem as me and the only 3 places where people talk about this error message were topic (on reddit, nvidia forums and gentoo forums) talking about plymouth on latest nvidia proprieritary drivers but did not provide a solution working for me. Some of them are talking about launching weston with full parameters but I'm not using weston so I'm in a bit of a dead end.

I'm using GNOME as my DE with GDM, plymouth-git (but plymouth from the repos does not work for me either) with gdm-plymouth and systemd-boot as my loader.

I think that I correctly set up plymouth, here is my mkinitcpio.conf:

# vim:set ft=sh
# MODULES
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES="piix ide_disk reiserfs"
MODULES="nvidia nvidia_modeset nvidia_uvm nvidia_drm"

# BINARIES
# This setting includes any additional binaries a given user may
# wish into the CPIO image.  This is run last, so it may be used to
# override the actual binaries included by a given hook
# BINARIES are dependency parsed, so you may safely ignore libraries
BINARIES=""

# FILES
# This setting is similar to BINARIES above, however, files are added
# as-is and are not parsed in any way.  This is useful for config files.
FILES=""

# HOOKS
# This is the most important setting in this file.  The HOOKS control the
# modules and scripts added to the image, and what happens at boot time.
# Order is important, and it is recommended that you do not change the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
# help on a given hook.
# 'base' is _required_ unless you know precisely what you are doing.
# 'udev' is _required_ in order to automatically load modules
# 'filesystems' is _required_ unless you specify your fs modules in MODULES
# Examples:
##   This setup specifies all modules in the MODULES setting above.
##   No raid, lvm2, or encrypted root is needed.
#    HOOKS="base"
#
##   This setup will autodetect all modules for your system and should
##   work as a sane default
#    HOOKS="base udev autodetect block filesystems"
#
##   This setup will generate a 'full' image which supports most systems.
##   No autodetection is done.
#    HOOKS="base udev block filesystems"
#
##   This setup assembles a pata mdadm array with an encrypted root FS.
##   Note: See 'mkinitcpio -H mdadm' for more information on raid devices.
#    HOOKS="base udev block mdadm encrypt filesystems"
#
##   This setup loads an lvm2 volume group on a usb device.
#    HOOKS="base udev block lvm2 filesystems"
#
##   NOTE: If you have /usr on a separate partition, you MUST include the
#    usr, fsck and shutdown hooks.
HOOKS="base udev plymouth autodetect modconf block filesystems keyboard fsck"

# COMPRESSION
# Use this to compress the initramfs image. By default, gzip compression
# is used. Use 'cat' to create an uncompressed image.
#COMPRESSION="gzip"
#COMPRESSION="bzip2"
#COMPRESSION="lzma"
#COMPRESSION="xz"
#COMPRESSION="lzop"
#COMPRESSION="lz4"

# COMPRESSION_OPTIONS
# Additional options for the compressor
#COMPRESSION_OPTIONS=""

And my systemd-boot entry conf (/boot/loader/entries/arch.conf):

title   Arch Linux
linux   /vmlinuz-linux
initrd  /initramfs-linux.img
options root=UUID=a2fcda58-c4a5-4b14-9583-9ac44cdbc35a rw quiet splash nvidia-drm.modeset=1

At boot I just get a black screen until GDM shows up.

Do you guys know where to look ? Any help is appreciated!

Thanks for taking time to read me.

EDIT: Forget to tell that the Nvidia driver version is 364.19-3.

Last edited by PlqnctoN (2016-05-12 15:19:59)

Offline

#2 2016-05-15 15:28:15

Mixu
Member
Registered: 2012-12-03
Posts: 14

Re: Problem with nvidia_drm and Plymouth

Same here, just wanted to change to Wayland and after removing all framebuffer from grub and kernel there's that error.

Offline

#3 2016-05-20 19:13:31

Strider
Member
From: Belgium
Registered: 2009-08-04
Posts: 90

Re: Problem with nvidia_drm and Plymouth

Also same here. When I login from gdm or from lightdm I just get back to the login screen.
What is strange, is that gdm does not show anymore the option 'gnome on wayland' while lightdm does.


Win XP -> Ubuntu -> Fedora -> Arch -> Arch -> Arch -> Ar...

Offline

#4 2016-06-21 18:27:30

korgull
Member
Registered: 2016-06-21
Posts: 1

Re: Problem with nvidia_drm and Plymouth

Interesting, I received the same errormsg, but after I removed the . in nvidia-drm.modeset=1, no more errormsg. Instead this:

[  +1.302166] NVRM: Your system is not currently configured to drive a VGA conso
[  +0.000002] NVRM: on the primary VGA device. The NVIDIA Linux graphics driver
[  +0.000001] NVRM: requires the use of a text-mode VGA console. Use of other co
[  +0.000001] NVRM: drivers including, but not limited to, vesafb, may result in
[  +0.000001] NVRM: corruption and stability problems, and is not supported.


I wasn't trying to setup plymouth or anything, just checking dmesg.

Last edited by korgull (2016-06-21 18:31:33)

Offline

Board footer

Powered by FluxBB