You are not logged in.

#1 2006-05-08 09:20:58

Arkamririon
Member
From: Germany
Registered: 2005-12-27
Posts: 34

Speedstep-> scaling governor problem

Hello,
I have some trouble with speedstepping on my Laptop.

I installed powernowd and running it with the options "-m 2 -l 50 -u 90"
So the expected behavior is:
1 - Cpuload reaches 90% increases the cpufreq step by step.
2 - Cpuload falls below 50% immediately switch to lowest possible Frequenze.

But this is not what i get. The smallest CPULoad leads to the immediately switch to the maximum frequency. And also there is no Load anylonger it tooks several seconds (20-30 seconds) to switch back to the minimum Frequency. Thats not what I want.

I searched for the reason and I think I found it, but don't know how to solve:
The Powerscaling Daemons like Powernowd neeeds the userspace governor to be able to work, right?
I think this is the problem. The governors are switched automatically on my Laptop. I set to userspace, produce some cpuload and the used governor is automatically switsched to performance  :shock:
Then after some idle time the governor is switched to powersave.
I think this is the reason that powernowd don't work as expected.
Any idea why this happens or better how to solve this problem?

btw:
Speedstepping in general works with no problems. I can manually switch to any frequency supported by my cpu. The acpi daemon is also started.


//edit:
Removed gnome-power-manager and now powernowd works, but not without problems:
It works only for a short period of time (1-5 minutes), then the the cpu freq is set to the maximum end stays there until i set it manually to the minimum. Then powernowd shows for some minutes again the behavior i want. But even if i do nothing after a while cpu freq is again set to maximum and stays there.
Tried to replace powernowd with cpudyn: same effect: works for some minutes as expected, then maximum frequency sad
Its really annoying.

Offline

#2 2006-05-19 12:00:48

patroclo7
Member
From: Bassano del Grappa, ITALY
Registered: 2006-01-11
Posts: 913

Re: Speedstep-> scaling governor problem

Just select the userspace governor as default governor in kernel compilation... If you want to use powernowd to control your speedstepping you do not even need the othe governors, you can safely select "no" in kernel compilation for them.


Mortuus in anima, curam gero cutis

Offline

#3 2006-05-19 12:27:35

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: Speedstep-> scaling governor problem

try manually setting the 'ondemand' governer, it's in kernel based, does exactly what you want, and ought to do it a bit better and easily.

James

Offline

#4 2006-05-19 12:48:21

patroclo7
Member
From: Bassano del Grappa, ITALY
Registered: 2006-01-11
Posts: 913

Re: Speedstep-> scaling governor problem

I guess that you can not do exactly what you want through a kernel governor. In fact, ondemand jumps to the highest speed when under load and decrease step by step afterwards. On the contrary, conservative increases and decreases step by step. If you what you want is to increase step by step and decrease immediately, then you need to resort to  userspace tools.


Mortuus in anima, curam gero cutis

Offline

#5 2006-05-19 13:21:24

Arkamririon
Member
From: Germany
Registered: 2005-12-27
Posts: 34

Re: Speedstep-> scaling governor problem

Exactly. The ondemand governor works, but not in the way i want this.
Its too often and too fast at the maximum frequency -> less battery time, more heat.

The problem is no longer that the userpace governor not stays.
I get the wanted behaviour with powernowd:
On Cpu-Load increasy frequency step by step.
On no Cpu-Load immediately fall back to the minimum frequency.
But this i only get for 30 - 60 seconds.
Also there is no CPU-Load after a short time the frequency automatically changed to the maximum. If this happens and i look for the used governor, its the userpace governor (as expected, the switching governors was caused by the gnome-power-manager I think). The frequency then also stays at the maximum. I watched the Cpu-Load and frequency for 5 minutes and also load was always beetween 0 and 5 % the frequency remains at the maximum.
I had to manually set it to the minimum. Then powernowd works again for some time, till i had to set the frequency manually  back to the minimum. This also happens when using other tools like cpudyn.
My current workaround is a script that sets the cpufrequency to the minimum every 30 sec. Im not happy with this, but it works.

Offline

#6 2006-05-19 13:36:32

patroclo7
Member
From: Bassano del Grappa, ITALY
Registered: 2006-01-11
Posts: 913

Re: Speedstep-> scaling governor problem

Uhm very strange. I prefer userspace tools for similar reasons and powernowd is for me the simplest and most proficient.
Anyway, if you are forced to use kernel governors, conservative is closer to your needs than ondemand, maybe you can try
May be you are interested in this document for a comparison between inkernel and userspace approaches
http://www.intel.com/cd/ids/developer/a … .htm?prn=Y
However, conservative is not discussed here, bt you can find infos on it in the kernel docs.


Mortuus in anima, curam gero cutis

Offline

Board footer

Powered by FluxBB