You are not logged in.

#1 2016-05-26 08:20:35

Hackedia
Member
Registered: 2016-05-12
Posts: 69

[Solved] Wifi dont set up : "Failed to enable P2P Device interface"

Hello everyone ! wink


Im installing Archlinux and try to set up my wifi, but my interface dont want to set UP ! sad
I dont know why but there is a conflict with p2p :

wpa_supplicant -B -i wlp4s0 -c /etc/wpa_supplicant/wpa_supplicant-wlp4s0.conf

Successfully initialized wpa_supplicant
Could not read interface p2p-dev-wlp4s0 flags: No such device
nl80211: Could not set interface 'p2p-dev-wlp4s0' UP
nl80211: deinit ifname=p2p-dev-wlp4s0 disabled_11b_rates=0
p2p-dev-wlp4s0: Failed to initialize device interface
P2P: Failed to enable P2P Device interface

Nothing is noticed in the archlinux's wiki's installation,
I dont found any solution on internet working for me,
I dont know what to do ! Hmm... big_smile

Someone have an idea (even a little ^^) about that ?
Anyway, have a good day ! wink

Last edited by Hackedia (2016-05-30 14:34:19)

Offline

#2 2016-05-26 14:03:09

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,644

Re: [Solved] Wifi dont set up : "Failed to enable P2P Device interface"

Can you please post the output of:
lspci -nn
ip link
and the contents of /etc/wpa_supplicant/wpa_supplicant-wlp4s0.conf with any passphrases redacted.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#3 2016-05-27 10:14:04

Hackedia
Member
Registered: 2016-05-12
Posts: 69

Re: [Solved] Wifi dont set up : "Failed to enable P2P Device interface"

Hi ewaller,


My ip links :

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp5s0f1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN mode DEFAULT group default qlen 1000
    link/ether 80:fa:5b:13:55:a5 brd ff:ff:ff:ff:ff:ff
3: wlp4s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DORMANT group default qlen 1000
    link/ether d8:fc:93:08:93:32 brd ff:ff:ff:ff:ff:ff

lspci -nn :

00:00.0 Host bridge [0600]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor DRAM Controller [8086:0c04] (rev 06)
00:01.0 PCI bridge [0604]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller [8086:0c01] (rev 06)
00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06)
00:03.0 Audio device [0403]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller [8086:0c0c] (rev 06)
00:14.0 USB controller [0c03]: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI [8086:8c31] (rev 05)
00:16.0 Communication controller [0780]: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 [8086:8c3a] (rev 04)
00:1a.0 USB controller [0c03]: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 [8086:8c2d] (rev 05)
00:1b.0 Audio device [0403]: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller [8086:8c20] (rev 05)
00:1c.0 PCI bridge [0604]: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 [8086:8c10] (rev d5)
00:1c.1 PCI bridge [0604]: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #2 [8086:8c12] (rev d5)
00:1c.2 PCI bridge [0604]: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #3 [8086:8c14] (rev d5)
00:1c.3 PCI bridge [0604]: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #4 [8086:8c16] (rev d5)
00:1d.0 USB controller [0c03]: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 [8086:8c26] (rev 05)
00:1f.0 ISA bridge [0601]: Intel Corporation HM86 Express LPC Controller [8086:8c49] (rev 05)
00:1f.2 SATA controller [0106]: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] [8086:8c03] (rev 05)
00:1f.3 SMBus [0c05]: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller [8086:8c22] (rev 05)
01:00.0 3D controller [0302]: NVIDIA Corporation GM107M [GeForce GTX 950M] [10de:139a] (rev a2)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader [10ec:5229] (rev 01)
04:00.0 Network controller [0280]: Intel Corporation Wireless 7260 [8086:08b1] (rev c3)
05:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device [10ec:5287] (rev 01)
05:00.1 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 12)

/etc/wpa_supplicant/wpa_supplicant-wlp4s0.conf :

network={
	ssid="Livebox-6f21"
	psk="Hackedia"
	priority=5
}

Offline

#4 2016-05-27 14:23:31

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,644

Re: [Solved] Wifi dont set up : "Failed to enable P2P Device interface"

That all looks rational. I am puzzled from where it is getting the P2P.   Can you now post the output of systemctl list-unit-files  --type=service | grep enabled


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#5 2016-05-27 16:30:17

Hackedia
Member
Registered: 2016-05-12
Posts: 69

Re: [Solved] Wifi dont set up : "Failed to enable P2P Device interface"

Thanks for your help,

Here is the output of systemctl :

autovt@.service                             enabled 
dbus-org.freedesktop.network1.service       enabled 
dbus-org.freedesktop.NetworkManager.service enabled 
dbus-org.freedesktop.nm-dispatcher.service  enabled 
display-manager.service                     enabled 
gdm.service                                 enabled 
getty@.service                              enabled 
NetworkManager-dispatcher.service           enabled 
NetworkManager.service                      enabled 
systemd-networkd.service                    enabled 
wpa_supplicant@.service                     enabled 

If it can help you, when i plug the ethernet cable (because ethernet work), sometimes i can see the wifi interface up, but in many case he is down, i dont know why, but is the actually DORMANT mode of the wifi interface normal ?

Thanks for all !

Offline

#6 2016-05-27 17:31:06

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,644

Re: [Solved] Wifi dont set up : "Failed to enable P2P Device interface"

Ah.  You are using two different, mutually exclusive tools.   Did you want to use NetworkManager or systemd-networkd?

If NetworkManager, stop and disable systemd-networkd.service and wpa_supplicant@.service.

If systemd-networkd, stop and disable NetworkManager.service and NetworkManager-dispatcher.service and enable and start systemd-resolved.service


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#7 2016-05-30 10:09:01

Hackedia
Member
Registered: 2016-05-12
Posts: 69

Re: [Solved] Wifi dont set up : "Failed to enable P2P Device interface"

I heard about that in a forum, that why i disable networkmanager, but apparently, he is still here ^^.
Is that a pacman -R not enough ?
Anyway "systemctl disable" work ^^.

I think i'll use systemd-networkd, unless you advise me the other !

Thanks for all ewaller !

Last edited by Hackedia (2016-05-30 14:33:20)

Offline

#8 2016-05-30 15:29:54

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,644

Re: [Solved] Wifi dont set up : "Failed to enable P2P Device interface"

Hackedia wrote:

I think i'll use systemd-networkd, unless you advise me the other !

Glad it is worked out.  I actually use systemd-networkd on my own systems and I highly recommend it.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#9 2016-08-30 14:15:06

Hackedia
Member
Registered: 2016-05-12
Posts: 69

Re: [Solved] Wifi dont set up : "Failed to enable P2P Device interface"

Hi !

I came back from vacations, and my internet dont work at all,
Both wifi and ethernet interface dont work !

Ip link show me that my ethernet interface is up but my wifi is down, and a  "ping 8.8.8.8" dont work (Network is unreachable)
However, it worked before, but now nothing work, i checked everything, nothing apperently change, i really dont know where to look hmm

I found nothing on google !
And now im back to the starting point ^^"

Did something like that already happened to someone ?

Last edited by Hackedia (2016-08-30 14:16:20)

Offline

#10 2016-08-30 14:30:00

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,644

Re: [Solved] Wifi dont set up : "Failed to enable P2P Device interface"

Have you an IP address?  What are the output of ip addr  ?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#11 2016-08-30 14:52:48

Hackedia
Member
Registered: 2016-05-12
Posts: 69

Re: [Solved] Wifi dont set up : "Failed to enable P2P Device interface"

Hi Ewaller !

Thanks for helping me again big_smile

As i dont have neither usb nor internet, i'll write the outup by myself ^^" (from old output)

ip addr :
1: lo: <LOOPBACK,MULTICAST,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever

2: enp5s0f1 <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
link/ether 80:fa:5b:13:55:a5 brd ff:ff:ff:ff:ff:ff
inet fe80::82fa:5bff:fe13:55a5/64 scope link
valid_lft forever preferred_lft forever

3: wlp4s0 <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
link/ether d8:fc:93:08:93:32 brd ff:ff:ff:ff:ff:ff

Looks like i dont have ip indeed...
Im working on it on the archlinux wiki ! Thanks !

Last edited by Hackedia (2016-08-30 14:57:29)

Offline

#12 2016-08-30 15:38:31

Hackedia
Member
Registered: 2016-05-12
Posts: 69

Re: [Solved] Wifi dont set up : "Failed to enable P2P Device interface"

So i create udev and iftab files, run dhcpcd for my both interface,
It work for my ethernet interface, but not for my wifi interface because he is not up (no carrier), and he dont want to stand up at all ^^"
(I only use wifi cause there is no ethernet plug in in my school)

Do you have any idea about it ?

Offline

Board footer

Powered by FluxBB