You are not logged in.

#1 2006-05-10 03:28:27

munkymonk
Member
Registered: 2006-05-10
Posts: 8

this is the noob question of the week regarding gdm

I am no linux noob per se. but i did something really really stupid just now.

started with a fresh install of arch, added e17 and gdm.

wait...did i forget something? but of course! create a non-root user. so anywho. now gdm is installed and comes up automatically on boot.

the problem: i have only a root user as of right now and gdm does not allow root logins by default. pressing ALT+CTRL+BACKSPACE quits gdm alright, but it just keeps restarting and restarting. doing killall gdm also fails to do the trick.

so pretty much... i can't log in. of course i need to create a nonroot user, but first i must figure out how to kill gdm so i have room to work.

i am thinking running a livecd (gentoo maybe?) and then chroot and edit the rc.conf so gdm does not come on automatically. then reboot into arch, create user, edit rc.conf to start gdm once again. reboot once again and login with user, but i am sure there is a less drastic measure out there somewhere i can take.


PS: i installed madwifi-ng from svn just fine, but i cant seem to find wireless-tools (at least pacman doesn't install it)... and i kinda need them, how do i go about setting them up?

and why am i using gdm when i can be using entrance? hell. you got me there. i really dont know.

Offline

#2 2006-05-10 03:40:44

McQueen
Member
From: Arizona
Registered: 2006-03-20
Posts: 382

Re: this is the noob question of the week regarding gdm

munkymonk wrote:

the problem: i have only a root user as of right now and gdm does not allow root logins by default.

You can set gdm from the main screen to accept a root login by going to the configure options. The exact heading it is under will depend upon the gdm style you are using (usually under the "Actions" category). It will require your root pass to access but after that just goto the appropriate tab and tick where needed. Also, you can Alt + Ctrl + F1 to exit X and get to a command prompt where you can set up your user as desired.


/path/to/Truth

Offline

#3 2006-05-10 03:43:48

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: this is the noob question of the week regarding gdm

At the gdm screen, use Ctrl+Alt+F1 to swith to a console. Log in as root and create a user account.
BTW, better stick with gdm for now. The entrance package in the community repo is currently broken. I'm working on updating/fixing it.

Offline

#4 2006-05-10 15:01:38

sh__
Member
Registered: 2005-07-19
Posts: 271

Re: this is the noob question of the week regarding gdm

munkymonk wrote:

PS: i installed madwifi-ng from svn just fine, but i cant seem to find wireless-tools (at least pacman doesn't install it)... and i kinda need them, how do i go about setting them up?

The package name is "wireless_tools".

Offline

#5 2006-05-16 06:06:50

ScriptDevil
Member
From: In Front of My PC
Registered: 2006-04-06
Posts: 253

Re: this is the noob question of the week regarding gdm

fi this is gdm, there is an option in configure gdm,it allows u to enter ur root password. Then in one of th tabs there is a check box for allow root (local system admistraitor) login.Check it


Be yourself, because you are all that you can be

Offline

Board footer

Powered by FluxBB