You are not logged in.

#1 2016-06-05 20:38:06

George Mpouras
Member
Registered: 2016-06-05
Posts: 6

[Solved] perl 5.24

with the last pacman -Syu (2016 06 05) , Perl upgraded to 5.24 but from this time almost all the modules stop working
e.g.

    perl -e "use Dancer2"
    cpanm

with the message

    Cwd.c: loadable library and perl binaries are mismatched (got handshake key 0xdb00080, needed 0xdb80080

Please help because all my work is based on Perl
Thanks,
George

Last edited by George Mpouras (2016-06-06 07:52:51)

Offline

#2 2016-06-05 20:54:54

mcmillan
Member
Registered: 2006-04-06
Posts: 733

Re: [Solved] perl 5.24

I'm assuming modules were installed via cpan or aur? If so they'll need to be rebuilt for the new version. The arch-dev mailing list had some more detailed direction, and a script to help identify what needs rebuilding
https://lists.archlinux.org/pipermail/a … 28034.html

Offline

#3 2016-06-05 21:23:06

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,149
Website

Re: [Solved] perl 5.24

To add to what mcmillan said: anything you installed that pacman does not know about is your responsibility, not pacman's.


Moving to NC.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#4 2016-06-05 22:42:33

George Mpouras
Member
Registered: 2016-06-05
Posts: 6

Re: [Solved] perl 5.24

Thanks for your help mcmillan
I make the exercise with scripts
    https://git.server-speed.net/users/flo/ … ackages.sh
    https://git.server-speed.net/users/flo/ … to-dist.pl
But unfortunately it was a dead end
After you told me what was wrong I fix it with the following commands

perl -E 'map {say $_} @INC'

rm -rf /usr/lib/perl5/core_perl/*
rm -rf /usr/share/perl5/core_perl/*
rm -rf /usr/lib/perl5/site_perl/*
rm -rf /usr/share/perl5/site_perl/*
rm -rf /usr/lib/perl5/vendor_perl/*
rm -rf /usr/share/perl5/vendor_perl/*

pacman -R perl-cpan-meta
pacman -R perl-extutils-installpaths
pacman -R perl-extutils-depends
pacman -R perl-extutils-pkgconfig
pacman -R perl-extutils-config
pacman -R perl-extutils-helpers
pacman -R perl-extutils-installpaths
pacman -R perl-extutils-xsbuilder
pacman -R perl-json perl-mime-base32
pacman -R cpanminus

pacman -S --force perl imagemagick

pacman -S perl-cpan-meta
pacman -S perl-extutils-installpaths
pacman -S perl-extutils-depends
pacman -S perl-extutils-pkgconfig
pacman -S perl-extutils-config
pacman -S perl-extutils-helpers
pacman -S perl-extutils-installpaths
pacman -S perl-extutils-xsbuilder
pacman -S perl-json perl-mime-base32
pacman -S cpanminus


the Scope::Upper can not be saved , but that is a detail


George Mpouras

Offline

#5 2016-06-06 02:55:16

mcmillan
Member
Registered: 2006-04-06
Posts: 733

Re: [Solved] perl 5.24

If you've dealt with the problem, you can edit your first post to change the thread title to include [solved]

Offline

#6 2016-06-08 19:57:44

Corwin
Member
Registered: 2016-06-08
Posts: 2

Re: [Solved] perl 5.24

I'm getting this error also, but I'm trying to run Chromium after running pacman -Suy:

╭─user@machine /home 
╰─➤  chromium
Cwd.c: loadable library and perl binaries are mismatched (got handshake key 0xdb00080, needed 0xdb80080)

I went through these commands but then also needed: pacman -S perl-file-basedir

Last edited by Corwin (2016-06-08 20:06:12)

Offline

#7 2016-06-09 21:12:14

silur
Member
Registered: 2016-06-09
Posts: 1

Re: [Solved] perl 5.24

same error in perl IO module what is not a cpan module, I don't even have cpan configured in my environment. The real problem is that the most basic tasks like autoconf/automake and simple scripts that use IO broke.
IO.c: loadable library and perl binaries are mismatched (got handshake key 0xdb00080, needed 0xdb80080)

Last edited by silur (2016-06-09 21:12:37)

Offline

#8 2016-06-11 11:19:53

bijanbina
Member
From: Tehran
Registered: 2014-07-13
Posts: 19
Website

Re: [Solved] perl 5.24

got same error with automake after upgrade. As George Mpouras said, removing perl files and install it again using pacman solve the problem.

rm -rf /usr/share/perl5/core_perl/*
rm -rf /usr/lib/perl5/site_perl/*
rm -rf /usr/share/perl5/site_perl/*
rm -rf /usr/lib/perl5/vendor_perl/*
rm -rf /usr/share/perl5/vendor_perl/*
pacman -S --force perl imagemagick

Last edited by bijanbina (2016-06-11 11:20:35)

Offline

#9 2016-06-12 02:45:40

itoffshore
Member
Registered: 2016-06-12
Posts: 3

Re: [Solved] perl 5.24

Offline

#10 2016-06-13 08:42:31

ThomasG
Member
Registered: 2011-05-16
Posts: 4

Re: [Solved] perl 5.24

OK, that was somewhat annoying.

"Just rebuild the modules" is of course a valid strategy, but when "perl Makefile.pl", and thus rebuilding the modules itself doesn't work anymore it's somewhat hard to do.

Deleting everything in site_perl and vendor_perl and re-installing all perl modules from scratch worked, but perhaps a warning on the front page might be in order?

Offline

#11 2016-06-13 10:26:38

stounloon
Member
Registered: 2015-01-03
Posts: 2

Re: [Solved] perl 5.24

ThomasG wrote:

"Just rebuild the modules" is of course a valid strategy, but when "perl Makefile.pl", and thus rebuilding the modules itself doesn't work anymore it's somewhat hard to do.

Deleting everything in site_perl and vendor_perl and re-installing all perl modules from scratch worked, but perhaps a warning on the front page might be in order?


This was the situation I found myself in, removing the contents of site_perl to a holding directory solved the issue for me - I haven't noticed any ill effects on my system so far.

I only had one module installed via cpan, which I no longer use.

Offline

#12 2016-06-13 10:31:41

itoffshore
Member
Registered: 2016-06-12
Posts: 3

Re: [Solved] perl 5.24

Deleting the modules fixed it for me too on pacmanager-bin but it also broke pango & few other things required to build the perl modules in PAC.

Deleting the modules manually also broke perl-xml-parser which was required by libintl to build virt-viewer.

Next time I will use the scripts to just rebuild the installed perl modules.

Last edited by itoffshore (2016-06-13 20:13:21)

Offline

#13 2016-06-13 18:09:23

rel
Member
Registered: 2016-06-13
Posts: 2

Re: [Solved] perl 5.24

Same perl problem here after the last upgrade, when using automake/autoconf:

$ aclocal
threads.c: loadable library and perl binaries are mismatched (got handshake key 0xdb00080, needed 0xdb80080)

Is there really no other way, than removing those perl modules manually? I've installed/built quite many perl packages with yaourt from AUR repos...

Last edited by rel (2016-06-13 18:10:41)

Offline

#14 2016-07-03 13:49:27

rel
Member
Registered: 2016-06-13
Posts: 2

Re: [Solved] perl 5.24

A short update on this problem:
I solved it by manually uninstalling / reinstalling all required perl packages. I did not delete any files manually! This was important to me...

In my case, I had problems with slic3r (3d printing slicing tool). So that's about what I had to do (the actual order may be different, and this list of packages inclomplete, some packages can also be deleted with '-Rns' to remove dependencies automatically but I wanted to keep track of all the packages myself):

$ pactree -u slic3r | grep perl
perl
perl-moo
perl-class-method-modifiers
perl-devel-globaldestruction
perl-sub-exporter
perl-data-optlist
perl-params-util
perl-sub-install
perl-sub-exporter-progressive
perl-import-into
perl-module-runtime
perl-module-build
perl-inc-latest
perl-role-tiny
perl-math-clipper
perl-extutils-typemaps-default
perl-test-deep
perl-test-nowarnings
perl-test-tester
perl-module-build-withxspp
perl-extutils-cppguess
perl-capture-tiny
perl-extutils-xspp
perl-math-convexhull
perl-math-geometry-voronoi
perl-params-validate
perl-module-implementation
perl-try-tiny
perl-class-accessor
perl-math-planepath
perl-constant-defer
perl-math-libm
perl-math-convexhull-monotonechain
perl-io-stringy
perl-encode-locale
perl-extutils-makemaker-aur
perl-threads-aur

$ yaourt -R slic3r

$ yaourt -R perl-encode-locale
$ yaourt -R perl-extutils-makemaker-aur
$ yaourt -R perl-extutils-parsexs-aur
$ yaourt -R perl-extutils-typemap
$ yaourt -R perl-io-stringy 
$ yaourt -R perl-math-clipper
$ yaourt -R perl-math-convexhull
$ yaourt -R perl-math-convexhull-monotonechain
$ yaourt -R perl-math-geometry-voronoi 
$ yaourt -R perl-math-planepath
$ yaourt -R perl-moo
$ yaourt -R perl-threads-aur 


$ yaourt -R perl-class-accessor
$ yaourt -R perl-extutils-typemaps-default
$ yaourt -R perl-module-build-withxspp
$ yaourt -R perl-params-validate
$ yaourt -R perl-test-deep 

$ yaourt -R perl-wx-glcanvas
$ yaourt -R perl-wx
$ yaourt -R perl-opengl

After that, I reinstalled everything, and it luckily worked again!

Last edited by rel (2016-07-03 13:53:19)

Offline

#15 2017-08-11 12:38:06

avn
Member
Registered: 2017-03-15
Posts: 1

Re: [Solved] perl 5.24

bijanbina wrote:

got same error with automake after upgrade. As George Mpouras said, removing perl files and install it again using pacman solve the problem.

rm -rf /usr/share/perl5/core_perl/*
rm -rf /usr/lib/perl5/site_perl/*
rm -rf /usr/share/perl5/site_perl/*
rm -rf /usr/lib/perl5/vendor_perl/*
rm -rf /usr/share/perl5/vendor_perl/*
pacman -S --force perl imagemagick

Same problem (perl broken - see https://forum.manjaro.org/t/perl-seriou … ken/29005) here. This seems to have solved it for me...

Offline

#16 2017-08-11 12:50:03

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 11,861

Re: [Solved] perl 5.24

Glad to know this helped you, however be aware that you shouldn't necrobump a topic this old and should you ever have any support issues, that can't be solved by reading existing threads, that they should be made to the Manjaro boards, as we only support Arch.

https://wiki.archlinux.org/index.php/Co … bumping.22
https://wiki.archlinux.org/index.php/Co … .2Aonly.2A

Closing this old topic.

Offline

Board footer

Powered by FluxBB